policyui.py crashed with NameError in setVirtual()

Bug #269757 reported by Typhoe on 2008-09-13
6
Affects Status Importance Assigned to Milestone
screen-resolution-extra (Ubuntu)
High
Scott Kitterman

Bug Description

Binary package hint: screen-resolution-extra

Hi,

with the latest screen-resolution-extra (0.1.1), I still have the same problem I had when pressing "yes" to confirm that I want to set a virtual display.

I get a crash, and gnome-display-properties is freezed. If I check the process, I see a line:
typhoe 7571 1 0 11:23 ? 00:00:00 gnome-display-properties
typhoe 7572 7571 0 11:23 ? 00:00:00 python /usr/share/screen-resolution-extra/policyui.py -1,-1:-1x-1 1680,0:1920x1200 0,0:1680x1050
Killing the policyui.py line let me unfreeze/close gnome-display-properties

My notebook screen is a 1680x1050 display, and my extended one is a 1920x1200 (VGA connected).

Trying to invoke the policyui.py line in the command line terminal gives me:
python /usr/share/screen-resolution-extra/policyui.py -1,-1:-1x-1 1680,0:1920x1200 0,0:1680x1050
Traceback (most recent call last):
  File "/usr/share/screen-resolution-extra/policyui.py", line 190, in on_button1_clicked
    status = self.conf.setVirtual(self.resolution)
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/var/lib/python-support/python2.5/dbus/connection.py", line 607, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.NameError: Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/dbus/service.py", line 696, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/screen-resolution-extra/screenresolution-mechanism.py", line 265, in setVirtual
    except(IOError, XKit.xorgparser.ParseException):#if xorg.conf is missing or broken
NameError: global name 'XKit' is not defined

regards,
Typhoe

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/share/screen-resolution-extra/policyui.py
InterpreterPath: /usr/bin/python2.5
Package: screen-resolution-extra 0.1.1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: python /usr/share/screen-resolution-extra/policyui.py -1,-1:-1x-1 1680,0:1920x1200 0,0:1680x1050
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/screen-resolution-extra/policyui.py', '-1,-1:-1x-1', '1680,0:1920x1200', '0,0:1680x1050']
SourcePackage: screen-resolution-extra
Title: policyui.py crashed with NameError in setVirtual()
Uname: Linux 2.6.27-3-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare vboxusers

Typhoe (spamistrash) wrote :
Typhoe (spamistrash) wrote :

That bug is NOT RESOLVED by the fix released for LB #262906.
https://bugs.launchpad.net/ubuntu/+source/screen-resolution-extra/+bug/262906

It could be the same I previously reported as LB #263682
https://bugs.launchpad.net/ubuntu/+source/screen-resolution-extra/+bug/263682
which was marked as duplicate of bug #262906

James Westby (james-w) wrote :

Hi,

This is a different bug to the one that is marked fixed.

I can see the problem here though, so I will prepare a new
fix.

Thanks,

James

Changed in screen-resolution-extra:
importance: Undecided → High
status: New → Confirmed
James Westby (james-w) wrote :
James Westby (james-w) wrote :

Hi,

The fix is in my branch attached to the report

  ~james-w/screen-resolution-extra/intrepid

or in the diff in the last comment. Please sponsor
it in to Intrepid.

Thanks,

James

Changed in screen-resolution-extra:
assignee: nobody → kitterman
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

Uploaded based on the diff. I did change the version to 0.1.2. Typically for Native packages not in Debian we don't add the ubuntu1 revision. This also follows the pattern of the previous upload so I assume the dch default behavior just slipped by your review.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package screen-resolution-extra - 0.1.2

---------------
screen-resolution-extra (0.1.2) intrepid; urgency=low

  * Don't try and use XKit, as it hasn't been imported. Instead import
    xorgparser from it and use that instead. (LP: #269757)

 -- James Westby <email address hidden> Sat, 13 Sep 2008 12:38:51 +0100

Changed in screen-resolution-extra:
status: In Progress → Fix Released
Typhoe (spamistrash) wrote :

Hi,

I can confirm it doesn't crash anymore.

That issue is resolved.

But now I have a different problem (I made a new LP bug #270980):
My main notebook display is 1680x1050 and my secondary display is 1920x1200

The virtual setting in the xorg.conf file is set to 3360x1050 (1680*2 x 1050)...
Should be something like (1680+1920)x max(1050,1200) => 3600x1200 , shouldn't it?

Regards,
Typhoe

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers