screenresolution-mechanism.py crashed with ImportError in __main__: No module named XKit

Bug #1012774 reported by rpanman on 2012-06-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
screen-resolution-extra (Ubuntu)
High
Alberto Milone
Quantal
High
Alberto Milone
x-kit (Ubuntu)
High
Alberto Milone
Quantal
High
Alberto Milone

Bug Description

Description: Ubuntu quantal (development branch)
Release: 12.10

#lsmod:
Module Size Used by
autofs4 73208 1
xt_tcpudp 13384 48
ip6table_mangle 13401 0
iptable_nat 15183 1
nf_nat 48186 1 iptable_nat
nf_conntrack_ipv4 26640 16 iptable_nat,nf_nat
nf_defrag_ipv4 13428 1 nf_conntrack_ipv4
xt_TCPMSS 13716 2
xt_LOG 27308 45
ipt_REJECT 13330 0
iptable_mangle 13384 0
xt_multiport 13424 0
xt_state 13095 13
xt_limit 13728 46
xt_conntrack 14449 0
nf_conntrack_ftp 18924 0
nf_conntrack 167806 6 iptable_nat,nf_nat,nf_conntrack_ipv4,xt_state,xt_conntrack,nf_conntrack_ftp
ip6table_filter 13420 1
ip6_tables 54582 2 ip6table_mangle,ip6table_filter
iptable_filter 13405 1
ip_tables 45963 3 iptable_nat,iptable_mangle,iptable_filter
x_tables 52819 15 xt_tcpudp,ip6table_mangle,iptable_nat,xt_TCPMSS,xt_LOG,ipt_REJECT,iptable_mangle,xt_multiport,xt_state,xt_limit,xt_conntrack,ip6table_filter,ip6_tables,iptable_filter,ip_tables
parport_pc 71127 0
ppdev 22794 0
nfsd 581719 2
nfs 799449 0
lockd 176461 2 nfsd,nfs
fscache 127638 1 nfs
auth_rpcgss 103837 2 nfsd,nfs
nfs_acl 13582 2 nfsd,nfs
sunrpc 513294 6 nfsd,nfs,lockd,auth_rpcgss,nfs_acl
ext2 167093 1
dm_crypt 46955 1
snd_hda_codec_realtek 138964 1
nvidia 12448208 30
snd_hda_intel 67557 1
snd_hda_codec 256615 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 24819 1 snd_hda_codec
snd_pcm 206956 2 snd_hda_intel,snd_hda_codec
coretemp 25008 0
snd_seq_midi 23381 0
snd_rawmidi 58043 1 snd_seq_midi
snd_seq_midi_event 21821 1 snd_seq_midi
kvm_intel 223576 0
kvm 860029 1 kvm_intel
snd_seq 147881 2 snd_seq_midi,snd_seq_midi_event
snd_timer 62042 2 snd_pcm,snd_seq
snd_seq_device 20992 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 174686 11 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
hid_generic 12774 0
tpm_infineon 23921 0
i7core_edac 46723 0
edac_core 105548 3 i7core_edac
hp_wmi 24837 0
sparse_keymap 15579 1 hp_wmi
soundcore 17446 1 snd
tpm_tis 26122 0
mei 89392 0
mac_hid 14852 0
snd_page_alloc 29778 2 snd_hda_intel,snd_pcm
lpc_ich 22609 0
psmouse 195452 0
serio_raw 24163 0
microcode 32491 0
wmi 26207 1 hp_wmi
lp 24302 0
parport 80461 3 parport_pc,ppdev,lp
usbhid 100852 0
hid 158103 2 hid_generic,usbhid
e1000e 436903 0

$ lspci -k
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
 Subsystem: Hewlett-Packard Company Device 304b
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
 Kernel driver in use: pcieport
 Kernel modules: shpchp
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
 Subsystem: Device 003c:004b
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
 Subsystem: Device 003c:004b
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
 Subsystem: Device 003c:004b
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
 Subsystem: Device 003c:004b
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
 Subsystem: Device 003c:004b
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
 Subsystem: Device 003c:004b
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel modules: mei
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: serial
00:19.0 Ethernet controller: Intel Corporation 82578DM Gigabit Network Connection (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: e1000e
 Kernel modules: e1000e
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: ehci_hcd
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: snd_hda_intel
 Kernel modules: snd-hda-intel
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
 Kernel driver in use: pcieport
 Kernel modules: shpchp
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
 Kernel driver in use: pcieport
 Kernel modules: shpchp
00:1c.6 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 7 (rev 05)
 Kernel driver in use: pcieport
 Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation 5 Series Chipset LPC Interface Controller (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: lpc_ich
 Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: ahci
01:00.0 VGA compatible controller: NVIDIA Corporation G86 [Quadro NVS 290] (rev a1)
 Subsystem: NVIDIA Corporation Device 0492
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current_updates, nvidia_current, nouveau, nvidiafb
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
 Kernel driver in use: i7core_edac
 Kernel modules: i7core_edac
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b
3f:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)
 Subsystem: Hewlett-Packard Company Device 304b

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: screen-resolution-extra 0.14ubuntu3
Uname: Linux 3.5.0-999-i7 x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Tue Jun 12 15:06:47 2012
ExecutablePath: /usr/share/screen-resolution-extra/screenresolution-mechanism.py
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120608)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/screen-resolution-extra/screenresolution-mechanism.py
ProcEnviron:

PythonArgs: ['/usr/share/screen-resolution-extra/screenresolution-mechanism.py']
SourcePackage: screen-resolution-extra
Title: screenresolution-mechanism.py crashed with ImportError in __main__: No module named XKit
Traceback:
 Traceback (most recent call last):
   File "/usr/share/screen-resolution-extra/screenresolution-mechanism.py", line 31, in <module>
     from XKit import xutils, xorgparser
 ImportError: No module named XKit
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

rpanman (rpanman-2000) wrote :
tags: added: lubuntu
rpanman (rpanman-2000) wrote :

trying to install xutils now to see if that resolves it.

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in screen-resolution-extra (Ubuntu):
status: New → Confirmed
Pete Graner (pgraner) on 2012-07-10
visibility: private → public
Sebastien Bacher (seb128) wrote :

could you run "python -c "import XKit"", does it work? what version of python-xkit is installed?

Changed in screen-resolution-extra (Ubuntu):
importance: Undecided → High
Changed in x-kit (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
Sebastien Bacher (seb128) wrote :

Ok, confirmed, the 0.5 x-kit update renamed XKit->xkit, if compatibility was broken the package should be renamed or use Breaks on all unported clients, or compatibility must be restored

Changed in screen-resolution-extra (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → Triaged
Changed in screen-resolution-extra (Ubuntu Quantal):
status: Triaged → In Progress
Changed in x-kit (Ubuntu Quantal):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package screen-resolution-extra - 0.15

---------------
screen-resolution-extra (0.15) quantal; urgency=low

  * Add support for python 3.
  * Migrate to python-gi.
  * Fix issue with the new XKit API (LP: #1012774).
  * Drop obsolete code for the DontZap option.
 -- Alberto Milone <email address hidden> Thu, 12 Jul 2012 18:58:36 +0200

Changed in screen-resolution-extra (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers