package screen-profiles 1.44-0ubuntu1.1 failed to install/upgrade: il sottoprocesso pre-installation script ha restituito un codice di errore 2

Bug #391105 reported by crisandbea on 2009-06-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Dustin Kirkland 
screen-profiles (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: screen-profiles

E: /var/cache/apt/archives/screen-profiles_1.44-0ubuntu1.2_all.deb: il sottoprocesso pre-installation script ha restituito un codice di errore 2

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: il sottoprocesso pre-installation script ha restituito un codice di errore 2
NonfreeKernelModules: nvidia
Package: screen-profiles 1.44-0ubuntu1.1
PackageArchitecture: all
SourcePackage: screen-profiles
Title: package screen-profiles 1.44-0ubuntu1.1 failed to install/upgrade: il sottoprocesso pre-installation script ha restituito un codice di errore 2
Uname: Linux 2.6.28-13-generic i686

Related branches

crisandbea (crisandbea) wrote :
Dustin Kirkland  (kirkland) wrote :

moving from screen-profiles -> byobu

Changed in screen-profiles (Ubuntu):
status: New → Won't Fix
Changed in byobu (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Can you explain in english what you're trying to do, and what these error messages mean?

:-Dustin

Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → High

Sorry,

when I try to update screen-profiles,
I get the following error: the subprocess pre-installation script
returned an error code 2.

Regards,
Cristian

Dustin Kirkland ha scritto:
> Can you explain in english what you're trying to do, and what these
> error messages mean?
>
> :-Dustin
>

--
---------------------------------------------------
Cristian

e-mail: <email address hidden>

www.romeo-bosco.com

A volte basta un attimo per scordare una vita,
ma a volte non basta una vita per scordare un attimo.
     [Jim Morrison]
----------------------------------------------------

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 2.16-0ubuntu1

---------------
byobu (2.16-0ubuntu1) karmic; urgency=low

  * byobu-config, doc/help.txt: update the verbage of some text
  * byobu-config, byobu-janitor, byobu-select-profile, debian/install,
    debian/rules, po/POTFILES.sh, rpm/byobu.spec: rename select-screen-profile
    to byobu-select-profile; fits our namespace better
  * byobu-config, byobu-launcher, byobu-launcher-install,
    byobu-launcher-uninstall, debian/install, debian/rules,
    rpm/byobu.spec: rename to byobu-launcher*

  Fixes for: LP: #391105, #390405, #391039
  * debian/control: add screen-profiles and screen-profiles-extras
    transitional packages
  * debian/postinst, debian/prerm, debian/rules: fix screen-profiles ->
    byobu upgrades; drop byobu's attempt to remove the dpkg-divert on
    /usr/bin/screen, as this fails; establish links in the postinst,
    remove in the prerm
  * debian/screen-profiles.postinst: remove the diversion on *installation*
    of this transitional package

 -- Dustin Kirkland <email address hidden> Tue, 23 Jun 2009 14:47:10 -0500

Changed in byobu (Ubuntu):
status: In Progress → Fix Released

Are you experiencing this issue in Jaunty or Karmic?

Do you have any PPA's enabled?

cat /etc/apt-sources.list

:-Dustin

Download full text (3.5 KiB)

I used Jaunty,
this is my /etc/apt/sources.list
---
#deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090421.3)]/
jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ppa.launchpad.net/gijzelaar/opencv/ubuntu jaunty main

deb http://it.archive.ubuntu.com/ubuntu/ jaunty main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ jaunty universe
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty universe
deb http://it.archive.ubuntu.com/ubuntu/ jaunty-updates universe
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ jaunty multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty multiverse
deb http://it.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://it.archive.ubuntu.com/ubuntu/ jaunty-backports main
restricted universe multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ jaunty-backports main
restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
# deb-src http://archive.canonical.com/ubuntu jaunty partner

deb http://security.ubuntu.com/ubuntu jaunty-security main restricted
deb-src http://security.ubuntu.com/ubuntu jaunty-security main restricted
deb http://security.ubuntu.com/ubuntu jaunty-security universe
deb-src http://security.ubuntu.com/ubuntu jaunty-security universe
deb http://security.ubuntu.com/ubuntu jaunty-security multiverse
deb-src http://security.ubuntu.com/ubuntu jaunty-security multiverse
-

Dustin Kirkland ha scritto:
> Are you experiencing this issue in Jaunty or Karmic?
>
> Do you have any PP...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers