Input problems in Kate save file dialog

Bug #94310 reported by erzhong
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

Binary package hint: kate

When I open kate first time, and try to save the new file to a directory that is different from the initial directory, I cannot enter the file name in the savefile dialog. I type the file name, but nothing appears in the dialogo. I have to creat an empty file in the desired directory and then overwrite the empty file. If I open kate first time, save the file to the initial directory, it works fine.

I am using Kubuntu 6.10.
My laptop is a IBM T42.

Revision history for this message
Marco Maini (maini10) wrote :

Sorry, I don't understand your problem. Does it happen when you try to open with Kate an existent file or when you open Kate to create a new file? And what is the directory that don't allow you to save? Thanks for your collaboration.

Changed in kdebase:
assignee: nobody → maini10
status: Unconfirmed → Needs Info
Revision history for this message
erzhong (gnulinuxfun) wrote : Re: [Bug 94310] Re: Cannot save file when kate is opened for the first time.

It happens when I create a new file and try to save it. The problem is very strange:
If I use Ctrl+s to save the file, I cannot type anything into 'location' (filename). But if I press return once, just before using the save command in the file menu, I can type the file name into 'location'. If I did not press return just before using save from file menu, I cannot type anything into 'location'.

Maini Marco <email address hidden> wrote: Sorry, I don't understand your problem. Does it happen when you try to
open with Kate an existent file or when you open Kate to create a new
file? And what is the directory that don't allow you to save? Thanks for
your collaboration.

** Changed in: kdebase (Ubuntu)
     Assignee: (unassigned) => Maini Marco
       Status: Unconfirmed => Needs Info

--
Cannot save file when kate is opened for the first time.
https://bugs.launchpad.net/bugs/94310
You received this bug notification because you are a direct subscriber
of the bug.

---------------------------------
Ahhh...imagining that irresistible "new car" smell?
 Check outnew cars at Yahoo! Autos.

Revision history for this message
Marco Maini (maini10) wrote : Re: Cannot save file when kate is opened for the first time.

Thanks for your collaboration.
We need more information about your version of KDE and Kate used. You can find this with command dpkg -l kate. Before of this a full update could be useful to avoid that bug was fixed yet.
Please do further a test with other application of KDE (e.g. Konqueror) and non KDE (e.g Firefox, Openoffice ... ) and post your results.
Thanks in advance.

Revision history for this message
SimSQ (daniel-ssq89) wrote :

I can reproduce this on kate 3.5.6-ubuntu02.

I thought the net result was pretty much like #92932. The keyboard input is suddenly suspended, and both were triggered by keyboard (for me at least). The two might be related.

Revision history for this message
SimSQ (daniel-ssq89) wrote :

I was using SCIM (1.4.4-7ubuntu1) on XIM. (This is set in my environment)

Turning it off seems to resolve this problem, but is definitely not desirable.

and erzhong is Chinese too? Are you using SCIM?

This might be a SCIM problem because with fcitx everything works fine.

Revision history for this message
Marco Maini (maini10) wrote :

Thanks for assigning this report to skim package.

Revision history for this message
SimSQ (daniel-ssq89) wrote :

I was using SCIM on XIM. Thus it should be the scim package. (in fact... I'm not even sure how to get the special build of Qt that supports input modules.)

Revision history for this message
Ming Hua (minghua) wrote : [Bug 94310] Re: Cannot save file when kate is opened for the first time.

On Sat, Jun 23, 2007 at 03:00:10PM -0000, SimSQ wrote:
> I was using SCIM on XIM. Thus it should be the scim package.

I don't see why that makes this a bug in scim package. Does kate works
fine for all other input methods in XIM mode?

Ming
2007.06.23

Revision history for this message
SimSQ (daniel-ssq89) wrote : Re: Cannot save file when kate is opened for the first time.

fcitx on XIM works. So it must either be a problem with how the KDE Text Control or how SCIM handles input events ... I suppose.

Revision history for this message
Marco Maini (maini10) wrote :

I'm unable to reproduce this but probably is really related with scim and Chinese characters. However, information of this report seem sufficient to be examined by scim mainteiners. Thanks.

Changed in scim:
assignee: maini10 → nobody
status: Incomplete → Confirmed
Revision history for this message
SimSQ (daniel-ssq89) wrote :

Steps to reproduce (and notes):

1. Open shell, and type:
$ export LANG=en_US.UTF-8
$ scim # turn it on, basically
$ XMODIFIERS=@im=SCIM kate

2.
 a) Press Ctrl+S. Press 's' a few times. Results: No characters appear.
 b) Dismiss the save dialog with Alt+F4
 c) Repeat step (a) to observe some pattern (but there isn't -- see notes)
 d) Dismiss kate

3. On the shell, type:
$ XMODIFIERS= kate

4.
 a) Press Ctrl+S. Press 's' a few times. Results: "ssss..." appear in the save dialog

Note:
1. Results may be sporadic. Try to press Ctrl+S immediately after kate starts up. Avoid typing anything else in the kate text box.
2. If it happens the first time, it may not happen the second time. But it can happen on the fourth try, 13th try, etc. It's random!
3. The entire SCIM toolbar (English/Keyboard, 智能拼音, etc.) must be hidden to achieve this.

Revision history for this message
Ming Hua (minghua) wrote : [Bug 94310] Re: Input problems in Kate save file dialog

On Mon, Jun 25, 2007 at 08:05:57AM -0000, SimSQ wrote:
> Steps to reproduce (and notes):
>
> 1. Open shell, and type:
> $ export LANG=en_US.UTF-8
> $ scim # turn it on, basically
> $ XMODIFIERS=@im=SCIM kate
>
> 2.
> a) Press Ctrl+S. Press 's' a few times. Results: No characters appear.

Sounds a bit similar to bug #106087. Does the bug appear in non-XIM
mode (for example, installing scim-qtimm, set QT_IM_MODULE to scim)?

> b) Dismiss the save dialog with Alt+F4
> c) Repeat step (a) to observe some pattern (but there isn't -- see notes)
> d) Dismiss kate

Ming
2007.06.28

Revision history for this message
Gnurou (gnurou) wrote :

I was affected by this bug too. Switching the input method to scim-bridge (im-switch -s scim-bridged) solved it for me. Strangely, I have to run skim manually at the beginning of every KDE session now, but afterwards it works for all applications launched after skim.

Revision history for this message
Régis B. (regisb) wrote :

I am affected by this bug in KUbuntu Intrepid and Jaunty.

Scenario:
1) Open new kate session
2) type a few characters
3) Ctrl+s
-> cannot type file name in "Name" bar.

Closing scim fixes the problem, but is not desirable.

Scim is 1.4.7-3 and Kate is 4.2.2-0.

I suspect a recent update caused this bug because it never occurred before today (at least in Intrepid).

Revision history for this message
Rolf Leggewie (r0lf) wrote :

does this ever occur in trusty or later?

There's also been some further upstream work on bugs like this lately. If you are still affected I'd love to hear if the latest upstream can fix this issue.

Changed in scim (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Revision history for this message
Rolf Leggewie (r0lf) wrote :
Revision history for this message
Rolf Leggewie (r0lf) wrote :

If you are still affected by this problem, please speak up. The ticket will otherwise be closed.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

closing as obsolete/unreproducible

Changed in scim (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers