Ubuntu

SCIM defaults prevent Alt Gr key from working in Netbeans

Reported by iGEL on 2008-04-05
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
SCIM
Unknown
Unknown
scim (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: netbeans

In Netbeans, the Alt Gr (present on many european keyboards) doesn't work. If you want to type [ (Alt Gr + 8 on the German keyboard), just an 8 appears. This can be solved by setting an environment variable:

AWT_TOOLKIT=MToolkit

Ubuntu version: 8.04
Netbeans version: 6.0.1 (Build 080320)
Ubuntu package version: 6.0.1-0ubuntu2
JDK version: 1.6.0_05

Xavi Ivars (xavi-ivars) wrote :

This does not work when using Netbeans 6.1. It does not start.

Carlos Hoyos (karlos1982) wrote :

I can testify this bug exists. The Alt Gr key appears as "Undefined" when testing new shortcuts on Editor Preferences. Also, because the only way to write brackets ({} []) in a spanish keyboard is by using a Alt Gr key combination, Netbeans becomes almost totally useless (you can still copy+paste from other applications).

Carlos Hoyos (karlos1982) wrote :

It seems I got the culcript. It's the SCIM input editor.

People at aMSN forums have found a quick fix to the problem. Instructions can be found here:

http://www.amsn-project.net/forums/viewtopic.php?p=23368#23368

Basically, SCIM doesn't work on java and Tcl/Tk applications if you don't define certain global variables before launching the daemon.

Problem fixed for me. Hope it works for others.

minet (roux-minet) wrote :

It does not work with me.
Because I'm not suer of what I did, could you explicitly give me exactly what you did?
Thanks in advance

Minet

rpuchadm (rpuchadm-gmail) wrote :

running netbeans with java-6-openjdk happens exactly the same

Rafel

samstre (samuel-streiner) wrote :

just start netbeans with XMODIFIERS=''
then it'll work

here's a little script to start it =)

#!/bin/bash
#change /home/samste/netbeans-6.5.rc2 to your netbeans directory
cd /home/samstre/netbeans-6.5rc2/bin/
XMODIFIERS='' ./netbeans

Daniel T Chen (crimsun) on 2008-12-08
Changed in netbeans:
importance: Undecided → Low
newur (newur) wrote :

I can confirm this bug, too. The solutions Carols posted works fine for me, but I still hope somebody fix it.

pandabeer (jonathanpoedts) wrote :

samstre wrote on 2008-11-06: (permalink)

just start netbeans with XMODIFIERS=''
then it'll work

here's a little script to start it =)

#!/bin/bash
#change /home/samste/netbeans-6.5.rc2 to your netbeans directory
cd /home/samstre/netbeans-6.5rc2/bin/
XMODIFIERS='' ./netbeans

---------------------------------------------
I can confirm that this works, but how can i change this so i can start netbeans from the menu?

I get errors when i just put that command in the menu

thanks a lot

Hi.

I'm on Fedora 10 (soon 11).
I had the same problem and used the same hack to make it work.

If you don't want to use a shell to start netbeans, you can put
export XMODIFIERS=''

 in your /etc/profile.
That's not really clean since it may be unwanted for some other programs such as pidgin. However, if you don't need them or netbeans'priority is greater, that's ok. ;-)

Rolf Leggewie (r0lf) wrote :

I'd assume this was a conscious choice by the Ubuntu devs. It's a direct effect of debian/patches/20_scim_config.dpatch which makes AltGr a trigger key.

Rolf Leggewie (r0lf) on 2009-07-26
Changed in scim (Ubuntu):
status: New → Confirmed
Paxdfgb (ne234234) wrote :

Same problem Ubuntu 9.04 and Netbeans 6.7.1

Jean-Marc Leroy (jmleroy) wrote :

Same problem Ubuntu 9.10 and Netbeans 6.8

Same problem Ubuntu 10.04 and Netbeans 6.8

dblv (eric-dblv) wrote :

Same problem Ubuntu 10.04 and Netbeans 6.9 !

+1 Ubuntu 10.04 / NB 6.8

XMODIFIERS='' works, but come on...no one tried to fix this in two years?

Any why is this low priority? It makes an incredible IDE completely unusable, and that's low priority? Not a very nice way to welcome new developers.. :-/

Same problem Ubuntu 10.10 and Netbeans 6.9
Same problem Ubuntu 10.04 and Netbeans 6.8

Please fix it!

FYI XMODIFIERS='' do NOT work!

Paul Wulff (paul-wulff) wrote :

I have just a stupid question. ;D
The workaround works for me but is it possible to modify the launcher to do this trick ?

I have try to type :

XMODIFIERS='' /usr/bin/netbeans

in the command box but I got the error :

There was an error launching the application.
Details: Failed to execute child process "XMODIFIERS=" (No such file or directory)

I use Ubuntu 10.04 LTS and NetBeans 6.8.

Paul Wulff (paul-wulff) wrote :

I think the issue is not coming from scim.
On my computer scim is not installed

#dpkg -s scim
Package `scim' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

Xavi Ivars (xavi-ivars) wrote :

The XMODIFIERS workaround does not work in Ubuntu 12.10. Does anyone know any other workaround?

Xavi Ivars (xavi-ivars) wrote :

Also, I don't have scim installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.