Incomplete Khmer input support

Bug #200844 reported by csokun on 2008-03-11
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
Medium
Unassigned
scim (openSUSE)
Fix Released
Medium

Bug Description

Ever since at least Ubuntu 10.04 Khmer language input has not worked correctly out-of-the-box (including 12.04 beta). The problem lies in Khmer's use of digraphs (two chars) for one input keystroke for some vowels. This bug has been documented and fixed in OpenSuse at
https://bugzilla.novell.com/show_bug.cgi?id=335944

Status: The scim maintainers are requesting some help in understanding and reproducing the issue.

Arne Goetje (arnegoetje) wrote :

Regarding scim, I think this bug should be reported upstream.

Did you also test this with the compose table in X.org? Does it work there?

csokun (chornsokun) wrote :

I am newbie to this could you elaborate a bit more detail how do I proceed with your suggestion?

Soben (chumsoben) wrote :

Like kids_pro, I don't seem to find the proper solution. What we understand is that, those Khmer vowels are not recognized by the Unicode standard. We can solve this problem by using the compose table of x.org. It seems what we have added into the compose table for Khmer had been added upstream at x.org. But we still cannot type those vowels (http://bp0.blogger.com/_BRGf4aMx5dE/R9Nyyo4N6lI/AAAAAAAAAsU/9RB0ukrZ6jE/s1600-h/missing_script.jpg).

Additional information: http://www.khmeros.info/drupal/?q=en/node/2631

csokun (chornsokun) wrote :

@Paul, every single point mention was already there.
But we still can't type composite key.

Reproduce:

sudo apt-get install khmeros-ttf

Add Keyboard: Cambodia
Open gedit => change keyboard layout to Cambodia type

k and follow by SHIFT + V it suppose to render like this កេះ

csokun (chornsokun) wrote :

the fix is simply add this line to /etc/environment :
GTK_IM_MODULE="xim"

Changed in scim:
status: Unknown → In Progress
Arne Goetje (arnegoetje) on 2009-01-19
Changed in scim:
assignee: nobody → arnegoetje
Changed in scim:
status: In Progress → Fix Released
Arne Goetje (arnegoetje) on 2009-11-09
Changed in scim (Ubuntu):
assignee: Arne Goetje (arnegoetje) → nobody
tags: removed: pet-bug
Adam Wood (gospeltocambodia) wrote :

csokun's comment to put this line:
GTK_IM_MODULE="xim"
in the /etc/environment file does work.

*However* even after this is done, there are still rendering issues, in which the open layout tables in the fonts are not being followed correctly. The best case would be a complete fix of the default scim, but that may not fix the issues of which I am referring. One example is the rendering of the word "bread." This word, using the KhmerOS fonts, should be rendered with the "samyook sannyaa" and "sraq o", but instead it is rendered with "samyook sannyaa" above a "samlap pii". The problem arises in gedit, but not in OpenOffice. I would be glad to post some more information about this if needed, as it is difficult to give specifics without a Khmer speaker. See this post for more details:

http://ubuntuforums.org/showthread.php?t=1588538

Nathan Wells (sungkhum) wrote :

I also confirm that csokun's solution works:
GTK_IM_MODULE="xim"

Is there any way to make this automatic when using the Khmer (Cambodian) keyboard layout?

-Nathan

Adam Wood (gospeltocambodia) wrote :

I want to reconfirm that this bug still exists in Ubuntu 11.04. *Even after the fix above* this problem continues to occur in various OS-level functions, not just in individual programs. For instance, I have already applied the fix above to my system. Khmer input works correctly in gedit and LibreOffice. However, when using the Unity launcher and inputting Khmer the same issue occurs as was first reported in this bug report, though the fix is already applied. I continue to keep my eyes open for other occurrences.

Changed in scim (Ubuntu):
status: New → Confirmed
summary: - Some Khmer vowels did not display
+ Incomplete Khmer input support
Adam Wood (gospeltocambodia) wrote :

Ubuntu 12.04 LTS still does not fully support Khmer. It makes using this language in Ubuntu completely impossible. Please assign someone to fix it.

Aron Xu (happyaron) wrote :

As commented on Bug #988178:

"Please send your request to other IMFs like IBus and Fcitx if possible, because we are in a slow but moving process of removing SCIM from Debian because of its unmaintained/broken status, so it will make Ubuntu lost SCIM someday, too."

Changed in scim (openSUSE):
importance: Unknown → Medium
Rolf Leggewie (r0lf) wrote :

OpenSuse has been able to fix this problem quite a while ago.

Changed in scim (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Rolf Leggewie (r0lf) wrote :

#11 is FUD spread by people with an agenda. scim is maintained in Debian and upstream.

That being said, I apologize we failed to address this issue earlier.

Rolf Leggewie (r0lf) wrote :

I do not speak Khmer, so I have trouble understanding the issue. I'd appreciate some hand-holding to understand what is still going wrong.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.