Can't close SCIM

Bug #199030 reported by Mårten Woxberg on 2008-03-06
102
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
High
Arne Goetje

Bug Description

Binary package hint: scim

I'm not interested in using SCIM.

I didn't even know I had it until today when I accidentaly activated it and suddenly I was typing in Armenic... THIS SUCKS

Also I didn't know how to re-activate Latin and I had to look around pretty long before noticing that there was a new icon
in my notification bar.

Now I set it back to latin but I cant for the life of me close the SCIM program, it keeps poping up.

I've looked through sessions and everything but no...

The first thing I remove when I install Windows is that blasted language chooser for the keyboard. I DON'T want to be able to choose
by accident another language without prompt or warning.

Please remove SCIM (which doesn't abide by HIG btw) until you can warn users about it.

Arne Goetje (arnegoetje) wrote :

Won't do. SCIM is needed to type several complex scripts and therefor needed by many users.
If you want to disable SCIM, please do one of the following:

System/Administration/Language Support -> disable the checkbox "Enable support to enter complex characters"

if this doesn't work, open a terminal and type the following:

sudo im-switch -z all_ALL -s none

This should disable SCIM permanently. For the changes to take effect, you need to re-login.

Changed in scim:
status: New → Invalid
Arne Goetje (arnegoetje) wrote :

fixed in 1.4.7-3ubuntu2

Changed in scim:
status: Invalid → Fix Released

Whatዶ ዮኡ መአን ኢት"ስ ፊሸድ?

Oh, sorry. "What do you mean it's fixed?" is what I tried to type. But since it auto-changes language all the time it's really hard to get it right. Seems it uses SHIFT-space to switch to Amharic, which is apparently extremely easy to hit by accident, is really surprising, and gives no clue whatsoever to what happened.

That can't be a good design by any measure.

(PS I wasn't even trying to make a joke up there, that's what ACTUALLY happened, it happens ALL the time for me).

Mario Vukelic (mario-vukelic) wrote :

I have this all the time, too, and within a short time two other guys confirmed it on ubuntu-devel-discuss. Started two days ago or so, while the scim updates happened in Hardy.

Mario Vukelic (mario-vukelic) wrote :

Ah, crap, somehow I overlooked the fix (it's late). I tried to uncheck the option and it helped.

Vadim Peretokin (vperetokin) wrote :

I do hope that the behavior of this will be changed in the final release. It's absolutely unacceptable, and I don't think people who do use scim will find this aggressive behavior helpful either.

Ming Hua (minghua) wrote :

This bug is labeled "Fix Released" by a developer. If people are still seeing this bug with up-to-date hardy, please say so and I'll reopen this bug.

Reopened: ON Right-click -> exit, the applet should not instantly reappear, regardless of the setting in language support. Otherwise the exit option should be removed from the right-click menu.

Changed in scim:
status: Fix Released → Confirmed
Martijn vdS (martijn) wrote :

Also, I've selected Dutch and English... which means I don't need support for complex languages... if I do, I'll enable it.

Now if I had selected an interface language that needs complex characters, I'd expect it to be enabled by default... but not for everyone!

Also shift+space.. what have the SCIM devs been smoking?

Martijn vdS (martijn) wrote :

And I'd expect KEYBOARD settings (like "I want to use complex characters") to be in the KEYBOARD settings dialog, nog the LANGUAGE settings dialog.

(can you tell I'm frustrated? I've just spent 30 minutes trying to get rid of SCIM.. then I dpkg --purge'd it)

John Leach (johnleach) wrote :

System/Administration/Language Support -> disable the checkbox "Enable support to enter complex characters"

After applying this it tells me I need a reboot! Did it upgrade my kernel?!!

So can someone confirm that this is not enabled by default now? The SCIM gtk interface is utterly insane - I can't believe this is going to be enabled by default.

John Carr (johncarr) wrote :

This was really ****ing me off until I worked out it was Shift+Space and Ctrl+Space. Still triggering it accidentally with an alarming and annoying regularity.

Can somebody please set the Importance to "critically" or "high"? This is a really bad bug which makes you crazy...

BTW, I can confirm this bug on Hardy Heron A-6 with all updates on a German-localized machine.

Alexander Jones (alex-weej) wrote :

This has been winding me up since a few weeks of Hardy, too. Are we shipping with SCIM on by default now? Or did I enable it myself without really knowing what it was? If it's on by default, we absolutely have to remove the Shift+Space keyboard shortcut as it is FAR too easy to accidentally trigger. I didn't realise I had this habit of hitting Shift+Space every time I type "I" until this started happening.

Alexander Jones (alex-weej) wrote :

Furthermore, the keyboard shortcuts listed in SCIM setup collide with window-manager codes for switching workspaces... e.g. Control-Alt-Right for "Show input method menu".

 subscribe

Martin Pitt (pitti) wrote :

Release Management-wise this should be fixed soon, since breaking keyboard input is one of the worst things we can do.

Maybe the input switch can be triggered by a combination which will not hit accidentally all the time, very much *unlike* shift-space? what about both control keys, control+esc, or sth similar?

Changed in scim:
assignee: nobody → arnegoetje
importance: Undecided → High
milestone: none → ubuntu-8.04-beta

On Mon, Mar 10, 2008 at 2:46 AM, Martin Pitt <email address hidden> wrote:

> Release Management-wise this should be fixed soon, since breaking
> keyboard input is one of the worst things we can do.
>
> Maybe the input switch can be triggered by a combination which will not
> hit accidentally all the time, very much *unlike* shift-space? what
> about both control keys, control+esc, or sth similar?

I thought about this, and in a way, it is still as dangerous as ever -
because someone, sometime, might happen to accidentally trigger it. Then
they'll be completely lost and confused, since the obscure combination will
be hard to duplicate. People who do have use for scim might find the
combination too hard to do too, and would need to change it themselves (and
complain about the bad default setting!).

I believe that the best way to go is to set a meaningful default shortcut
key, but have scim disabled by default. That way, non-scim people won't run
into the combination, and scim people will simply enable scim if they need
it (there's nothing wrong with that - it's a personal preference, so it
would be understandable). After enabling it, they'll also have a useful
shortcut key set for them, so they'll be all set.

Martijn vdS (martijn) wrote :

On Mon, 10 Mar 2008, Vadim Peretokin wrote:

> scim people will simply enable scim if they need it (there's nothing
> wrong with that - it's a personal preference, so it would be
> understandable).

No, it's a global setting (System -> Administration, not System ->
Preferences)... if you enable "Complex input" support, ALL users on the
system get SCIM.

Martijn
--
Sorry isn't an excuse when you do something stupid on purpose.

Martin Pitt (pitti) wrote :

  mvo| pitti: it used to be a global setting, but after some discussion it was decided it should be per-user

Martijn vdS (martijn) wrote :

That's not what it looks like currently (it's in Language Settings, which is global, not Keyboard Settings which is user-local)

Martijn vdS (martijn) wrote :

It also asks for a reboot(!) when you change the setting.

Murat Gunes (mgunes) wrote :

According to the fix that closed it, and as per the discussion at [1], as I understand, this bug was originally about SCIM being enabled for all languages instead of non-European languages only. Has this decision been changed? Is it intentional that it's enabled for all languages now?

[1] http://irclogs.ubuntu.com/2008/03/06/%23ubuntu-devel.html

If I close it. It will immediately restart.

I don't even have ANY non-latin15 language installed in this computer.

Why is this installed in the first place?

Why did you bother to ask about language support when I installed Ubuntu?

Do I sound frustrated enough?

[...]

There is NO obvious way to turn this stupid program off. The obvious way being:

Right.click -> Exit
Right.click -> Configure -> Some obvious button for "disable this forever"

Arne Goetje (arnegoetje) wrote :

This bug has been resolved in the latest scim, scim-bridge and language-selector packages.
Also, the current daily live CD image is fine.

This bug only affects those folks who are using Hardy for a longer time already and updated frequently.

The proper way to disable scim is:
1. System -> Administration -> Language Support
2. uncheck the 'Enable support to enter complex characters' checkbox
3. restart your X session by logout/re-login or if this doesn't do the trick, reboot.

If this still does not do the trick, the following will definitely do:
Open a terminal window and type: sudo im-switch -z all_ALL -s none
After that, restart your X session.

Explanation:
scim is running as daemon under the control of im-switch. To allow scim to grab the keyboard input, a bunch of environment variables need to be set within the X session. Toggeling the checkbox in Language Support will set/unset those variables. To get the changes into effect, a restart of the running X session is required.

Background:
For scim to work correctly in Ubuntu, the combination of im-switch, scim and language-selector is required, as well as several optional scim-modules for the actual input methods.
Before Hardy, the im-switch package was not seeded into the default desktop (and therefor into the live CD), which made it impossible to get scim working on the live CD without installing the language support packages for one of the CJK languages. As scim is also used by many other non-CJK users who don't have appropriate keyboard layouts available for their desired languages, we decided to seed im-switch, so that it can be used on the Live CD as well.
Some time in the past (during the Hardy development cycle), the function in Language Support to set/unset he environment variables, stopped working correctly and the environment variables got enabled by default for everyone. With the seeding of im-switch, this led to the behaviour which you experienced, but which was not intentional.
As we cannot detect who intentionally enabled scim support in their non-CJK locales and who didn't, we cannot solve this by script and manual interaction is required to disable scim support for those who don't want it.

And a comment to the 'Close' function in the scim gtk frontend:
This one only works when scim is started as a foreground process, but has no effect when scim is running in daemon mode.

And one more comment:
As this is a development version, such breakage may occur. For those of you who need a stable and reliable system, please use the current stable release.

Changed in scim:
status: Confirmed → Fix Released

Even for a development release, not being able to type more than one or two words, due to scim screwing up and changing your input (after deleting the shortcuts to stop it triggering that way), is ridiculous, and well warrants people screaming.

You can't even report bugs if your keyboard input is screwing up *that* badly.

wizard10000 (wizard10000) wrote :

What I did was remove the Shift-Space keybinding. I originally griped
about that but my bug got combined with this one - which makes more
sense because scim shouldn't be running unless you need it anyway.

On Wed, 2008-03-12 at 12:05 +0000, Sarah Hobbs wrote:
> Even for a development release, not being able to type more than one or
> two words, due to scim screwing up and changing your input (after
> deleting the shortcuts to stop it triggering that way), is ridiculous,
> and well warrants people screaming.
>
> You can't even report bugs if your keyboard input is screwing up *that*
> badly.
>

Alexander Jones (alex-weej) wrote :

SCIM won't be running if you disable complex character input in "Language
Support".

Vadim Peretokin (vperetokin) wrote :

I thought I had this but now I'm a bit confused.

What is the intended behavior of SCIM in the final release? Will it be enabled/disabled by default? If enabled, what will be the keybinding for it?

Lex Ross (lross) wrote :

SCIM won't close in version 1.4.7-3ubuntu2
It is screwing my keyboard as well. And yes, complex characters input is disabled in "Language Support"
I do have support for Russian language checked in because that's what I need. Not the keyboard support however. X can deal with that way better than SCIM does, and there is System->Settings->Keyboard dialog which does the job. SCIM on the other hand has Russian key table all wrong. And there is no apparent way to configure it. And it looks ugly. not to mention that s applet violates HIG policy. I vote to kill this monster for good.

Lex Ross (lross) wrote :

Okay I do understand that for more complex languages then Russian and Thai (like Chinese and Japanese for instance) SCIM may be required. Meaning SCIM should only appear if complex characters input is enabled, which is not my case. Could you please fix SCIM to appear only when compex characters input is enabled.

Thanks.

Steve Langasek (vorlon) wrote :

SCIM is already fixed to only appear when complex character input is enabled.

The problem is that a previous version of the scim package was broken in a way that the wrong enabling of SCIM became sticky for those users who had installed that broken version, even after upgrading to the fixed version.

The following very long shell one-liner should reset all of the input method configuration options that were broken by the previous scim package, giving you a pristine state:

for conf in ja_JP ko_KR zh_CN zh_HK zh_SG zh_TW all_ALL; do if LC_ALL=C update-alternatives --display xinput-${conf} | grep -q 'status is manual' && LC_ALL=C update-alternatives --display xinput-${conf} | grep -q 'currently points to .*scim-bridge'; then update-alternatives --auto xinput-${conf}; fi; done

This may be included in an upcoming update of the scim package.

Arne Goetje (arnegoetje) wrote :

Included the one-liner above into scim

New packages are on people.ubuntu.com/~arne/scim/

Please sponsor!

Thanks

Ming Hua (minghua) wrote :

Commets about the newly proposed patch by Arne:

1. The update-alternatives setting reset should be put into some "if [ "$1" = configure ]; ...; fi" test, otherwise the command would be unconditionally executed, and not desired for situations such as abort-upgrade.

2. For the same reason, the old version $2 should be checked, so that it only attempts to do this heavy-handing fix when upgrading from known-to-be-broken versions.

3. I am still not quite sure whether preinst or postinst is the correct place. I would have put it in preinst. But this is a minor thing.

Arne Goetje (arnegoetje) wrote :

This debdiff will clean up the scim-bridge entry for all_ALL in case scim-bridge-agent was installed *before* the upgrade to scim 1.4.7-3ubuntu1 was made. This case has not been handled yet by scim 1.4.7-3ubuntu4.

Source package is available on people.ubuntu.com/~arne/scim/

Please sponsor.

Martin Pitt (pitti) wrote :

I sponsored and accepted Arne's recent debdiff.

I just ran an update and got: "An error occurred:The following details are provided:E: scim: subprocess post-installation script returned error exist-status 2"

sorry of course that'd be exit status not exiSt-status

Michael Nash (michaelc-nash) wrote :

Hello,

Apologies if my comments are irrelevant or superfluous, this is my first time using the forums.

Whenever I log on, the SCIM keyboard icon appears by the date and time. When I open a window, it turns to a Chinese character icon and whatever I type turns to Chinese.

"System/Administration/Language Support -> disable the checkbox "Enable support to enter complex characters"
 - I've done this.

"sudo im-switch -z all_ALL -s none"
 - I've done this.

"for conf in ja_JP ko_KR zh_CN zh_HK zh_SG zh_TW all_ALL; do if LC_ALL=C update-alternatives --display xinput-${conf} | grep -q 'status is manual' && LC_ALL=C update-alternatives --display xinput-${conf} | grep -q 'currently points to .*scim-bridge'; then update-alternatives --auto xinput-${conf}; fi; done"
 - I've done this.

Yet the blasted thing still appears, and I still end up typing Chinese every time I open a new window. I'm at the end of my tether, and I don't really want to have to do a clean installation. Any more suggestions?

(If I've not provided enough information to be useful, please ask me what you need to know and I'll get back to you a.s.a.p.)

Alexander Jones (alex-weej) wrote :
  • unnamed Edit (166 bytes, text/html; charset=ISO-8859-1)

These aren't the forums. Please use http://answers.launchpad.net/ for
support requests!

This bug is fixed.

No this bug is not fixed. I am using Hardy and Shift-Space is bound to ... something, but not the space character, which drives meINSANE. This is totally unacceptable for anybody who is a fast touch typist.

In "Language Support", I do NOT have "complex character support" enabled.

Even more ridiculous is that in the SCIM control panel, it doesn't list Shift-Space as one of the hotkeys! Only Ctrl-Space.

Am I just missing something here? How can this bug be "fixed"?

I ended up disabling SCIM entirely with 'sudo im-switch -z all_ALL -s none', but that's not a real solution.

Hew (hew) wrote :

This bug was fixed months ago, before Hardy release, and I can confirm it really has been fixed. Please find/report a new bug on your issue. Thanks.

Vadim Peretokin (vperetokin) wrote :

shift+space generates a space here...

Yeah... I'm sorry, once I saw the text that comes up when you try to change this bug's status, I realized what the problem was.

On the computer which has the problem, I had updated to Hardy slightly before the official release, so I got the broken SCIM setup, and subsequent updates were not able to fix it.

Can someone verify that SCIM doesn't use Shift-Space when you do enable it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments