Please apply patch to SCIM for Java clients

Bug #178742 reported by Masaki on 2007-12-26
12
Affects Status Importance Assigned to Milestone
SCIM
Unknown
Unknown
scim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: scim

SCIM is not working properly when it's using on Java client e.g. NetBeans IDE.

This problem happens on Ubuntu, but does not happen on Fedora Core
because Fedora is applying a patch to SCIM.

For example, I'm using SCIM-Anthy in Japanese locale.

When you create input field of dialog, then
1. open dialog
2. CTRL+SPACE
3. input something (ex, nihonn + SPACE)
4. close dialog
5. open dialog
6. CTRL+SPACE
7. input something (ex, nihonn + SPACE)
8. I see the uncommitted texts underlined waiting to be comitted. They're not disappearing.

It's same behavior on JDK5 and JDK6, which are being provided through apt package manager.

Java is using XIM, it seems that problem exists in SCIM XIM frontend. This problem does not
happen on Fedora Core, because they applied the patch to SCIM. Could you please
apply this patch to SCIM of Ubuntu? Now many folks are using NetBeans IDE on Ubuntu,
it's great, but this issue is really serious for Japanese users. I'm actually getting many inquiries
and complaints for this issue.

scim_x11_frontend-ic-focus-LTC27940-215953.patch

--- scim-1.4.4.orig/modules/FrontEnd/scim_x11_frontend.cpp 2006-10-06 01:05:49.000000000 +0900
+++ scim-1.4.4/modules/FrontEnd/scim_x11_frontend.cpp 2006-10-06 10:29:55.000000000 +0900
@@ -1094,7 +1094,8 @@
     // If the ic is not focused, then return.
     if (!is_focused_ic (ic)) {
         SCIM_DEBUG_FRONTEND(1) << "IC " << call_data->icid << " is not focused, focus it first.\n";
- ims_set_ic_focus_handler (ims, (IMChangeFocusStruct *) call_data);
+// ims_set_ic_focus_handler (ims, (IMChangeFocusStruct *) call_data);
+ return 1;
     }

     XKeyEvent *event = (XKeyEvent*) &(call_data->event);

Related branches

On Wed, Dec 26, 2007 at 03:35:01PM -0000, Masaki wrote:
> Binary package hint: scim
>
> SCIM is not working properly when it's using on Java client e.g.
> NetBeans IDE.
>
> This problem happens on Ubuntu, but does not happen on Fedora Core
> because Fedora is applying a patch to SCIM.

Why is this patch not sent to upstream? Or did I miss it?

Ming
2008.02.04

Masaki (masaki-katakai) wrote :

Hi Ming,

Thank you for comment. What is upstream? Do you mean I should talk to SCIM folks first?

Ming Hua (minghua) wrote :

Yes, I meant SCIM upstream.

As the Debian maintainer, I don't know much about the scim code myself, so I'm very careful about applying patches. When Fedora is a respectable distribution and their patch should be well tested, if you the SCIM upstream can accept this patch into SVN or give a nod to this patch, it will make me more willing to include this patch in the Debian package (and hopefully, later inherited by Ubuntu package as well).

Masaki (masaki-katakai) wrote :

Thank you for clarification. OK, I'll try.

Upstream development is almost stopped.
We need to apply this patch.

Here is the debdiff. Please apply.

Rolf Leggewie (r0lf) wrote :

http://scim.svn.sourceforge.net/viewvc/scim/ looks quite active to me. Why do you think upstream development stopped?

Masaki (masaki-katakai) wrote :

Thank you very much Awashiro-san, can anyone apply this patch quickly?

Rolf, I'm not sure the detail about the upstream development, but it seems that this part (x11_frontend area) is almost stopped. Awashiro-san, please correct me if I'm wrong.

Regards.

Matthias Klose (doko) wrote :

This patch is not applied in the Fedora packages anymore; removed in May 2007 ("no longer needed").

Masaki (masaki-katakai) wrote :

Thank you very much Matthias,

It's bad. I tried it on Fedora 8, now it's reproducible again from Fedora 8.

Awashiro-san, is it still possible to fix in SCIM upstream?

Hi Katakai-san,

> Awashiro-san, is it still possible to fix in SCIM upstream?
IMHO, It is very hard. There is no active person...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scim - 1.4.7-3ubuntu6

---------------
scim (1.4.7-3ubuntu6) hardy; urgency=low

  * debian/patches/30_scim_x11_frontend-ic-focus-LTC27940-215953.dpatch:
    added (LP: #178742).

 -- Ikuya Awashiro <email address hidden> Sat, 15 Mar 2008 06:37:14 +0000

Changed in scim:
status: New → Fix Released
Masaki (masaki-katakai) wrote :

Thank you very much! I'm now seeing the notification of these updates on 8.04 beta. Great!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.