Ubuntu

scim-launcher crashed with SIGSEGV in scim::FrontEndModule::load()

Reported by Sunjae Park on 2007-09-12
44
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: scim

Ubuntu Gutsy, English version of KDE, with im-switch -s scim will crash SCIM, and disable KDE panels. With im-switch -s nabi or others the KDE panels launch just fine.

ProblemType: Crash
Architecture: amd64
Date: Tue Sep 11 22:40:39 2007
Disassembly: 0x2b05449dcaec:
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/lib/scim-1.0/scim-launcher
NonfreeKernelModules: ath_hal
Package: scim 1.4.7-1ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/scim-1.0/scim-launcher -d -c simple -e all -f x11
ProcCwd: /home/darehanl
ProcEnviron:
 PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/home/darehanl/local/bin
 LANG=ko_KR.UTF-8
 SHELL=/bin/tcsh
Signal: 11
SourcePackage: scim
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libstdc++.so.6
 scim::FrontEndModule::load ()
 scim::FrontEndModule::FrontEndModule ()
 ?? ()
Title: scim-launcher crashed with SIGSEGV in scim::FrontEndModule::load()
Uname: Linux bohanjae 2.6.22-11-generic #1 SMP Fri Sep 7 04:31:16 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin netdev plugdev powerdev scanner video

Related branches

Sunjae Park (darehanl) wrote :

StacktraceTop:?? ()
__gxx_exception_cleanup (code=<value optimized out>, exc=0x6213e0) at ../../../../src/libstdc++-v3/libsupc++/eh_throw.cc:50
scim::FrontEndModule::load (this=0x60d780, name=@0x1, backend=@0x7fff680eb1e0, config=@0x6044f8, argc=3, argv=0x7fff680eb040)
FrontEndModule (this=0x621400, name=@0x7fff680eb1c0, backend=@0x7fff680eb1e0, config=@0x6044f8, argc=3, argv=0x7fff680eb040)
main (argc=8, argv=0x7fff680eb4b8) at scim_launcher.cpp:204

Ming Hua (minghua) wrote :

Thanks for reporting. I wonder if the crash happens when you start scim manually. Can you test with "im-switch -s none", then once you've logged into KDE, run the following in a terminal?

export XMODIFIERS="@im=SCIM"
export QT_IM_MODULE=xim
scim -d

Sunjae Park (darehanl) wrote :

Thanks for your advice. Indeed it dies with:
/usr/lib/scim-1.0/scim-panel-gtk: error while loading shared libraries: libscim-gtkutils-1.0.so.8: cannot open shared object file: No such file or directory

Installing scim-gtk2-immodule fixed the problem. I wonder the dependencies were broken somewhere. I started with the English version of Kubuntu Gutsy, and installed skim and scim-hangul manually. Nowhere do I see Depends: scim-gtk2-immodule.

$ apt-cache show skim
...Depends: kdelibs4c2a (>= 4:3.5.7-1), libc6 (>= 2.5-5), libgcc1 (>= 1:4.2-20070516), libqt3-mt (>= 3:3.3.8really3.3.7), libscim8c2a (>= 1.4.6), libskim0, libstdc++6 (>= 4.2-20070516), libx11-6
$ apt-cache show libscim8c2a
...Depends: libc6 (>= 2.6), libgcc1 (>= 1:4.2-20070516), libstdc++6 (>= 4.2-20070516), libx11-6
$ apt-cache show libskim0
...Depends: kdelibs4c2a (>= 4:3.5.7-1), libc6 (>= 2.5-5), libgcc1 (>= 1:4.2-20070516), libqt3-mt (>= 3:3.3.8really3.3.7), libscim8c2a (>= 1.4.6), libstdc++6 (>= 4.2-20070516), libx11-6

On Sat, Sep 15, 2007 at 02:48:49PM -0000, Sunjae Park wrote:
> Thanks for your advice. Indeed it dies with:
> /usr/lib/scim-1.0/scim-panel-gtk: error while loading shared libraries: libscim-gtkutils-1.0.so.8: cannot open shared object file: No such file or directory

Alas, so scim in gutsy is broken. Thanks for bringing this to my
attention.

> Installing scim-gtk2-immodule fixed the problem. I wonder the
> dependencies were broken somewhere. I started with the English version
> of Kubuntu Gutsy, and installed skim and scim-hangul manually. Nowhere
> do I see Depends: scim-gtk2-immodule.
>
> $ apt-cache show skim
> $ apt-cache show libscim8c2a
> $ apt-cache show libskim0

Indeed it's a broken dependency problem. But since
/usr/lib/scim-1.0/scim-panel-gtk belongs to scim package, you should
look at scim. Of course it doesn't depend on scim-gtk2-immodule either.

I'll see what I can do.

 status triaged

Ming
2007.09.15

Changed in scim:
status: New → Triaged
Ming Hua (minghua) wrote :

On Sat, Sep 15, 2007 at 04:45:27PM -0000, Ming Hua wrote:
>
> I'll see what I can do.

I've sent a mail to ubuntu-devel list about this bug:
https://lists.ubuntu.com/archives/ubuntu-devel/2007-September/024307.html

Ming
2007.09.15

Arne Goetje (arnegoetje) wrote :

scim (1.4.7-1ubuntu2) gutsy; urgency=low

  * Add scim-gtk2-immodule to scim's Depends, LP: #139249

 -- Arne Goetje <email address hidden> Thu, 20 Sep 2007 09:44:30 +0800

Changed in scim:
status: Triaged → Fix Released

I saw this crash with scim-1.4.7-1ubuntu2 on Ubuntu 7.10 Gutsy AMD64. To reproduce:

1. login with different locale than in 'grep SupportedUnicodeLocales /etc/scim/global'
 -> ie something other than en_US.UTF-8, eg en_GB.UTF-8

2. install language packs, select 'Enable support to enter complex characters' in Administration->Language Support

3. run eg 'im-switch -z en_GB.UTF8 -s scim'

4. login again, or run 'scim-launcher'

I noticed that, after adding (eg) en_GB.UTF-8 to either /etc/scim/global or ~/.scim/global, the crashing does NOT occur, and I can use scim as expected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers