Ubuntu

scim lock modifier status (ctrl/shift/alt) on Firefox 1.5

Reported by Ruey-Cheng Chen on 2007-06-25
8
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
Medium
Rolf Leggewie

Bug Description

Binary package hint: scim

I doubted that the problem has something to do with scim-gtk2-immodule. In Firefox, SCIM eats up all the modifier events in widgets such as textarea, text fields, and sometimes even in the searchengine bar; so webapps listening keycode events with Javascript may malfunction. On the other hand, everything went okay when gcin was used instead.

* Steps to reproduce:
1) Launch firefox with either XIM or immodule
    $ XMODIFIERS=@im=SCIM GTK_IM_MODULE=xim firefox
    or $ XMODIFIERS=@im=SCIM GTK_IM_MODULE=scim firefox
2) Launch GMail
3) In the chatbox of GMail interface, hitting ENTER will normally send the message out, but with SCIM switched on hitting ENTER will get you a newline (much like hitting Ctrl-ENTER or Shift-ENTER).

A simple workaround is to switch off IM and hit ENTER again. It's like:
1. Hit toggle key, e.g. Ctrl-Space or Shift-Space
2. Type things such as Chinese/Japanese/Korean
    (Nothing happen if you hit Ctrl-K or Ctrl-L right now => status locked)
3. Hit ENTER (not working)
4. Hit toggle key again to switch off IM
5. Hit ENTER (message sent!)
    (Ctrl-K and Ctrl-L works again)

The locking problems remains even if you changed the toggle key to some other combinations which don't include modifiers (e.g. Scroll-Lock or Win-Key). A javascript keycode detector may help reproducing the situation.
http://www.beansoftware.com/ASP.NET-Tutorials/Examples/Shift-Ctrl-Alt-Detect.aspx

* Version information:
firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
scim 1.4.4-1ubuntu12
scim-bridge 0.1.4-0ubuntu2
scim-chewing 0.2.1-2ubuntu4
scim-gtk2-immodule 1.4.4-1ubuntu12
scim-modules-socket 1.4.4-1ubuntu12
scim-qtimm 0.9.4-0ubuntu4

Ming Hua (minghua) wrote :

Thanks for the detailed report. I'll investigate when I have time.

Changed in scim:
status: New → Triaged
Mnlg (mnlg) wrote :

Hi, I have had the same exact problem with Firefox 3 on an Ubuntu 8.04.1. Also with kubuntu 8.04.1.

When I type an enter key on gmail/gtalk for the very first time, my message goes through. From that moment on it won't -- only way to make it work is to focus on any other window (or just click outside of firefox window) then go back to firefox. Then, the next enter key will be registered correctly but after it, all enter keys will be considered as newlines.

I am unsure as to what I can provide to help track this thing down. It is very irritating for me. I often chat in esperanto, and scim/skim with m17n is a great help.

Thank you for any help you can give.

Rolf Leggewie (r0lf) wrote :

I think I am experiencing something similar. But I don't have gmail, so I cannot test there. I do experience keyboard unresponsiveness in pidgin and the terminal, though.

Mnlg (mnlg) wrote :

I have noticed the same thing on the latest epiphany (2.24.1-0ubuntu1) as well as the latest firefox (3.0.10). I am using SCIM 1.4.7-3-ubuntu10, scim-bridge-client-gtk 0.4.14-2ubuntu5, scim-gtk2-immodule 1.4.7-3ubuntu10, scim-m17n 0.2.2-3. I think they all are the latest there are.

Thanks for any help.

Mnlg (mnlg) wrote :

How to replicate the issue:

- Fresh install ubuntu
- Install m17n-contrib and scim-m17n (m17n-db should be tagged along)
- within scim, activate Other>eo-x-sistemo (but I think any other should do)
- restart X if needed, then:

1- do not activate scim;
Open firefox / epiphany, go to gmail, chat with any of your contacts, try sending at least two messages in a row, and you should be able to send them both.

2- activate scim;
try sending at least two messages in a row, without switching windows or clicking anywhere else than the textarea you are in.

The expected result is that your first message goes through but your second enter key, and any other enter key after that, translates into a newline.

Click outside of the textarea (within or out of firefox does not matter). click back into the textarea to send a message, type anything and press enter, and your message will go through. try any other number of messages right after that and they won't.

Note: This behavior does not limit itself to gmail/gtalk but to any website with a textarea whose enter-key event has been channeled to a form submit (mostly this is true for chat rooms).

Thank you for your attention.

Rolf Leggewie (r0lf) wrote :

Thank you for reporting. I think this may be fixed in 1.4.9 which is about to be released in Karmic. I don't see it anymore. Please verify.

https://launchpad.net/~r0lf/+archive/hardy/+sourcepub/678492/+listing-archive-extra

Changed in scim (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Triaged → Incomplete
ming (mctiew) wrote :

I am still have this problem and here is my versions :-

iceweasel 3.5.1
scim 1.4.9.1
scim-gtk2-immodule 1.4.9.1
scim-modules-socket 1.4.9.1

scim-array 1.0.1-1
scim-chewing 0.3.1-3
scim-modules-table 0.5.8-1
scim-pinyin 0.5.91-1
scim-tables-zn 0.5.8-1

Please let me know if other packages need to be upgraded.

Rolf Leggewie (r0lf) on 2009-10-16
Changed in scim (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
importance: Undecided → Medium
status: Incomplete → Confirmed
Ruey-Cheng Chen (rueycheng) wrote :

Thanks for these efforts. The problem seems to be gone on Ubuntu Jaunty.

firefox-3.0 3.0.19+nobinonly-0ubuntu0.9.04.1
firefox-3.0-gnome-support 3.0.19+nobinonly-0ubuntu0.9.04.1
scim-bridge-agent 0.4.14-2ubuntu5
scim-bridge-client-gtk 0.4.14-2ubuntu5
scim-chewing 0.3.3-1ubuntu1
scim-gtk2-immodule 1.4.7-3ubuntu12
scim-modules-socket 1.4.7-3ubuntu12

On the other hand, I didn't keep the old Debian so that I have no idea how it looks right now on Debian 5.0.

Rolf Leggewie (r0lf) wrote :

Ming, what about you, are you still affected?

Changed in scim (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

no further reports of problems, closing as fix released.

thank you

Changed in scim (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers