scim works in koffice but not in openoffice

Bug #119755 reported by John O'Connell on 2007-06-10
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
scim (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

scim-anthy works perfectly in a console and koffice but refuses to operate in openoffice.

Ming Hua (minghua) wrote :

Hi John,

Thanks for your bug report. However more information is needed to diagnose this bug: Which Ubuntu release are you using? Are you using im-switch? If not, how do you start scim? What is your GTK IM module setting? Which scim module packages do you have installed?

If you don't quite understand these questions, please give the output of the following commands:
$ locale
$ /usr/share/bug/scim/script 3>&1
$ echo $QT_IM_MODULE
$ im-switch -l
and attache your /etc/scim/config, /etc/scim/global, ~/.scim/config, and ~/.scim/global files.

Download full text (9.2 KiB)

On Sunday 10 June 2007 22:22:28 Ming Hua wrote:
> Hi John,
>
> Thanks for your bug report. However more information is needed to
> diagnose this bug: Which Ubuntu release are you using? Are you using
> im-switch? If not, how do you start scim? What is your GTK IM module
> setting? Which scim module packages do you have installed?
>
> If you don't quite understand these questions, please give the output of
> the following commands: $ locale
> $ /usr/share/bug/scim/script 3>&1
> $ echo $QT_IM_MODULE
> $ im-switch -l
> and attache your /etc/scim/config, /etc/scim/global, ~/.scim/config, and
> ~/.scim/global files.

Thanks for the amazingly fast response. Here is the data requested:
I am running 7.04 Feisty Fawn from Linux Magazine. I downloaded kde desktop
and am running this.
I am sending this from my SuSE 10.0 partition since scim is now the only thing
stopping me from migrating to Kubuntu so my emails are still here, sorry!
regards
 John

 john@john-laptop:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
john@john-laptop:~$ /usr/share/bug/scim/script 3>&1
Related packages:
ii libscim8c2a 1.4.4-7ubuntu1 library for SCIM platform
ii scim 1.4.4-7ubuntu1 smart common input method platform
ii scim-anthy 1.2.1-1build1 SCIM IMEngine module for Anthy
ii scim-canna 1.0.0-2ubuntu1 SCIM IMEngine module for Canna
ii scim-gtk2-immodule 1.4.4-7ubuntu1 GTK+2 input method module with SCIM as backe
ii scim-modules-socket 1.4.4-7ubuntu1 socket modules for SCIM platform
ii scim-modules-table 0.5.6-2 generic tables IM engine module for SCIM pla
ii scim-qtimm 0.9.4-0ubuntu5 SCIM context plugin for qt-immodule
ii scim-tables-additional 0.5.6-2 miscellaneous input method data tables for S
ii scim-uim 0.1.4-2 UIM IM engine module for SCIM platform

Related environment variables:
$XMODIFIERS=@im=SCIM
$GTK_IM_MODULE=scim

Installed SCIM components:
/usr/lib/scim-1.0:
1.4.0 scim-helper-launcher scim-helper-manager scim-launcher scim-panel-gtk

/usr/lib/scim-1.0/1.4.0:
Config Filter FrontEnd Helper IMEngine SetupUI

/usr/lib/scim-1.0/1.4.0/Config:
kconfig.la kconfig.so simple.so socket.so

/usr/lib/scim-1.0/1.4.0/Filter:
sctc.so

/usr/lib/scim-1.0/1.4.0/FrontEnd:
socket.so x11.so

/usr/lib/scim-1.0/1.4.0/Helper:
anthy-imengine-helper.a anthy-imengine-helper.la anthy-imengine-helper.so setup.so

/usr/lib/scim-1.0/1.4.0/IMEngine:
anthy.la anthy.so canna.la canna.so libanthy.a libcanna.a rawcode.so socket.so table.so uim.so

/usr/lib/scim-1.0/1.4.0/SetupUI:
aaa-frontend-setup.so anthy-imengine-setup.la canna-imengine-setup.la libanthy-imengine-setup.a panel-gtk-setup.so
aaa-imengine-setup.so anthy-imengine-setup.so canna-imengine-setup.so libcanna-imengine-setup.a table-imengine-setup.so
john@john-laptop:~$ ec...

Read more...

On Sunday 10 June 2007 22:22:28 Ming Hua wrote:
> Hi John,
>
> Thanks for your bug report. However more information is needed to
> diagnose this bug: Which Ubuntu release are you using? Are you using
> im-switch? If not, how do you start scim? What is your GTK IM module
> setting? Which scim module packages do you have installed?
>
> If you don't quite understand these questions, please give the output of
> the following commands: $ locale
> $ /usr/share/bug/scim/script 3>&1
> $ echo $QT_IM_MODULE
> $ im-switch -l
> and attache your /etc/scim/config, /etc/scim/global, ~/.scim/config, and
> ~/.scim/global files.

Sorry I forgot to add the files that I created from online advice to enable
scim to work as it is at present.
The first file is /etc/X11/Xsession.d/74custom-scim_startup
this contains:
 export XMODIFIERS="@im=SCIM"
 export GTK_IM_MODULE="scim"
 export XIM_PROGRAM="scim -d"
 export QT_IM_MODULE="scim"

The second file is ~/kde/Autostart/startscim
this contains:
 #!/bin/sh
 scim -d

well that's all.
Hope it helps.
regards
  John

Ming Hua (minghua) wrote :

Just a reply saying I haven't forgotten this bug yet, but the past week
has been busy and I don't have much time to work for Ubuntu.

On Tue, Jun 12, 2007 at 04:38:03PM -0000, John O'Connell wrote:
>
> Sorry I forgot to add the files that I created from online advice to enable
> scim to work as it is at present.

Meanwhile I want to point out that such settings, while probably okay,
is made in a way I am very unfamiliar with. The package im-switch
exists to make input method settings consistent and should be used
unless there is a bug in the im-switch setting. If possible I suggest
trying the im-switch setting first.

> The first file is /etc/X11/Xsession.d/74custom-scim_startup
> this contains:
> export XMODIFIERS="@im=SCIM"
> export GTK_IM_MODULE="scim"
> export XIM_PROGRAM="scim -d"
> export QT_IM_MODULE="scim"
>
> The second file is ~/kde/Autostart/startscim
> this contains:
> #!/bin/sh
> scim -d

Ming
2007.06.22

A.K.Karthikeyan (mindaslab) wrote :

I use Kubuntu 7.04, SCIm works in Kate, Kmail, Konqureor , firefox etc, but dosent work in open office 2.2

kamereon (kamereon) wrote :

This bug may be identical with #44626

No, No, this is not a duplicate.
I can confirm this bug on Hardy.
This is because scim cannot start when skim is installed.
So, this is scim-bridge's issue.

Here is the debdiff.

if skim was installed, that means users prefer to use skim, and skim's
UI is nicer than scim's.

On Sat, Mar 15, 2008 at 2:12 PM, Ikuya Awashiro <email address hidden> wrote:
> *** This bug is a duplicate of bug 44626 ***
> https://bugs.launchpad.net/bugs/44626
>
> No, No, this is not a duplicate.
> I can confirm this bug on Hardy.
> This is because scim cannot start when skim is installed.
> So, this is scim-bridge's issue.
>
> Here is the debdiff.
>
> ** Attachment added: "scim-bridge_0.4.14-1ubuntu3.debdiff"
> http://launchpadlibrarian.net/12683053/scim-bridge_0.4.14-1ubuntu3.debdiff
>
>
>
> --
> scim works in koffice but not in openoffice
> https://bugs.launchpad.net/bugs/119755
> You received this bug notification because you are a member of Ubuntu
> CJK Testers, which is a direct subscriber (via bug 44626).
>

SKIM itself is just a GUI program. It doesn't have XIM server function.
So, when we want to use XIM, scim should start.
If we want to use SKIM, launch skim -f -> icon right click -> configure -> frontend -> Other -> Panel Program to scim-panel-gtk.

s/scim-panel-gtk/scim-panel-kde/

Rolf Leggewie (r0lf) wrote :

Is this still an issue?

Changed in scim (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Horacio (hsanson) wrote :

I have no problems with Japanese in Kubuntu 9.04 using anthy and skim. I can perfectly write Japanese in all applications including all openoffice apps, kde pim apps, konsole, konqueror, firefox, dolphin, amarok and digikam that are the applications I use most.

  ありがとうです。

Rolf Leggewie (r0lf) wrote :

Horacio, thank you for reporting back. What is the experience of everybody else?

Zorael (zorael) wrote :

I have to manually modify the xinput.d file to get proper support in OpenOffice; out of the box it's incomplete. I'm running Kubuntu 9.04.

Basically the environmental variables XIM and XIM_PROGRAM aren't set properly, while GTK_IM_MODULE and QT_IM_MODULE is.

The top of /etc/X11/xinit/xinput.d/skim looks like this immediately after installation:

       XIM=SCIM
       XIM_PROGRAM=

...and it needs to look like this for OpenOffice, xterm, and other XIM stuff to work.

       XIM=SCIM
       XIM_PROGRAM=/usr/bin/scim
       XIM_ARGS="-d"
       XIM_PROGRAM_SETS_ITSELF_AS_DAEMON=yes

Assuming the locale is set to use /etc/X11/xinit/xinput.d/skim (via im-switch), restarting X after making these changes makes skim work in everything.

Rolf Leggewie (r0lf) wrote :

Looks like this is working for everybody now with the limitations as given by Zorael. Closing the ticket.

Zorael, please open a new ticket against the skim package requesting /etc/X11/xinit/xinput.d/skim to be changed as you documented here.

Changed in scim (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers