'*' expression cannot be used in Chanjie anymore

Bug #42094 reported by Shu Hung (Koala) on 2006-04-29
6
Affects Status Importance Assigned to Milestone
scim-tables (Debian)
Fix Released
Unknown
scim-tables (Ubuntu)
Medium
Ming Hua

Bug Description

I'm a Chinese linux user and have used SCIM as my Chinese input method for a more than a year. I updated with dapper development weekly and a month or 2 ago, I found SCIM removed a useful feature.

As you may know, Chinese input method usually done by typing in a set of composition code for every character input so the input method can sort out the character I want within serveral 10,000.

Before the change, I can use the key '*' within the set and SCIM will try 'any one or more than one' code for that '*'. For example, if I type 'j*i' and SCIM will show me a list of characters with 'jqhi' and etc that matches. It is highly useful since quite frequently people do forget some part of code sets.

However, after the change, SCIM does not receive any '*' input anymore.

I'm not quite sure if it is a change of SCIM or other components in ubuntu, but this change really upset me and, I believe, many other SCIM users.

Is there anybody who is kind enough to check it out?
Thanks

Ming Hua (minghua) wrote :

This bug is also reported and confirmed in Debian. Also, it belongs to scim-tables instead of scim.

Changed in scim:
status: Unconfirmed → Confirmed
Changed in scim-tables:
status: Unknown → Confirmed
Changed in scim-tables:
status: Confirmed → Fix Committed
Changed in scim-tables:
status: Fix Committed → Fix Released

Dear all,
I've updated to the latest version of scim-tables in ubuntu ().
The problem is not solved yet.

Regards,
Koala Yeung

On 11/15/06, Bug Watch Updater <email address hidden> wrote:
>
> ** Changed in: scim-tables (Debian)
> Status: Fix Committed => Fix Released
>
> --
> '*' expression cannot be used in Chanjie anymore
> https://launchpad.net/bugs/42094
>

Ming Hua (minghua) wrote :

This bug was fixed in scim-tables 0.5.6-2. Feisty is released with 0.5.6-2. So I am changing it to "fix released". If you still see this bug in the final feisty release, please report.

Changed in scim-tables:
assignee: nobody → minghua
status: Confirmed → Fix Released
Shu Hung (Koala) (koalay) wrote :

Will the new scim back-port to Dapper?
It is after all a long term support.

Regards,
Koala Yeung

On 5/10/07, Ming Hua <email address hidden> wrote:
>
> This bug was fixed in scim-tables 0.5.6-2. Feisty is released with
> 0.5.6-2. So I am changing it to "fix released". If you still see this
> bug in the final feisty release, please report.
>
> ** Changed in: scim-tables (Ubuntu)
> Assignee: (unassigned) => Ming Hua
> Status: Confirmed => Fix Released
>
> --
> '*' expression cannot be used in Chanjie anymore
> https://bugs.launchpad.net/bugs/42094
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ming Hua (minghua) wrote :

> Will the new scim back-port to Dapper?

Sorry, I am not involved with backport efforts. Please follow the instructions on https://wiki.ubuntu.com/BackportRequestProcess to request backports.

Also, your request sounds more like a stable release update issue. Please also read https://wiki.ubuntu.com/StableReleaseUpdates and see which is more appropriate, and follow the procedures.

Good luck.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.