Ubuntu

UVFe for scim-bridge from 0.2.7 to 0.4.6

Reported by ZhengPeng Hou on 2006-10-15
6
Affects Status Importance Assigned to Milestone
scim-bridge (Ubuntu)
Wishlist
MOTU Release Team

Bug Description

Binary package hint: scim-bridge

scim-bridge is a wrapper libray for SCIM, writen in C. Recently, upstream author add the support for qt_immodule for scim, it can solve bugs reported on scim-qtimm or relate to (guys use kubuntu can not input CJK using scim in 3rd qt stuffs.). Also author has fix improved the support of gtk_immodule for scim.
The packages for edgy are ok now, need to be approved.

ZhengPeng Hou (zhengpeng-hou) wrote :

diffstat of the upstream tarballs

description: updated
ZhengPeng Hou (zhengpeng-hou) wrote :

diffstat of the upstream tarballs

ZhengPeng Hou (zhengpeng-hou) wrote :

 diff of the Upstream

ZhengPeng Hou (zhengpeng-hou) wrote :

pbuilderlog

Changed in scim-bridge:
assignee: nobody → motu-uvf
importance: Undecided → Wishlist
Reinhard Tartler (siretart) wrote :

The changes look a bit too big for this point of edgy's development. apt does not reveal any reverse depends. ZengPeng, could you perhaps give us some sort of risk analyses? This package seems to be to provide a dynamic library, which is loaded by other apps.

Honestly, I have no idea about scim. Currently, I have the impression that this update has the potential to break in a lot of situations. Do you have arguments to weaken this impressions, like, how much testing your updated package has received?

2006/10/15, Reinhard Tartler <email address hidden>:
> The changes look a bit too big for this point of edgy's development. apt
> does not reveal any reverse depends. ZengPeng, could you perhaps give us
> some sort of risk analyses? This package seems to be to provide a
> dynamic library, which is loaded by other apps.
This package is for guys wanna use scim, maybe say alternate. In
ubuntu, we now use scim-gtk-immodule and scim-qtimm as immodule for
scim, but because of the C++ ABI issue, they have some problems, such
as 3rd packages like acrabat reader, skype,etc. So, there will has not
any risk using this package, many chinese are like scim-bridge,
because it can make them use scim more smoothly. as to the big changes
between this release and the one exist in ubuntu now, it add the qt
client, which can replace scim-qtimm. Actrually, I'd upgrade this
package when the author release 0.4.1, but there has some License
issue, so I poked the author, and now upsrteam was released under dual
license, so can I upgrade to the latest. Also from 0.2.7, upstream
author has done many improvement too, now it become more stable.
> Honestly, I have no idea about scim. Currently, I have the impression
> that this update has the potential to break in a lot of situations. Do
It will not break anything. 1. we have tested it months, and haven't
found any critical bugs. 2.
it's in universe, will not be installed defaultly.
> you have arguments to weaken this impressions, like, how much testing
> your updated package has received?

> --
> UVFe for scim-bridge from 0.2.7 to 0.4.6
> https://launchpad.net/bugs/66205
>

Daniel Holbach (dholbach) wrote :

I share Reinhard's view - although the changelog mentions a good bunch of fixes, we should have got this in earlier. There are now 10 days left until release.

ZhengPeng, can you make sure you and the cjk-testers team are default subscribers for the scim packages?

https://launchpad.net/distros/ubuntu/+source/ <package> /+subscribe

Andrew, Sebastian, what do you think?

Andrew Mitchell (ajmitch) wrote :

The changelog seems to detail mostly fixes from a quick glance - we wouldn't have much time to back out the change before release though. If it goes in, it should really go in in the next day or two. I'd give it a tentative +1

Colin Watson (cjwatson) wrote :

Action wasn't taken on this in time for Edgy, so it will have to happen early in Feisty.

Kai Kasurinen (kai-kasurinen) wrote :

There is 0.4.8-0ubuntu2 in Feisty.

Changed in scim-bridge:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers