Ubuntu

scim-bridge crahes due to segfault error 4 in libscim-1.0.so.8.2.4

Reported by Jimmy on 2010-05-01
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
scim-bridge (CentOS)
New
Undecided
Unassigned
scim-bridge (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Nominated for Lucid by Skippy le Grand Gourou

Bug Description

Binary package hint: scim-bridge

OS: Lucid, upgraded from Karmic

scim-bridge crashes sometimes with no apparent reason. It looks like it's happening at random.

From syslog:
May 1 16:53:46 my-laptop kernel: [ 2909.881392] scim-bridge[7302]: segfault at 10 ip 00007fa5e8e5d836 sp 00007fff3425ed98 error 4 in libscim-1.0.so.8.2.4[7fa5e8df2000+d1000]

Hans (hw56) wrote :

Same for me.

Just out of a sudden scim is not working anymore. It's now a zombie process. Didn't install or do anything else.

Alexserve kernel: [ 1606.137508] scim-launcher[4725]: segfault at a7d4500 ip 0024da98 sp bfa20660 error 4 in pinyin.so[215000+66000]

Rolf Leggewie (r0lf) wrote :

does it help to move the ~/.scim directory somewhere else?

Changed in scim-bridge (Ubuntu):
status: New → Incomplete

Same error message and exactly the same symptoms as Hans here, on a Karmic Koala. Scim crashed yesterday morning without any reason (apparently last update was 10 days ago, and scim has been used daily since then), and won't launch anymore.

Moving the ~/.scim directory does help a bit : it allows to launch scim again, but I still can't manage to get it working, scim-bridge regularly complains in syslog :
-----------------------------------------------------------------------------------------
scim-bridge: No such IMContext
scim-bridge: An invalid char is given at scim_bridge_string_to_uint (): -
scim-bridge: Invalid message: Close the connection.
-----------------------------------------------------------------------------------------

Mmh… For some reason it works again, but not in gnome-terminal, which I was using for testing — however I'm not sure it has ever worked in gnome-terminal on this setup (though I'm sure it works on other setups), since this is not my computer. So most probably (re)moving ~/.scim did the trick and the quoted messages are irrelevant.

Changed in scim-bridge (Ubuntu):
importance: Undecided → Low

Can this be reproduced, or can you provide the .scim directory? Would it be possible to get a backtrace of the segfault? If you could turn on apport, that would be great.

inductiveload (inductiveload) wrote :

I also have this problem. Scim has a lot of messages in my syslog like this:

------------
No such IMContext
scim-bridge: No such IMContext
An invalid char is given at scim_bridge_string_to_uint (): -
scim-bridge: An invalid char is given at scim_bridge_string_to_uint (): -
Invalid message: Close the connection.
scim-bridge: Invalid message: Close the connection.
-------------

Interestingly, this appears to be triggered by closing the "Find" dialogue in gEdit. I haven't found anything else that will trigger it on demand, but if I do I will report it here.

It also occasionally segfaults and crashes:

-------------
kernel: [11810.159614] scim-bridge[4352]: segfault at c ip 00ed8ecc sp bfe12bb8 error 4 in libscim-1.0.so.8.2.4[e80000+c2000]
-------------

An Apport report of the latest crash can be found at: https://bugs.launchpad.net/ubuntu/%2Bsource/scim-bridge/%2Bbug/649589

This crash was caused by logging out of the Ubuntu Forums website.

André Pirard (a.pirard) wrote :

Exactly the same problem with up to date Lucid and .scim has been renamed.
The same SCIM messages are filling my log.

Well, 5 persons have reported the same problem and every question has been answered,
The report still remains incomplete after 6 months and the priority has been set to low...

Language support says SCIM is required for characters needing several keystrokes.
But dead keys and the compose key were working here long before SCIM was born.
I'm not even supposed to use SCIM, I chose the recommended ibus.

May we uninstall SCIM safely and how? Is it needed beside very complex typing?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers