scim-bridge crashed with SIGSEGV in scim::IMEngineInstanceBase::get_frontend_data()

Bug #243344 reported by Daniel J Blueman on 2008-06-26
This bug affects 372 people
Affects Status Importance Assigned to Milestone
scim-bridge (Debian)
Fix Released
Unknown
scim-bridge (Fedora)
Won't Fix
High
scim-bridge (Ubuntu)
High
Unassigned
Nominated for Intrepid by Kevin
Nominated for Jaunty by Alex Mauer
Nominated for Karmic by KujiUn
Nominated for Lucid by Fabien Lesire

Bug Description

Binary package hint: scim-bridge

I had launched gedit and hit the open-file dialog and pressed escape a few times.

It's possible to reproduce it, seemingly by playing around with the focus and hitting escape quickly in succession.

ProblemType: Crash
Architecture: i386
Date: Thu Jun 26 21:54:28 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/scim-bridge
NonfreeKernelModules: nvidia
Package: scim-bridge-agent 0.4.14-1ubuntu2
PackageArchitecture: i386
ProcCmdline: scim-bridge
ProcEnviron:
 PATH=/store/users/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: scim-bridge
StacktraceTop:
 scim::IMEngineInstanceBase::get_frontend_data ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: scim-bridge crashed with SIGSEGV in scim::IMEngineInstanceBase::get_frontend_data()
Uname: Linux 2.6.24-19-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin plugdev scanner video

StacktraceTop:scim::IMEngineInstanceBase::get_frontend_data (this=0x0) at scim_imengine.cpp:314
ScimBridgeAgentIMContextImpl::focus_out (this=0x8084b00)
ScimBridgeAgentImpl::change_focus (this=0x80752b8, imcontext_id=13, focus_in=false)
ScimBridgeAgentClientListenerImpl::change_focus (this=0x8082798, imcontext_id=13,
ScimBridgeAgentClientListenerImpl::process_message (this=0x8082798, message=0x8083e80)

Changed in scim-bridge:
importance: Undecided → Medium
Vladislav Muravyev (rex-lux) wrote :

the same error, when trying to close evince.

clever_fox (clever-fox) wrote :

this bug appeared after putting comupter with mounted external disk to sleep, than wake and copying file from external disk to home dir

Description of problem:
]$ totem
** (totem:25091): DEBUG: Init of Python module
** (totem:25091): DEBUG: Registering Python plugin instance: YouTube+TotemPythonPlugin
** (totem:25091): DEBUG: Creating object of type YouTube+TotemPythonPlugin
** (totem:25091): DEBUG: Creating Python plugin instance

** (totem:25091): WARNING **: Unknown codec ID 86022, please add here
No accelerated IMDCT transform found
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
** (totem:25091): DEBUG: Finalizing Python plugin instance

$cat ~/.xsession-errors
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
An IOException occurred at handle_message ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()

$ dmesg | grep scim
scim-bridge[4318]: segfault at c ip 00190297 sp bfe6871c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[23142]: segfault at c ip 00190297 sp bff3c8fc error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[23211]: segfault at c ip 00190297 sp bf99a35c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25007]: segfault at 433d454d ip 001982f7 sp bfaadf30 error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25009]: segfault at c ip 00190297 sp bff28d6c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25088]: segfault at c ip 00190297 sp bfe4247c error 4 in libscim-1.0.so.8.2.3[133000+cf000]

Version-Release number of selected component (if applicable):
0.4.15-7.fc10

How reproducible:
always

Steps to Reproduce:
1. Searching youtube on totem.
2. play youtube
3. Click Esc

Actual results:

Expected results:

Additional info:
totem-2.24.2-2.fc10.i386

rekado (rekado) on 2008-10-19
Changed in scim-bridge:
status: New → Confirmed
frankieus (frankieus) wrote :

It happens every time I try to type a password in Seahorse (the password and encryption keys application for ubuntu) in order to update an existing key. Seahorse freezes and crashes and then I get this scim-brigde error.

When removing the support for complex characters in the Language Support, Seahorse would let me type passwords again to update keys.

greatlinux (greatlinux) wrote :

I am using firefox, I click open-file, when the dialog appear, click cancel, it crashed

This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

in Rawhide
Launch gnome-volume-control -> Select device in input or output tab -> Click ESC key -> scim-bridge Segfault
$gnome-volume-control
[...]
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()

$ dmesg | grep scim
scim-bridge[3353]: segfault at c ip 00190297 sp bfd49d5c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3741]: segfault at c ip 00190297 sp bfe5493c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3916]: segfault at c ip 00190297 sp bf83a0ac error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3979]: segfault at c ip 00190297 sp bfdff0dc error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[4030]: segfault at c ip 00190297 sp bfa7c0ec error 4 in libscim-1.0.so.8.2.3[133000+cf000]

$ rpm -q scim-bridge gnome-media scim
scim-bridge-0.4.15-8.fc11.i386
gnome-media-2.25.1-1.fc11.i386
scim-1.4.7-35.fc10.i386

Julio Pedreira (julio.pedreira) wrote :

Same here.

After rotating cube. I can't reproduce it rotating cube again, but I can reporduce with gedit as described in first post.

Changed in scim-bridge:
status: Unknown → In Progress

I found the patch and made debdiff.
Please apply it.

Didier DOMINE (didier-domine) wrote :

Occured when trying to launch compiz : see hereafter

didier@didier-desktop:~$ compiz
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1440x900) to maximum 3D texture size (4096): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: present.
Checking for FBConfig: present.
running under gnome seesion, checking for gnomecompat
Checking for Xgl: not present.
/usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

This issue is happening to me every startup :-(

Same for me.

Le samedi 28 mars 2009 à 07:12 +0000, Oumar Aziz OUATTARA a écrit :
> This issue is happening to me every startup :-(
>

Don Cristóbal (doncristobal) wrote :

Maybe Bug https://bugs.launchpad.net/ubuntu/+source/scim-bridge/+bug/355332 is a duplicate. I don't use seahorse, but my computer had been to sleep before.

Don Cristóbal (doncristobal) wrote :

One more error report.

Newest scim-bridge is available from here:
https://launchpad.net/~japanese-testers/+archive/ppa
Please try it.

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Rolf Leggewie (r0lf) wrote :

still an issue in Jaunty or Karmic? How about the packages provided by Ikura, do they fix the crash?

Changed in scim-bridge (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

Ikuya, thank you for your quick comment and my sincere apologies for misspelling your name. It's nice to see that Karmic has the newest packages. But did they indeed fix these crashes? For those that experienced them, can you try a live CD or live USB?

Hi Rolf,

> my sincere apologies for misspelling your name.
Don't mind.

scim-bridge 0.4.16 is applied some patches such comment #9.
So, this issues is fixed hopefully.

Thanks,

s/issues/issue/

Fabien Tassin (fta) wrote :

This is happening to me on Karmic x64 using scim-bridge-agent 0.4.16-2ubuntu2

Rolf Leggewie (r0lf) on 2009-07-16
Changed in scim-bridge (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
status: Incomplete → Confirmed
Facundo Batista (facundo) wrote :

This is happening for me, using 0.4.16-2ubuntu2.

As it's a new version (this bug talks about an older one), and a patch was applied, and it says it should be fixed, I opened a new bug: #409347

Jack Leigh (leighman) wrote :

Happened when using software-store, here

Rob Speer (rspeer) wrote :

I also got this while using Software Center.

I have the similar (maybe the same) problem, but unrelated to totem: from time to time scim-bridge crashes, leaving all my gnome-terminals, galeon, and the mini_commander_applet without the keyboard input. I can switch to the text console, and in "ps ax|grep scim" I see the following processes:

 3514 ? Ss 0:00 /usr/lib64/scim-1.0/scim-helper-manager
 3515 ? Ssl 0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 3517 ? Ss 0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d

When I kill the scim-launcher process, all the processes get restarted, leading to the following "ps ax|grep scim" output:

 7204 ? Ss 0:00 /usr/lib64/scim-1.0/scim-helper-manager
 7205 ? Ssl 0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 7207 ? Ss 0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d
 7209 ? Ss 0:00 /usr/lib64/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay -d
 7210 ? S 0:00 scim-bridge

and since then, the text input to gnome-terminal, galeon, and all the other GNOME apps works fine. The relevant part of .xsession-errors is probably the following one (altough I am not sure - I am writing this bug report some time after the last scim-bridge crash):

===============================
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
The messenger is now down
** Message: Active session changed
** Message: Active session changed
An IOException at scim_bridge_messenger_receive_message (): Connection reset by peer
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_register_imcontext ()
Cannot register the IMContexts...
nt_register_imcontext ()
Cannot register the IMContexts...
The messenger is now down
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.8

Starting SCIM as daemon ...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
===============================

I think this started in F11 for me (I use scim-bridge for a longer time). Also, my system is x86_64, so the Platform: attribute of this bug can be changed to "All".

(In reply to comment #5)
> I think this started in F11 for me

Could you try to reproduce with the scim-bridge from f10 then?

(Additional comment: our general advice would be to switch to ibus
though - we are not really supporting scim as the primary input
method system in fedora.)

I can reproduce the bug as described in comment #2 on a F11 system with F10 scim-bridge:

scim-bridge-0.4.15-8.fc10.x86_64
scim-bridge-gtk-0.4.15-8.fc10.x86_64
scim-bridge-gtk-0.4.15-8.fc10.i386

I will try ibus later.

Rob Candee (rob-candee) wrote :

I have run into this for the first time upon upgrading from 9.04 to 9.10. The bug I opened (Bug 460149) was marked as a duplicate of this bug. I am running the 64-bit Ubuntu 9.10 release candidate, having just upgraded via upgrade-manager -d.

on xubuntu upgrade from jaunty, when running liferea+rhythmbox+firefox , the same bug appears

forumboy (cash-05) wrote :

I have run into this for the first time upon upgrading from 9.04 to 9.10, got this while using Software Center.

TraceyC (grrlgeek) wrote :

Like forumboy, I got this error using Software Center in 9.10 32 bit. I had just upgraded from 9.04 a couple of days ago.

1 - Open the Ubuntu Software Center
2 - Click the Programming category
3 - Receive error

Software Center continued to be functional.

Dave Espionage (daveespionage) wrote :

this tends to happen whenever I open Ubutu Software Center, this specific instance I was starting to search for a twitter client and hadn't begun to type when the error popped up. I was also in the middle of reporting a crash due to a hibernation restore failure.

Dell Inspiron 6400, Ubuntu 9.10

Nick B (nickb-symbian) wrote :

FWIW having upgraded to Karmic, this happens all the time when I start my work machine now. So many programs loaded from session it's hard to say which is at fault, it might be firefox or thunderbird or eclipse or nautilus, who knows.

What does happen is all text input gets sluggish afterwards, at least until I kill -9 scim-bridge (which doesn't last long as it seems to respawn).

Might just go ahead and uninstall the whole thing until this is fixed :(

Nick B wrote:
> FWIW having upgraded to Karmic, this happens all the time when I start
> my work machine now. So many programs loaded from session it's hard to
> say which is at fault, it might be firefox or thunderbird or eclipse or
> nautilus, who knows.
>
> What does happen is all text input gets sluggish afterwards, at least
> until I kill -9 scim-bridge (which doesn't last long as it seems to
> respawn).
>
> Might just go ahead and uninstall the whole thing until this is fixed :(

does deleting ~/.scim/ help?

BTW: we switched over to IBus for Karmic, you could give it a try.
Just run System->Administration->Language Support and select ibus as
your preferred keyboard input method framework. After restarting your
session, you should have IBus working. What you need to do then, is to
right click on the keyboard icon in the notification area, choose
Preferences, select the Input Method tab and add the input methods you
like. That is, select them from the combobox and click the Add button.
Then you can use IBus like you used SCIM before.

Jimmy (jimmy-axenhus) wrote :

I got this bug when clicking Internet in Ubuntu Softare Center right after loading it. Not able to reproduce it.

kamereon (kamereon) wrote :

that IBus tip is great, Arne! Seems to make SCIM obsolete, working flawlessly so far. Too bad, not too many people seem to have ever heard about it...

Dave Espionage (daveespionage) wrote :

I looked at IBus but it doesn't have Zhuyin input method as an installable option, so SCIM is all I can use right now. It seems to recover itself from the crash just fine, its just tedious that it dies so often. Usually when using the Software Center

Arne Goetje (arnegoetje) wrote :

Dave Espionage wrote:
> I looked at IBus but it doesn't have Zhuyin input method as an
> installable option, so SCIM is all I can use right now. It seems to
> recover itself from the crash just fine, its just tedious that it dies
> so often. Usually when using the Software Center
>

For Zhuyin use Chewing, the package is ibus-chewing.

Flemming Christensen (laoshi) wrote :

Crash in ubuntu-one happened when I was editing network-connections in nm-applet. After reboot all was ok again

jeremy-list (quick-dudley) wrote :

IBus also prevents you from using deadkeys in qt4 applications: I personally find that a worse problem than the SCIM crash.

Re: comment #7

I have switched to ibus and have not seen any IM-related crash since then.
It would be nice to have this bug fixed, but as for me, I don't care anymore :-)

Changed in scim-bridge (Debian):
status: Unknown → New

Please tell me how to reproduce this issue.
I cannot do...

Sorry i sant, i had this problem some weeks but now it's gone. Hurray
And the behave of Ubuntu 9.10 is getting better and better.

Med Hilsen
Kjetil Kleven
Brennstubben 29
2080 Eidsvoll
Mob. 92 02 36 74

2009/12/1 Ikuya Awashiro <email address hidden>

> Please tell me how to reproduce this issue.
> I cannot do...
>
> --
> scim-bridge crashed with SIGSEGV in
> scim::IMEngineInstanceBase::get_frontend_data()
> https://bugs.launchpad.net/bugs/243344
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “scim-bridge” package in Ubuntu: Confirmed
> Status in “scim-bridge” package in Debian: New
> Status in “scim-bridge” package in Fedora: In Progress
>
> Bug description:
> Binary package hint: scim-bridge
>
> I had launched gedit and hit the open-file dialog and pressed escape a few
> times.
>
> It's possible to reproduce it, seemingly by playing around with the focus
> and hitting escape quickly in succession.
>
> ProblemType: Crash
> Architecture: i386
> Date: Thu Jun 26 21:54:28 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/scim-bridge
> NonfreeKernelModules: nvidia
> Package: scim-bridge-agent 0.4.14-1ubuntu2
> PackageArchitecture: i386
> ProcCmdline: scim-bridge
> ProcEnviron:
>
> PATH=/store/users/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> Signal: 11
> SourcePackage: scim-bridge
> StacktraceTop:
> scim::IMEngineInstanceBase::get_frontend_data ()
> ?? ()
> ?? ()
> ?? ()
> ?? ()
> Title: scim-bridge crashed with SIGSEGV in
> scim::IMEngineInstanceBase::get_frontend_data()
> Uname: Linux 2.6.24-19-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin plugdev
> scanner video
>

phudaica (saobang2871987) wrote :
Download full text (3.6 KiB)

Thank you very much! i had update ubuntu 9.04 up 9.10 and had that problem
with many programes.
Some programes cant run. Now i installed ubuntu 9.10 and it run very smooth.

On Tue, Dec 1, 2009 at 2:21 PM, Kjetil Kleven <email address hidden>wrote:

> Sorry i sant, i had this problem some weeks but now it's gone. Hurray
> And the behave of Ubuntu 9.10 is getting better and better.
>
>
> Med Hilsen
> Kjetil Kleven
> Brennstubben 29
> 2080 Eidsvoll
> Mob. 92 02 36 74
>
>
> 2009/12/1 Ikuya Awashiro <email address hidden>
>
> > Please tell me how to reproduce this issue.
> > I cannot do...
> >
> > --
> > scim-bridge crashed with SIGSEGV in
> > scim::IMEngineInstanceBase::get_frontend_data()
> > https://bugs.launchpad.net/bugs/243344
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
> > Status in “scim-bridge” package in Ubuntu: Confirmed
> > Status in “scim-bridge” package in Debian: New
> > Status in “scim-bridge” package in Fedora: In Progress
> >
> > Bug description:
> > Binary package hint: scim-bridge
> >
> > I had launched gedit and hit the open-file dialog and pressed escape a
> few
> > times.
> >
> > It's possible to reproduce it, seemingly by playing around with the focus
> > and hitting escape quickly in succession.
> >
> > ProblemType: Crash
> > Architecture: i386
> > Date: Thu Jun 26 21:54:28 2008
> > DistroRelease: Ubuntu 8.04
> > ExecutablePath: /usr/bin/scim-bridge
> > NonfreeKernelModules: nvidia
> > Package: scim-bridge-agent 0.4.14-1ubuntu2
> > PackageArchitecture: i386
> > ProcCmdline: scim-bridge
> > ProcEnviron:
> >
> >
> PATH=/store/users/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> > LANG=en_GB.UTF-8
> > SHELL=/bin/bash
> > Signal: 11
> > SourcePackage: scim-bridge
> > StacktraceTop:
> > scim::IMEngineInstanceBase::get_frontend_data ()
> > ?? ()
> > ?? ()
> > ?? ()
> > ?? ()
> > Title: scim-bridge crashed with SIGSEGV in
> > scim::IMEngineInstanceBase::get_frontend_data()
> > Uname: Linux 2.6.24-19-generic i686
> > UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin plugdev
> > scanner video
> >
>
> --
> scim-bridge crashed with SIGSEGV in
> scim::IMEngineInstanceBase::get_frontend_data()
> https://bugs.launchpad.net/bugs/243344
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “scim-bridge” package in Ubuntu: Confirmed
> Status in “scim-bridge” package in Debian: New
> Status in “scim-bridge” package in Fedora: In Progress
>
> Bug description:
> Binary package hint: scim-bridge
>
> I had launched gedit and hit the open-file dialog and pressed escape a few
> times.
>
> It's possible to reproduce it, seemingly by playing around with the focus
> and hitting escape quickly in succession.
>
> ProblemType: Crash
> Architecture: i386
> Date: Thu Jun 26 21:54:28 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/scim-bridge
> NonfreeKernelModules: nvidia
> Package: scim-bridge-agent 0.4.14-1ubuntu2
> PackageArchitecture: i386
> ProcCmdline: scim-bridge
> ProcEnviron:
>
> PATH=/store/users/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbi...

Read more...

We have changed the default input framework to ibus. Please try it.

Arne, is this still an issue? Considering that Ubuntu uses iBus now, what should we do with this bug? Is there a fix upstream?

Changed in scim-bridge (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
Rolf Leggewie (r0lf) wrote :

Rick, thank you for your comment. It is correct that ibus is the preferred input method over scim since karmic. That doesn't mean we close bugs in scim (unless you suggest we close them as wontfix which I don't think is a good idea).

This ticket got a lot of discussion mixed in. That's helpful for the users but not helpful for resolving the bug. Let me reiterate Ikuya's question. Is there anybody who can confirm or disconfirm that this bug still exists in Karmic (or even Lucid)? phudacia, are you using scim or ibus?

The comments seem to indicate that this bug does no longer exist in Karmic. Please speak up if you still have this issue. This ticket is otherwise slated for closure as "fix released" in due time.

Arne Goetje (arnegoetje) on 2010-03-16
Changed in scim-bridge (Ubuntu):
assignee: Arne Goetje (arnegoetje) → nobody
tmin (na8ctm) wrote :
Bomber Cheng (tomcheng76) wrote :

This is my workaround to solve the scim crash (use scim-immodule as the xinput). Not sure is it help to solve this bug.

First, install scim-immodule as alternative, replace zh_TW with your locale, if you use english, it can be all_ALL
sudo update-alternatives --install /etc/X11/xinit/xinput.d/zh_TW xinput-zh_TW /etc/X11/xinit/xinput.d/scim-immodule 10

then config it
sudo update-alternatives --config xinput-zh_TW
or
sudo im-switch -s scim-immodule

then create a file /etc/profile.d/scim.sh with -rw-r--r-- root root permission
add this three line
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim

Lastly, i can see inside /etc/X11/xinit/xinput.d/scim, the module is xim instead of scim. I am not sure is this make the problem.

Hope someone find this useful, at least user level.

Rolf Leggewie (r0lf) wrote :

we still have no confirmation that this bug still exists in Karmic or Lucid. As such, I'll close this bug in about two weeks' time unless somebody confirms that this ticket is still present in Lucid. Feel free to use one of the Live CD to test.

Changed in scim-bridge (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete

Tôi đang sử dụng Gmail và nghĩ rằng bạn có thể muốn thử dịch vụ
này. Đây là thư mời để tạo tài khoản.

  Bạn được Mời Đăng ký Gmail!

Phu Nguyen Ngoc đã mời bạn mở tài khoản Gmail.

Gmail là dịch vụ email miễn phí của Google, được xây dựng trên ý tưởng rằng
email có thể trực quan, hiệu quả và thú vị. Gmail có:

 *Ít spam hơn*
Loại bỏ thư không mong muốn khỏi hộp thư đến bằng công nghệ tiên tiến của
Google.

*Dung lượng lớn*
Đủ dung lượng để bạn không bao giờ phải xoá thư khác.

*Tính năng trò chuyện được tích hợp sẵn*
Trò chuyện văn bản hoặc video với Phu Nguyen Ngoc và bạn bè khác trong thời
gian thực.

*Truy cập từ điện thoại di động*
Truy cập email của bạn ở bất cứ đâu bằng Gmail trên điện thoại di động của
bạn.

Bạn thậm chí có thể nhập danh sách liên hệ và email của mình từ Yahoo!,
Hotmail, AOL hoặc bất kỳ tài khoản thư trên web hoặc POP nào khác.

Sau khi tạo tài khoản của mình, Phu Nguyen Ngoc bạn sẽ được thông báo địa
chỉ Gmail mới để bạn có thể giữ liên lạc. Tìm hiểu
thêm<http://mail.google.com/mail/help/intl/vi/about.html>hoặc bắt
đầu<http://mail.google.com/mail/a-7e2523763e-5b64f980c8-MOYBGY4AQnEFe94P0gi_B-bwtx8>
!
        Đăng ký<http://mail.google.com/mail/a-7e2523763e-5b64f980c8-MOYBGY4AQnEFe94P0gi_B-bwtx8>

Google Inc. | 1600 Ampitheatre Parkway | Mountain View, California 94043

Rolf Leggewie (r0lf) wrote :

no confirmations received. Closing as fixed. Please reopen if you still experience this in karmic, lucid or maverick.

Changed in scim-bridge (Ubuntu):
status: Incomplete → Fix Released
Rolf Leggewie (r0lf) wrote :

lots of reports for maverick. reopening.

Changed in scim-bridge (Ubuntu):
status: Fix Released → Confirmed
Rolf Leggewie (r0lf) on 2010-10-25
Changed in scim-bridge (Ubuntu):
importance: Medium → High
Rolf Leggewie (r0lf) on 2011-04-07
Changed in scim-bridge (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
Changed in scim-bridge (Debian):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

scim-bridge was rewritten fro scratch and has moved to the scim package. Please reopen a ticket there if you still experience this problem. You can reference this bug if what you see is similar

Changed in scim-bridge (Ubuntu):
status: Confirmed → Won't Fix
Changed in scim-bridge (Fedora):
importance: Unknown → High
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.