Sync scim-anthy 1.2.7-1 (universe) from Debian unstable (main).

Bug #407649 reported by Rolf Leggewie on 2009-08-01
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kasumi (Ubuntu)
Undecided
Unassigned
scim-anthy (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync scim-anthy 1.2.7-1 (main) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:

Ubuntu got ahead of Debian in packaging scim-anthy 1.2.7. I based the current
version in Debian on the one currently in Karmic/Jaunty. There is no remaining
delta, it's safe to sync.

Changelog since current karmic version 1.2.7-0ubuntu1:

scim-anthy (1.2.7-1) unstable; urgency=low

  * new upstream release, push back from Ubuntu Jaunty. (Closes: #503764)
  * debian/control
    - drop Tagoh-san from uploaders. (Closes: #508203)
    - add myself to uploaders
    - add Homepage and Vcs-* fields
    - recommend instead of suggest kasumi (LP: #332041)
  * update standards to 3.8.2
    - update to debhelper 5
    - use config.sub and config.guess from host instead of patching
    - better error handling for distclean

 -- Rolf Leggewie <email address hidden> Tue, 21 Jul 2009 17:34:03 +0200

scim-anthy (1.2.7-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #329435)
  * debian/patches/00list: removed 11_gcc-4.3_fixes.dpatch
    Already included by upstream.

 -- Ikuya Awashiro <email address hidden> Sat, 14 Feb 2009 15:12:42 +0000

Daniel Holbach (dholbach) wrote :

To get kasumi supported out of the box (move to recommends), it'd need to be in main too. https://wiki.ubuntu.com/MainInclusionProcess that'd need to be followed for that.

Rolf Leggewie (r0lf) wrote :

Daniel, thank you for pointing that out. I'm completely unaware of the MIR process and thus can't help move it forward for kasumi. As Debian maintainer for both scim-anthy and kasumi, I'm of course willing to help where I can and answer questions. But I think somebody else familiar with MIR should act as the driver.

Daniel Holbach (dholbach) wrote :

Arne: can you try to make a decision here how we move forward? As I see it it's either
 - diverge from Debian and move kasumi back to Suggests or
 - include kasumi in Main through MIR process.

Arne Goetje (arnegoetje) wrote :

I think the best for now would be to diverge from Debian, move kasumi to Suggests and see how it goes.

Arne Goetje wrote:
> I think the best for now would be to diverge from Debian, move kasumi to
> Suggests and see how it goes.
>

Fair enough.

As far as "see how it goes" is concerned, there isn't really any
guesswork needed. You'll be reintroducing bug 332041, nothing more yet
nothing less.

Rolf Leggewie (r0lf) wrote :

<email address hidden> wrote:
> nothing more yet nothing less.

plus, of course, you'll be forever stuck in merge mode despite the
efforts I put into making sync possible again.

@Rolf: you could have linked bug 332041 here earlier, then I would have known what's going on. ;)

In that case it makes sense to write a MIR for kasumi and get it into main. ibus-anthy should also benefit from that in the future.
Will do that today.

Arne Goetje (arnegoetje) wrote :

MIR is here: https://wiki.ubuntu.com/MainInclusionReport/Kasumi

@Rolf: Can you please review, add missing information if any and set your name below the report? Thanks.

When compiling the package on my machine, I noticed the following output:

-------------------- snip ---------------------------
dpkg-shlibdeps: warning: dependency on libfontconfig.so.1 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libatk-1.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libgio-2.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libgdk_pixbuf-2.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libcairo.so.2 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libpango-1.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libgmodule-2.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libpangocairo-1.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libfreetype.so.6 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
dpkg-shlibdeps: warning: dependency on libpangoft2-1.0.so.0 could be avoided if "debian/kasumi/usr/bin/kasumi" were not uselessly linked against it (they use none of its symbols).
-------------------- snip ---------------------------

Anything to do about that? Or should we ignore those claims?

And the following lintian warnings:

Now running lintian...
W: kasumi: copyright-without-copyright-notice
W: kasumi: desktop-entry-invalid-category Applications /usr/share/applications/kasumi.desktop
W: kasumi: menu-item-uses-apps-section /usr/share/menu/kasumi:2
W: kasumi: menu-item-creates-new-section Apps/Tools /usr/share/menu/kasumi:2
Finished running lintian.

Not sure how serious they are, please comment.

Arne Goetje wrote:
> @Rolf: you could have linked bug 332041 here earlier, then I would have
> known what's going on. ;)
>

RTFC ;-)

It's all right there in the changelog in comment 0

/me whistles

Thank you for your testing and getting the MIR process moving. I had
seen the errors you posted. Like many Japanese packages, kasumi had a
few problems. I only tackled the really big ones first. I'm aware that
there is more to do in the future. I wasn't thinking kasumi might be
going MIR when I uploaded it to Debian ;-) Expect more packaging fixes
in the future, but I don't commit to any definitive schedule.

It would be nice if Launchpad understood (LP: #nnn) and (Closes: #nnn) -> bug 419675

BTW, I think I already fixed some of the errors in Vcs: http://git.debian.org/?p=collab-maint/kasumi.git

Rolf Leggewie (r0lf) wrote :

I had reported the unnecessary runtime dependencies at the end of July in bug 403189, but have not had time to look further into the matter so far. It's certainly not nice, but not highest priority either, IMHO.

Loïc Minier (lool) wrote :

Superfluous link flags > either fix the build to use exactly the right libs for all objects, or build things with -Wl,-z,defs -Wl,--as-needed. The latter will cause superfluous link flags to dropped by ld, and the former will first check whether all symbols can be resolved which is a good idea when you're using --as-needed in some complex cases.

All the lintian warnings listed are fairly minor but can also be easily fixed.

I see scim-anthy is listed in this bug which is both a MIR and a request to sync; it's getting a bit complex to deal with three things at once for 2 MIRs and a sync in the same bug; could you please split things and explain which packages you're proposing to include in main for which reason?

Thanks!

Loïc Minier (lool) wrote :

I filed bug #424238 for the kasumi MIR.

Changed in kasumi (Ubuntu):
status: New → Invalid
Martin Pitt (pitti) wrote :

Blocked on kasumi MIR, which is blocked for further input from reporter.

Changed in scim-anthy (Ubuntu):
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

kasumi is progressing slowly, but nicely. I expect an upload to Debian later tonight. I'll keep you posted. I think a similar clean-up to the build system as was done to kasumi would also benefit the scim-anthy package. I've statrted a bit of work on this. Depending on the progress we may want to sync 1.2.7-2.

Martin Pitt (pitti) wrote :

We do not need scim in main any more, since we use ibus now. Thus I demoted all the scim packages to universe, and consequently we can sync them all now.

Sponsor sync approval.

Changed in scim-anthy (Ubuntu):
status: Incomplete → Confirmed
Rolf Leggewie (r0lf) wrote :

fair enough

subscribing MOTU sponsors to get a sync

Benjamin Drung (bdrung) on 2010-02-05
summary: - Sync scim-anthy 1.2.7-1 (main) from Debian unstable (main).
+ Sync scim-anthy 1.2.7-1 (universe) from Debian unstable (main).
Benjamin Drung (bdrung) wrote :

scim-anthy 1.2.7-1 builds, sync request ACK'd

Changed in scim-anthy (Ubuntu):
importance: Undecided → Wishlist
James Westby (james-w) wrote :

[Updating] scim-anthy (1.2.7-0ubuntu1 [Ubuntu] < 1.2.7-1 [Debian])
 * Trying to add scim-anthy...
  - <scim-anthy_1.2.7-1.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <scim-anthy_1.2.7-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <scim-anthy_1.2.7.orig.tar.gz: already in distro - downloading from librarian>
I: scim-anthy [universe] -> scim-anthy_1.2.7-0ubuntu1 [universe].

Changed in scim-anthy (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers