FeatureFreezeException: Please sync scilab-5.1 (multiverse) from PPA

Bug #272264 reported by Jurgis Pralgauskis on 2008-09-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Medium
Christoph Korn
scilab (Baltix)
Undecided
Mantas Kriaučiūnas
scilab (Debian)
Fix Released
Undecided
Unassigned
scilab (Ubuntu)
Wishlist
Morten Kjeldgaard
Jaunty
Wishlist
Morten Kjeldgaard

Bug Description

Please sync scilab-5.1 from this PPA.
https://launchpad.net/~getdeb.packages/+archive/ppa

Changelog since current jaunty 4.1.2-6.
scilab (5.1-1~ppa2) jaunty; urgency=low

  * New upstream release
  * Some patches removed (included upstream)
  * Better watch file
  * Missing dep to pkg-config

 -- Christoph Korn <email address hidden> Thu, 12 Feb 2009 18:34:41 +0100

scilab (5.0.3-11) intrepid; urgency=low

  [ Sylvestre Ledru ]
  * Missing dep to ant & docbook-xsl
  * Information about the LGPL added in the copyright file
  * Force a minimal version of jeuclid
  * Install the icon
  * Fix a problem in the scilab.desktop file (thanks to Christoph Korn)
  * Icons added to the menu item

  [ Christoph Korn ]
  * Installing desktop file.
  * Adding missing commata in debian/control
  * patches/link-doc.diff:
      Fix french documentation:
      http://bugzilla.scilab.org/show_bug.cgi?id=3918
  * patches/switchOrder.diff,
    patches/xmltoformat-2.diff,
    patches/xmltoformat.diff
       This should finally fix bug 3918
  * debian/scilab.desktop:
    Categories=Education;Science;Math;Development;Physics;

 -- Christoph Korn <email address hidden> Thu, 05 Feb 2009 00:06:29 +0100

scilab (5.0.3-2) experimental; urgency=medium

  * Warnings removed on startup
  * Tests moved to scilab-test package

 -- Sylvestre Ledru <email address hidden> Sat, 22 Nov 2008 10:28:30 +0100

scilab (5.0.3-1) experimental; urgency=medium

  * New upstream version (Closes: #483682, #499565, #486876)
    Massive changes in the package construction
  * Package moved to main since Scilab is free (CeCILL license)
  * modelicac, intersci and scilab manpages added

 -- Sylvestre Ledru <email address hidden> Fri, 1 Oct 2008 13:37:08 +0200

While incorporating Scilab into Ubuntu, please change the revision number to match the one from Debian Science -6 for now.

Sylvestre Ledru is the author of the patches and the debian directory comes from debian-science.
http://svn.debian.org/viewsvn/debian-science/packages/scilab/trunk/debian/

Following other packages will have to be synced before scilab-5.0.3 can compile:
[x] jeuclid: https://bugs.launchpad.net/ubuntu/+bug/334767
[x] xmlgraphics-common: https://bugs.launchpad.net/ubuntu/+source/xmlgraphics-commons/+bug/326172
[x] fop: https://bugs.launchpad.net/ubuntu/+source/fop/+bug/326171

Packages marked with [x] are released in jaunty.

A description of the proposed changes, with sufficient detail to estimate their potential impact on the distribution:
- scilab-5.1 has many bugs fixed and a completely new user interface.
- The jeuclid package has to be in jaunty before scilab can be built.

A rationale for the exception, explaining the benefit of the change:
- scilab-5.1 has many bugs fixed.
- it has great improvements in speed and compatibility with graphic cards.
- The new user interface is more user friendly
- a main reason is: scilab is now free

The sources are available in the PPA and in the REVU request.
http://revu.ubuntuwire.com/p/scilab

Related branches

Changed in scilab:
status: Unknown → New
William Grant (wgrant) wrote :

We'll get this for free once it's in sid (after lenny's release). We're not likely to do anything about it before Debian does.

Changed in scilab:
importance: Undecided → Wishlist
status: New → Won't Fix
Christoph Korn (c-korn) wrote :

I currently try to package the new 5.0.2 release.

I took the 4.1.2 [1] package as a starting point.

These [2] are the build dependencies.
I had to take the libflexdock-java, libjogl-java,
libjrosetta-java, libmatio0 and libskinlf-java packages
from intrepid because they are not available in hardy.

Finally this [3] is the debian/rules file I used for
creating the package.

After installing and typing "scilab" there just is
a "Segmentation fault".
Nothing more happens.

[1] http://packages.ubuntu.com/hardy/scilab
[2] http://nopaste.com/p/a3BdtwoKt/txt
[3] http://nopaste.com/p/a3qeMGHT0/txt

Christoph Korn (c-korn) wrote :

scilab-5.0.2 is currently being built in the automated build system of getdeb.net.

Changed in getdeb.net:
assignee: nobody → c-korn
importance: Undecided → Medium
status: New → In Progress
Christoph Korn (c-korn) on 2008-10-18
Changed in getdeb.net:
status: In Progress → Fix Committed
João Pinto (joaopinto) wrote :

This package depends on libraries not available yet on Hardy, it will not be available from the getdeb page but can be installed from:

http://archive.getdeb.net/dump/hardy/scilab_5.0.2-1~getdeb1/

Thanks

Changed in getdeb.net:
status: Fix Committed → Fix Released
Christoph Korn (c-korn) wrote :

The package for amd64 in this directory does not work.

It is a well known bug I try to fix together with the developers.

Christoph Korn (c-korn) wrote :

This bug should be milestoned for jaunty.

There are already test packages available here:
http://www.scilab.org/team/sylvestre.ledru/

Just insert this line in /etc/apt/sources.list
deb-src http://www.scilab.org/team/sylvestre.ledru/repository/ubuntu/ intrepid main

Then run:
apt-get update
apt-get source scilab
apt-get source fop
apt-get source jeuclid
apt-get source xmlgraphics-commons

As you can see all required libraries are already built.
These sources just need to be verified.

Christoph Korn (c-korn) wrote :

There is a gnome menu entry missing in the package.

I have attached the desktop file.

Christoph Korn (c-korn) wrote :

There is currently some localization bug which makes scilab unable to compile the documentation in a clean environment.
http://bugzilla.scilab.org/show_bug.cgi?id=3918

But as soon as this is fixed there shouldn't be any problem left and so no reason (AFAIK) why scilab cannot be shipped out with jaunty.

Morten Kjeldgaard (mok0) wrote :

The new scilab package does not build in jaunty because it build-depends on package jeuclid which currently is in Debian NEW queue. When jeuclid comes through to experimental, it should be sync'ed.

Morten Kjeldgaard (mok0) on 2009-01-16
Changed in scilab:
status: Won't Fix → Confirmed
Christoph Korn (c-korn) wrote :

I don't know when jeuclid will be in experimental.
If the scilab compilation issue is fixed earlier is there
the possibility that the packages from Sylvestre Ledru's
repository is QAed?

Steve Langasek (vorlon) wrote :

Morten, since you've targeted this to jaunty, I assume you're taking responsibility for it?

Changed in scilab:
assignee: nobody → mok0
Sylvestre Ledru (sylvestre) wrote :

The bug 3918 has been fixed upstream and backported in Scilab 5.0.3 in the debian package.
http://svn.debian.org/viewsvn/debian-science/packages/scilab/trunk/debian/patches/
Patches:
switchOrder.diff
xmltoformat-2.diff
xmltoformat.diff
version 5.0.3-6 is the right one.
I am rebuilding the Ubuntu packages for:
http://www.scilab.org/team/sylvestre.ledru/

Christoph Korn (c-korn) wrote :

Unfortunately, still not all packages were built.

https://launchpad.net/~getdeb.packages/+archive/ppa

Christoph Korn (c-korn) wrote :

Sorry, it was a false alarm.

The missing packages are for all architectures and were successfully created by
the i386 build process (I only waited for the amd64 build process and wondered why
the other packages were not there).

Scilab 5 should make it into jaunty.

The packages and all dependencies are available here:
https://launchpad.net/~getdeb.packages/+archive/ppa

Christoph Korn (c-korn) wrote :

Bringing scilab 5 into jaunty requires the update of fop to version 0.95 and xmlgraphics-commons to version 1.3.1.

Also the package jeuclid needs to be created.
JEuclid 3.1.4 has been released. So this one should be used instead of 3.1.3 from the PPA.

Sylvestre Ledru (sylvestre) wrote :

While incorporating Scilab into Ubuntu, please change the revision number to match the one from Debian Science -6 for now

There are almost no change in the version 3.1.4 of jeuclid. You will find the updated packages description here:
http://svn.debian.org/viewsvn/debian-science/packages/jeuclid/trunk/debian/

fop and xmlgraphics-commons are both coming from Debian java team and are available in debian experimental.

I subscribed ubuntu-archive to this sync request before it was ACKed.

I apologize for this. The ubuntu-archive may want to unsubscribe until it gets subscribed again
after (hopefully) ACKing this sync request.

description: updated
James Westby (james-w) wrote :

ubuntu-archive unsubscribed.

Thanks,

James

Christoph Korn (c-korn) wrote :

Scilab-5.0.3 has been built for jaunty in the PPA.

Christoph Korn (c-korn) on 2009-02-14
description: updated
Christoph Korn (c-korn) on 2009-02-14
description: updated
Christoph Korn (c-korn) on 2009-02-17
description: updated

scilab-5.1 has been built for jaunty.

http://revu.ubuntuwire.com/p/scilab
I requested a REVU.

Christoph Korn (c-korn) on 2009-02-21
description: updated
Christoph Korn (c-korn) wrote :
Christoph Korn (c-korn) wrote :
description: updated
Luca Falavigna (dktrkranz) wrote :
Changed in scilab:
status: Confirmed → Incomplete
Christoph Korn (c-korn) wrote :

I tested scilab-5.1 in jaunty and it runs well.

Sylvestre Ledru (sylvestre) wrote :

This package is going to be uploaded in Debian experimental in the next few days. The introduction of jeuclid was the last issue. It has been accepted this morning.

Christoph Korn (c-korn) wrote :

@Scott Kitterman:
http://revu.ubuntuwire.com/p/scilab
I also uploaded the package to REVU.
It is the same as in the PPA except the revision is another.
Using ~ppa revision instead of 0ubuntu1 in PPAs.

Luca Falavigna (dktrkranz) wrote :

What about sivp source package? It's a direct rdependency and I see there's a new upstream version which provide support for scilab 5.x

http://sivp.svn.sourceforge.net/viewvc/sivp/trunk/sivp/ChangeLog:
     ---------------------------------
      SIVP 0.5.0
     ---------------------------------
     o Added:
       --------
      ind2rgb
      rectangle
      detectfaces
      detectlefteyes
     detectrighteyes
    detectforeground
     Scilab Version 5 support

    o Bug fixed:
      --------
     Bugs in std2 and stdev2 fixed.

Sylvestre Ledru (sylvestre) wrote :

sivp version 0.5.0 is available in debian unstable.
It is more important to have Scilab 5 free in Ubuntu that still having Scilab 4.X + sivp

StefanPotyra (sistpoty) wrote :

Hi,
I just took a glimpse at debian/copyright from the package on REVU, debian/copyright seems to contain dead references, e.g.src/forttan/slatec. Also, it's really not too easy to say if the license is in fact ok or not (i.e. GPL-compatible, there are GPL files in the package. I personally believe it is, but I must admit that I'm no expert in the legal territorry).
Also, debian/changelog contains only one entry?

That said, I guess I'm ok with having scilab 5 in, but ideally from unstable (or experimental), as that would avoid duplicate reviewing. If not from unstable/experimental, I'd like to see at least one ACK that the package is in shape from a MOTU.

Cheers,
    Stefan

Sylvestre Ledru (sylvestre) wrote :

Stefan,
debian/copyright is sorted by modules
For example, for slatec, it is in the module elementary_functions
----- Module: elementary_functions -----
therefor, it is going to be in the directory
modules/elementary_functions/src/fortran/slatec/

It is a real issue, I can change all that.
(I found it easier to work like that).

Gianluca (gmangialardo) wrote :

Hi Sylvestre

I am new in this Ubuntu environmnet. I am not able to install the package of Scilab in my laptop (Ubuntu network remix). Is there a way to install the package?

Thank you

StefanPotyra (sistpoty) wrote :

@Sylvestre: Ah, ok. I just thought that was not intentional and happened by e.g. upstream renamed directories. I don't think that's a reason to worry about.

Christoph Korn (c-korn) wrote :

I have also set up a FFe for sivp 0.5.0 which has to be updated for scilab-5.1.
(Sylvestre said so)
https://bugs.launchpad.net/ubuntu/+source/scilab/+bug/334362

The package compiled fine in my ppa at:
https://launchpad.net/~getdeb.packages/+archive/ppa

There have been some latest changes which are not in debian yet.

Christoph Korn (c-korn) wrote :

I have reuploaded the package to revu [1].
It now has the full changelog.

The scilab package should be fine now.

[1] http://revu.ubuntuwire.com/p/scilab

LaserJock (laserjock) wrote :

Feature Freeze exception ACK'd. Thanks for the work Morten and Christoph. Scientists around the world will love you ;-)

Changed in scilab:
status: Incomplete → Confirmed
Christoph Korn (c-korn) wrote :

The package scilab-include is installed by default because some plugins need the sources.

Is this a problem?

Is anything else wrong with the package?

I just want to be sure it will be accepted when it is in the jaunty new queue.
Also because the developers might have other interests than new packages
after feature freeze. ;-)

Christoph Korn (c-korn) on 2009-02-27
description: updated
Christoph Korn (c-korn) wrote :

Jeuclid made it into jaunty.

Can some push scilab in the queue?

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 5.1-0ubuntu1

---------------
scilab (5.1-0ubuntu1) jaunty; urgency=low

  [ Sylvestre Ledru ]
  * Package scilab-include added (was missing in the previous version)
  * sivp added in the recommanded packages (Closes: #505203)
  * Replaces: scilab (< 5.0) added in scilab-bin (caused issue in the 4.X
   => 5.X upgrade)

  [ Christoph Korn ]
  * debian/patches/filesWithSpace.diff: Removes a space in two filenames.
  * Closes (LP: #272264)

 -- Christoph Korn <email address hidden> Wed, 25 Feb 2009 17:08:01 +0100

Changed in scilab:
status: Confirmed → Fix Released
Christoph Korn (c-korn) wrote :

The package fails to build:
dh_strip debug symbol extraction: all non-arch-all packages for this build platform lpia: scilab-bin libscilab-java
dh_strip debug symbol extraction: packages to act on: scilab-bin
dh_strip debug symbol extraction: ignored packages:
pkgstriptranslations: processing control file: ./debian/scilab-bin-dbgsym/DEBIAN/control, package scilab-bin-dbgsym, directory ./debian/scilab-bin-dbgsym
pkgstriptranslations: scilab-bin-dbgsym does not contain translations, skipping
pkgstriptranslations: The following PO/POT files are empty. This is known to
cause trouble in the translation importer and generally indicates a package
bug:

./modules/maple2scilab/locales/fr_FR/maple2scilab.po
./modules/boolean/locales/fr_FR/boolean.po
./modules/intersci/locales/fr_FR/intersci.po
./modules/scilab2fortran/locales/fr_FR/scilab2fortran.po
./modules/arnoldi/locales/fr_FR/arnoldi.po
./modules/scipad/locales/fr_FR/scipad.po

It succeeded in a PPA.

Luca Falavigna (dktrkranz) wrote :

PPAs don't have support for pkgbinarymangler, if you install such package in a chroot (such as pbuilder), you can easily debug it.

Christoph Korn (c-korn) wrote :

The empty language files need to be removed.

Changed in scilab:
status: Fix Released → Incomplete
Christoph Korn (c-korn) wrote :

This debdiff has to be applied on the version that failed.

Christoph Korn (c-korn) wrote :

I forgot to increase the revision.

This is the fixed debdiff.

Christoph Korn (c-korn) wrote :

Well, this should finally be it :P

Morten Kjeldgaard (mok0) wrote :

Uploaded. Please open a new bug if more issues appear with this package. We prefer to have only one issue per bug. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 5.1-0ubuntu2

---------------
scilab (5.1-0ubuntu2) jaunty; urgency=low

  * debian/rules: Remove empty translation files (Closes LP: #272264)

 -- Christoph Korn <email address hidden> Thu, 05 Mar 2009 14:52:46 +0100

Changed in scilab:
status: Incomplete → Fix Released
Luca Falavigna (dktrkranz) wrote :

Unsubscribing motu-release for now, please resubscribe if other issues come out, thanks!

Christoph Korn (c-korn) wrote :

I do not know why this is linked to Ubuntu (Baltix).

Changed in scilab (Baltix):
status: New → Invalid
Christoph Korn (c-korn) wrote :

scilab-5 also is in Debian.

Changed in scilab (Debian):
importance: Unknown → Undecided
status: New → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

Christoph Korn wrote 3 hours ago:
> I do not know why this is linked to Ubuntu (Baltix).

This is because Baltix distribution also wants to have new scilab, backported to Baltix 2008 ;)

Changed in scilab (Baltix):
status: Invalid → Confirmed
assignee: nobody → Mantas Kriaučiūnas (mantas)
Morten Kjeldgaard (mok0) wrote :

Mantas,

In that place, could you please open a new bug under Baltix' own namespace, so we can get this one closed? As far as Ubuntu is concerned, we have "Fix Released" since over 6 months ago.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.