[SRU] scilab-cli and scilab-adv-cli does not start on bionic, cosmic, disco and eoan

Bug #1825037 reported by Norbert on 2019-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
scilab (Debian)
Fix Released
Unknown
scilab (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

 * Scilab does not show console prompt and freezes.
 * Scilab requires additional fixes to properly work with OpenJDK 11, thus it needs to be backported to releases that have openjdk-lts as the default-jdk.
 * The bug was caused by the failure to load modules, which had their service files removed during build time. The change was introduced in scilab 6.0.1-4, which started using find to remove all empty files during build time, that caused some required (although empty) files from the modules to be removed as well, thus causing scilab to fail to find and load these modules.

[Test Case]

 1. run scilab-cli
 2. verify that it reports missing modules and that it hangs
```
$ scilab-cli
commons module not found.
graphic_objects module not found.
ui_data module not found.
graph module not found.
history_browser module not found.
slint module not found.
coverage module not found.

```

With the fix applied scilab-cli should load and show a prompt to the user
```
$ scilab-cli Scilab 6.0.2 (May 21 2019, 20:36:16)

-->
```

[Regression Potential]

 * This change only prevent empty files in scilab source from being removed during build time. No side-effect (except for getting the modules working again) is known.

[Original Report]
Steps to reproduce:
1. Have Ubuntu 18.04.2 LTS installed with all updates
2. Install latest Scilab package (6.0.1-7ubuntu1~18.04)
3. Launch Scilab CLI with `scilab-cli` or `scilab-adv-cli`

Expected results:
* Scilab shows its console prompt

Actual results:
* Scilab does not show console prompt and freezes with the following messages:

```
$ scilab-cli
commons module not found.
graphic_objects module not found.
ui_data module not found.
graph module not found.
history_browser module not found.
slint module not found.
coverage module not found.

```

```
$ scilab-adv-cli
Picked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/java/javax.activation.jar:/usr/share/java/jaxb-runtime.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/external_objects_java/tests/libintl.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.scilab.modules.jvm.LibraryPath (file:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar) to field java.lang.ClassLoader.sys_paths
WARNING: Please consider reporting this to the maintainers of org.scilab.modules.jvm.LibraryPath
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
commons module not found.
graphic_objects module not found.
ui_data module not found.
graph module not found.
history_browser module not found.
slint module not found.
coverage module not found.

```

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: scilab-cli 6.0.1-7ubuntu1~18.04
ProcVersionSignature: Ubuntu 4.15.0-47.50-generic 4.15.18
Uname: Linux 4.15.0-47-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: MATE
Date: Tue Apr 16 22:30:55 2019
InstallationDate: Installed on 2018-10-17 (181 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
SourcePackage: scilab
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :

Cosmic is affected too with Scilab 6.0.1-7ubuntu1~18.10 .

summary: - scilab-cli and scilab-adv-cli does not start on bionic
+ scilab-cli and scilab-adv-cli does not start on bionic and cosmic
tags: added: cosmic

Disco is affected too with Scilab 6.0.2-0ubuntu1 .

summary: - scilab-cli and scilab-adv-cli does not start on bionic and cosmic
+ scilab-cli and scilab-adv-cli does not start on bionic, cosmic and disco
tags: added: disco
Changed in scilab (Debian):
status: Unknown → New
Norbert (nrbrtx) on 2019-04-21
summary: - scilab-cli and scilab-adv-cli does not start on bionic, cosmic and disco
+ scilab-cli and scilab-adv-cli does not start on bionic, cosmic, disco
+ and eoan
tags: added: eoan
tags: added: id-5cbf8cd59e0abe4d0844735a

This Bug report and workaround works for me:

https://<email address hidden>/msg1679259.html

I assume Ubuntu picked up the same...

Changed in scilab (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.2-0ubuntu2

---------------
scilab (6.0.2-0ubuntu2) eoan; urgency=medium

  [ Alexis Murzeau ]
  * Fix a startup issue with scilab-cli & scilab-adv-cli. (Closes: #907607,
    LP: #1825037)

 -- Tiago Stürmer Daitx <email address hidden> Tue, 21 May 2019 20:36:16 +0000

Changed in scilab (Ubuntu):
status: New → Fix Released
Norbert (nrbrtx) wrote :

Please backport the fix to Ubuntu 18.04 Bionic Beaver (LONG TERM SUPPORT release).

description: updated
summary: - scilab-cli and scilab-adv-cli does not start on bionic, cosmic, disco
- and eoan
+ [SRU] scilab-cli and scilab-adv-cli does not start on bionic, cosmic,
+ disco and eoan
Changed in scilab (Ubuntu):
importance: Undecided → High

Hello Norbert, or anyone else affected,

Accepted scilab into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/scilab/6.0.2-0ubuntu2~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in scilab (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Hello Norbert, or anyone else affected,

Accepted scilab into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/scilab/6.0.1-7ubuntu1~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in scilab (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Norbert, or anyone else affected,

Accepted scilab into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/scilab/6.0.1-7ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in scilab (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Tiago Stürmer Daitx (tdaitx) wrote :

Verified that bionic-proposed (6.0.1-7ubuntu1~18.04.1), cosmic-proposed (6.0.1-7ubuntu1~18.10.1), and disco-proposed (6.0.2-0ubuntu2~19.04) fixes this bug and can be successfully run.

tags: added: verification-done-bionic verification-done-cosmic verification-done-disco
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.1-7ubuntu1~18.04.1

---------------
scilab (6.0.1-7ubuntu1~18.04.1) bionic; urgency=medium

  [ Alexis Murzeau ]
  * Fix a startup issue with scilab-cli & scilab-adv-cli. (Closes: #907607,
    LP: #1825037)

 -- Tiago Stürmer Daitx <email address hidden> Tue, 21 May 2019 20:36:16 +0000

Changed in scilab (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for scilab has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.1-7ubuntu1~18.10.1

---------------
scilab (6.0.1-7ubuntu1~18.10.1) cosmic; urgency=medium

  [ Alexis Murzeau ]
  * Fix a startup issue with scilab-cli & scilab-adv-cli. (Closes: #907607,
    LP: #1825037)

 -- Tiago Stürmer Daitx <email address hidden> Tue, 21 May 2019 20:36:16 +0000

Changed in scilab (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.2-0ubuntu2~19.04

---------------
scilab (6.0.2-0ubuntu2~19.04) disco; urgency=medium

  * No change backport from Eoan.

scilab (6.0.2-0ubuntu2) eoan; urgency=medium

  [ Alexis Murzeau ]
  * Fix a startup issue with scilab-cli & scilab-adv-cli. (Closes: #907607,
    LP: #1825037)

 -- Tiago Stürmer Daitx <email address hidden> Tue, 21 May 2019 20:36:16 +0000

Changed in scilab (Ubuntu Disco):
status: Fix Committed → Fix Released
narayanadash (narayanadash) wrote :

I was writing a small command on editor scriptin scilab in Ubuntu os. Somehow the script window vanished. I force closed the scilab. Next time opened the computer, it showed some dialogues that some process runs in the background.. now scilab script did not respond and now scilab icon in gnome does not respond. I tried to remove / update/reinstall scilab but the message said latest version installed. Please advise

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.