Scilab does not start on disco and bionic-proposed

Bug #1807602 reported by Norbert on 2018-12-09
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Scilab
Fix Released
High
scilab (Debian)
Fix Released
Unknown
scilab (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 19.04
2. Install Scilab with `sudo apt install scilab`
3. Run Scilab with `scilab`

Expected results:
* Scilab started

Actual results:
* Scilab does not start:

$ scilab
Picked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/java/javax.activation.jar:/usr/share/java/jaxb-runtime.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.scilab.modules.jvm.LibraryPath (file:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar) to field java.lang.ClassLoader.sys_paths
WARNING: Please consider reporting this to the maintainers of org.scilab.modules.jvm.LibraryPath
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Inconsistency detected by ld.so: dl-lookup.c: 112: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: scilab 6.0.1-7
ProcVersionSignature: Ubuntu 4.18.0-12.13-generic 4.18.17
Uname: Linux 4.18.0-12-generic x86_64
ApportVersion: 2.20.10-0ubuntu14
Architecture: amd64
Date: Sun Dec 9 20:06:32 2018
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: scilab
UpgradeStatus: No upgrade log present (probably fresh install)

BUG DESCRIPTION:
----------------
When opened from GUI(gnome 3), Scilab closes immediately after opening in fedora 24. However, it runs fine when opened from terminal.

ERROR LOG:
----------
None

HOW TO REPRODUCE THE BUG:
-------------------------

OTHER INFORMATION:
------------------

Same on Ubuntu 12.04.5 LTS amd64 with Scilab 6.0.0-beta2. But scilab launches normally from gnome-terminal.

Desktop launcher and terminal command is
   env LC_ALL="en_US.UTF-8" /home/nikolay/Software/scilab-6.0.0-beta-2/bin/scilab

Same here.
Scilab 6.0.0.1486471292 amd64 under Ubuntu 12.04.5 LTS amd64.

It a pity but bug exists in Scilab 6.0.0.1487071837 (final) amd64 under Ubuntu 12.04.5 LTS amd64.

Temporary fixed by desktop launcher with "xterm -e"

env LC_ALL="en_US.UTF-8" xterm -e /home/nikolay/Software/scilab-6.0.0/bin/scilab

(In reply to Nikolay Strelkov from comment #4)
> Temporary fixed by desktop launcher with "xterm -e"
>
> env LC_ALL="en_US.UTF-8" xterm -e /home/nikolay/Software/scilab-6.0.0/bin/scilab

Nice catch ! I never use the default launcher shipped with the binary but use a local user-defined one. I will check the freedesktop norm and fix it.

Exactly the same problem at OpenSUSE Leap 42.2 with KDE with the same
temporary solution: ikon settings -> advance settings -> execute in terminal,
disadvantage: the terminal window is necessary to keep running.

(In reply to Clement DAVID from comment #5)
> Nice catch ! I never use the default launcher shipped with the binary but use a local user-defined one. I will check the freedesktop norm and fix
> it.

Hey clement, issue is still there.
It would be nice if you could take some time to to fix it...
ty

*** Bug 15203 has been marked as a duplicate of this bug. ***

It is very bad that you forgot to fix this bug before 6.0.1 release.
So bug exists in 6.0.1.1518683525 on Ubuntu 16.04 LTS x86_64.

Temporary fixed by desktop launcher with "xterm -e": env LC_ALL="en_US.UTF-8" xterm -e /home/nikolay/Software/scilab-6.0.0/bin/scilab

This may break scilab in for example upcoming Ubuntu 18.04 LTS.

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :
Download full text (3.8 KiB)

Still a problem:

$ scilab
Picked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/java/javax.activation.jar:/usr/share/java/jaxb-runtime.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab/modules/external_objects_java/tests/libintl.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:
WARNIN...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in scilab (Ubuntu):
status: New → Confirmed
summary: - Scilab does not start on Disco
+ Scilab does not start on disco and bionic-proposed
Matthias Klose (doko) wrote :

this works for me both in 18.04 LTS + bionic-proposed and 19.04. Are you sure that you updated every package, and not just installed scilab?

Changed in scilab (Ubuntu):
status: Confirmed → Incomplete
Amr Ibrahim (amribrahim1987) wrote :

Thanks for the hint. I installed scilab from scratch like this:

sudo apt install -t bionic-proposed scilab

To make sure that all packages comes from -proposed.

Now when it is called from its graphical launcher, it flashes for a second then closes. It runs when it is called from the terminal.
http://bugzilla.scilab.org/show_bug.cgi?id=14682

Matthias Klose (doko) on 2019-03-19
Changed in scilab (Ubuntu):
status: Incomplete → Triaged
Changed in scilab:
importance: Unknown → High
status: Unknown → Fix Released
Matthias Klose (doko) on 2019-03-21
Changed in scilab (Ubuntu Bionic):
status: New → Fix Committed
Changed in scilab (Ubuntu Cosmic):
status: New → Fix Committed
Changed in scilab (Ubuntu):
status: Triaged → Fix Released
Norbert (nrbrtx) wrote :

When launched from Dash:
* on Bionic it starts, but closes immediately (it is bug 1739476 ).
* on Disco it starts and shows its window.

When launched from Terminal:
* on Bionic it starts and shows its window.
* on Disco it starts and shows its window.

So:
* on Bionic it does not work (does not start from GUI - see bug 1739476 ; has broken ATOMS - see bug 1765503 ).
* on Disco it works (expect ATOMS - see bug 1765503 ).

Amr Ibrahim (amribrahim1987) wrote :

I can now start scilab from its desktop launcher in version 6.0.1-7ubuntu1~18.04 from bionic-proposed.

Tiago Stürmer Daitx (tdaitx) wrote :

Marked bug #1739476 as a duplicate of this one as both seem to be caused by the same upstream bug - keeping this one open and marking the other one as duplicate because this is the one tracked on the package's changelog.

Changed in scilab (Debian):
status: Unknown → Fix Released
Norbert (nrbrtx) wrote :

Thank you very much!

The 6.0.1-7ubuntu1~18.04 version fixes bug on Bionic Beaver.

It is great.

Norbert (nrbrtx) wrote :

Fixed on Disco.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.1-7ubuntu1~18.04

---------------
scilab (6.0.1-7ubuntu1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1814133.

scilab (6.0.1-7ubuntu1) disco; urgency=medium

  * Fix desktop startup. LP: #1807602.

scilab (6.0.1-7build2) disco; urgency=medium

  * No-change rebuild for ocaml abi changes.

scilab (6.0.1-7build1) disco; urgency=medium

  * Rebuild against new libhdf5-103.

scilab (6.0.1-7) unstable; urgency=medium

  * Team upload.

  [ Gilles Filippini ]
  * New patch force-fop-jar-into-classpath.patch:
    force /usr/share/java/fop.jar into the classpath. Closes: #915102

scilab (6.0.1-6) unstable; urgency=medium

  * Bump std-ver to 4.2.1.
  * Merge pull request from E.Bourg (Closes: #912392).

scilab (6.0.1-5) unstable; urgency=medium

  * Rework building doc (fixes another FTBFS on non-amd64)

scilab (6.0.1-4) unstable; urgency=medium

  * Remove faulty rmdir in d/rules (fixes a FTBFS on non-amd64)

scilab (6.0.1-3) unstable; urgency=medium

  * Rework the java >= 9 support (Closes: #875790,#739235,#818352,#662986).
  * Declared all doc packages as Multi-Arch: foreign following hinter.
  * Rewrite d/rules removing use of cdbs.
  * Clean up packaging:
    - Bump dh compat to 11 (Closes: #746028)
    - Bump std-ver to 4.1.5
    - don't ship various useless files
    - remove some lintian overrides
    - don't ship fonts : find them elsewhere
  * Checked that scilab does start
    (Closes: #712065,#764783,#812311,#891351,#896118).
  * Add patch to fix fortran compilation (Closes: #904856).
  * Checked that it builds with recent gcc (Closes: #791274).

scilab (6.0.1-2) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Fixed the build failure with Java 9 (Closes: #875790)

  [ Julien Puydt ]
  * Depend on unversioned tcl/tk (Closes: #803526)
  * Force use of java 8 since later versions aren't supported (Closes: #875790)

 -- Matthias Klose <email address hidden> Tue, 19 Mar 2019 13:51:26 +0100

Changed in scilab (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scilab - 6.0.1-7ubuntu1~18.10

---------------
scilab (6.0.1-7ubuntu1~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1814133.

scilab (6.0.1-7ubuntu1) disco; urgency=medium

  * Fix desktop startup. LP: #1807602.

scilab (6.0.1-7build2) disco; urgency=medium

  * No-change rebuild for ocaml abi changes.

scilab (6.0.1-7build1) disco; urgency=medium

  * Rebuild against new libhdf5-103.

scilab (6.0.1-7) unstable; urgency=medium

  * Team upload.

  [ Gilles Filippini ]
  * New patch force-fop-jar-into-classpath.patch:
    force /usr/share/java/fop.jar into the classpath. Closes: #915102

scilab (6.0.1-6) unstable; urgency=medium

  * Bump std-ver to 4.2.1.
  * Merge pull request from E.Bourg (Closes: #912392).

 -- Matthias Klose <email address hidden> Tue, 19 Mar 2019 13:51:26 +0100

Changed in scilab (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Norbert (nrbrtx) on 2019-04-21
tags: removed: amd64 disco
tags: added: id-5cbf8cd59e0abe4d0844735a
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.