Unable to launch fresh installed Scilab on Cosmic (java.xml.bind.jmod missed)

Bug #1798661 reported by Norbert on 2018-10-18
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
openjdk-lts (Ubuntu)
Undecided
Unassigned
scilab (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 18.10
2. Install Scilab package `sudo apt-get install scilab`
3. Try to launch Scilab

Expected results:
* Scilab could be launched

Actual results:
* Scilab does not launch, shows the following message in the terminal:

$ scilab
Picked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar: --add-modules=java.activation,java.xml.bind
Error occurred during initialization of boot layer
java.lang.module.FindException: Module java.xml.bind not found

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: scilab 6.0.1-5
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 18 22:33:00 2018
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: scilab
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) on 2018-10-19
summary: - Unable to launch fresh installed Scilab on Cosmic
+ Unable to launch fresh installed Scilab on Cosmic (java.xml.bind.jmod
+ missed)
Norbert (nrbrtx) wrote :

The problem comes from openjdk-11-jdk-headless package.
In previous release it has needed java.xml.bind.jmod , but in 18.10 the file is missed.

See https://packages.ubuntu.com/search?suite=bionic&arch=amd64&mode=filename&searchon=contents&keywords=java.xml.bind for clues.

Please repack openjdk to have more jmods.

Other missed stuff:
 /usr/lib/jvm/java-11-openjdk-amd64/bin/idlj
 /usr/lib/jvm/java-11-openjdk-amd64/bin/schemagen
 /usr/lib/jvm/java-11-openjdk-amd64/bin/wsgen
 /usr/lib/jvm/java-11-openjdk-amd64/bin/wsimport
 /usr/lib/jvm/java-11-openjdk-amd64/bin/xjc
 /usr/lib/jvm/java-11-openjdk-amd64/include/ir.idl
 /usr/lib/jvm/java-11-openjdk-amd64/include/orb.idl
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.activation.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.corba.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.se.ee.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.transaction.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.xml.bind.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.xml.ws.annotation.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/java.xml.ws.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/jdk.incubator.httpclient.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/jdk.xml.bind.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/jmods/jdk.xml.ws.jmod
 /usr/lib/jvm/java-11-openjdk-amd64/man/ja_JP.UTF-8/man1/idlj.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/ja_JP.UTF-8/man1/schemagen.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/ja_JP.UTF-8/man1/wsgen.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/ja_JP.UTF-8/man1/wsimport.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/ja_JP.UTF-8/man1/xjc.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/man1/idlj.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/man1/schemagen.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/man1/wsgen.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/man1/wsimport.1.gz
 /usr/lib/jvm/java-11-openjdk-amd64/man/man1/xjc.1.gz

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-lts (Ubuntu):
status: New → Confirmed
Changed in scilab (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2018-11-02
tags: added: disco
Norbert (nrbrtx) on 2019-04-21
tags: removed: amd64 cosmic disco
Changed in scilab (Ubuntu):
status: Confirmed → Fix Released
Changed in openjdk-lts (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers