Unable to start Scilab 6.0.1 on bionic because of missed Java

Bug #1762999 reported by Norbert on 2018-04-11
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
scilab (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 18.04 LTS with all updates
2. Install `scilab` package
3. Try to launch `scilab` from terminal

Expected results:
scilab works

Actual results:
scilab does not start with error in the terminal -

$ scilab
/usr/bin/scilab-bin: error while loading shared libraries: libjava.so: cannot open shared object file: No such file or directory

Note: libjava.so is in place -

$ dpkg -S libjava.so
openjdk-9-jre-headless:amd64: /usr/lib/jvm/java-9-openjdk-amd64/lib/libjava.so

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: scilab 6.0.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CurrentDesktop: MATE
Date: Wed Apr 11 14:02:41 2018
PackageArchitecture: all
SourcePackage: scilab
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 18.04
Package: scilab 6.0.1-1ubuntu1
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Tags: bionic
Uname: Linux 4.15.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Norbert (nrbrtx) wrote :

apport information

tags: added: apport-collected
description: updated

apport information

Norbert (nrbrtx) wrote :

Same on clean netboot.iso.

Norbert (nrbrtx) wrote :

Problem is not fixed. Even with proposed updates. Scilab is unusable.

Norbert (nrbrtx) wrote :

Problem is not fixed. Even with proposed updates. Scilab is unusable.

Norbert (nrbrtx) wrote :

Problem is not fixed. Even with proposed updates. Scilab is unusable. Ubuntu 18.04 LTS with all updates.

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 18.04 LTS with all updates.

Norbert (nrbrtx) wrote :

Scilab on Bionic starts normally if I have OpenJDK 9 (reproducible only on one system):

aptitude search "~o"
i A openjdk-9-jre - OpenJDK Java runtime, using Hotspot JIT
i A openjdk-9-jre-headless - OpenJDK Java runtime, using Hotspot JIT (headless)

So you should not remove OpenJDK 9 or recompile Scilab with the newest OpenJDK as dependency.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-9 (Ubuntu):
status: New → Confirmed
Changed in openjdk-lts (Ubuntu):
status: New → Confirmed
Changed in scilab (Ubuntu):
status: New → Confirmed
Tiago Stürmer Daitx (tdaitx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

However, openjdk-9 is no longer available in Bionic. In turn, scilab actually requires openjdk-8-jre to be installed, even though it declares a dependency on the default-jre (which depends on openjdk-11-jre). Thus scilab either needs to be updated to support openjdk-11 or its dependency updated to openjdk-8-jre instead of default-jre.

Changed in openjdk-9 (Ubuntu):
status: Confirmed → Invalid
Norbert (nrbrtx) wrote :

Bug still exists on Ubuntu 18.04 LTS with all updates.

18.10 cosmic is affected too.

summary: - Unable to start Scilab 6.0.1 on bionic because of missed Java
+ Unable to start Scilab 6.0.1 on bionic and cosmic because of missed Java
tags: added: cosmic
fede.tft (fede-tft) wrote :

Just installed 18.04, Scilab is broken.

$ scilab
/usr/bin/scilab-bin: error while loading shared libraries: libjava.so: cannot open shared object file: No such file or directory

I don't understand why this bug report is marked as invalid. If a program is installed through the package manager, isn't it reasonable to assume that there should be no unmet dependencies?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-8 (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2018-10-06
summary: - Unable to start Scilab 6.0.1 on bionic and cosmic because of missed Java
+ Unable to start Scilab 6.0.1 on bionic because of missed Java
tags: removed: cosmic
Norbert (nrbrtx) wrote :

Still broken on 18.04 LTS (!!!!!!).

Sylvestre Ledru (sylvestre) wrote :

Norbert, don't hesitate to help with a fix! Thanks!

Norbert (nrbrtx) wrote :

Dear Sylvestre!

Glad to meet to you here.
I already have a fix on AskUbuntu (see https://askubuntu.com/a/1029164/66509 ).
In brief we need to use OpenJDK 8 instead of OpenJDK 11.
Also please consider reading the whole answer on AskUbuntu and visit bug links.

I'm posting my comments here to get it fixed on distro/package level.
I hope you will hear me and do all needed steps.

Bug still exists.. Really regretting I updated to 18.04.. Even almost one year after release there are still so many things not working...

I can see a fix added recently into universe(proposed) at https://launchpad.net/ubuntu/+source/scilab/+index by Łukasz Zemczak. When will this make it into release?

Changed in scilab (Ubuntu):
status: Confirmed → Fix Released
Changed in openjdk-lts (Ubuntu):
status: Confirmed → Invalid
Changed in openjdk-8 (Ubuntu):
status: Confirmed → Invalid
moueza (mouezapeter) wrote :

Still error in Ubuntu 20.04 !

moueza (mouezapeter) wrote :

KO with

openjdk-8-jre installed

 dpkg -S libjava.so
openjdk-11-jre-headless:amd64: /usr/lib/jvm/java-11-openjdk-amd64/lib/libjava.so
openjdk-8-jre-headless:amd64: /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/libjava.so

moueza (mouezapeter) wrote :
Download full text (4.4 KiB)

After purge desinstallation and reinstallation :

~$ scilab
Picked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock.jar:/usr/share/java/skinlf.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/jhall.jar:/usr/share/java/lucene-core-4.10.4.jar:/usr/share/java/lucene-analyzers-common-4.10.4.jar:/usr/share/java/lucene-queryparser-4.10.4.jar:/usr/share/maven-repo/org/freehep/freehep-util/debian/freehep-util-debian.jar:/usr/share/maven-repo/org/freehep/freehep-io/debian/freehep-io-debian.jar:/usr/share/maven-repo/org/freehep/freehep-graphicsio/debian/freehep-graphicsio-debian.jar:/usr/share/java/freehep-graphicsio-emf-2.1.jar:/usr/share/java/freehep-graphics2d-2.1.1.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine-1.0.4.jar:/usr/share/java/jgraphx.jar:/usr/share/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop-1.0.7.jar:/usr/share/java/fop.jar:/usr/share/java/saxon.jar:/usr/share/java/batik.jar:/usr/share/java/xml-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath-1.0.7.jar:/usr/share/java/ecj.jar:/usr/share/java/javax.activation.jar:/usr/share/java/jaxb-runtime.jar:/usr/share/scilab/modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab/modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab/modules/helptools/jar/scilab_ru_RU_help.jar:/usr/share/scilab/modules/helptools/jar/scilab_images.jar:/usr/share/scilab/modules/helptools/jar/scilab_en_US_help.jar:/usr/share/scilab/modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/scilab/modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab/modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab/modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab/modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab/modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab/modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab/modules/types/jar/org.scilab.modules.types.jar:/usr/share/scilab/modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab/modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab/modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab/modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab/modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar:/usr/share/scilab/modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab/modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab/modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab/modules/scirenderer/jar/scirenderer.jar:/usr/share/scilab/modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab/modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab/modules/gui/jar/org.scilab.modules.gui.jar:
WARNING: An illegal reflective access o...

Read more...

moueza (mouezapeter) wrote :

It is for Scilab 6.1.0 apt installation

Tiago Stürmer Daitx (tdaitx) wrote :

That was a regression introduced by OpenJDK 11.0.6, it is being tracked in bug 1870813.

no longer affects: openjdk-8 (Ubuntu)
no longer affects: openjdk-9 (Ubuntu)
no longer affects: openjdk-lts (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers