Install failed: unmet dependencies

Bug #1013856 reported by Jason Moore on 2012-06-15
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Scilab
Unknown
Low
ktp-accounts-kcm (Ubuntu)
Undecided
Connor Fredireck Sarles
scilab (Ubuntu)
Critical
Connor Fredireck Sarles

Bug Description

When installing from 12.04 Ubuntu repositories on amd64

Package dependencies cannot be resolved

The following packages have unmet dependencies:

scilab: Depends: scilab-cli (>= 5.3.3-6) but 5.3.3-6 is to be installed

The following packages have unmet dependencies:
 scilab : Depends: scilab-cli (>= 5.3.3-6) but it is not going to be installed
          Depends: scilab-full-bin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

scilab:
  Installed: (none)
  Candidate: 5.3.3-6
  Version table:
     5.3.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

kroq-gar78 (kroq-gar78) on 2012-06-16
summary: - failed install
+ Install failed: unmet dependencies
Omar (silgon3200) wrote :

I'm having the same problem

Changed in scilab:
importance: Undecided → Critical
Changed in scilab (Ubuntu):
importance: Undecided → Critical
Changed in scilab:
importance: Critical → Undecided
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in scilab (Ubuntu):
status: New → Confirmed

--Originally by Jason Moore at Ubuntu Launchpad Bug Tracker--
--https://bugs.launchpad.net/ubuntu/+source/scilab/+bug/1013856--

Rajiv Shah (compukid) wrote :

The developers at Scilab may need additional information from you. It might be helpful to run "sudo apt-get install python-launchpadlib" then run "apport-collect 1013856" to have your computer automatically send helpful files for review to the Scilab developers.

Changed in scilab:
importance: Undecided → Unknown
status: New → Unknown

Sorry that I forgot Jason's bug description. Here it is:

When installing from 12.04 Ubuntu repositories on amd64

Package dependencies cannot be resolved

The following packages have unmet dependencies:

scilab: Depends: scilab-cli (>= 5.3.3-6) but 5.3.3-6 is to be installed

The following packages have unmet dependencies:
 scilab : Depends: scilab-cli (>= 5.3.3-6) but it is not going to be installed
          Depends: scilab-full-bin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

scilab:
  Installed: (none)
  Candidate: 5.3.3-6
  Version table:
     5.3.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

Changed in scilab:
importance: Unknown → Low
status: Unknown → Confirmed

This bug is fixed with Ubuntu quantal.

Changed in scilab:
status: Confirmed → Fix Released

The same dependecy problem appeared in Ubuntu 13.10

(Sorry, my system is Hungarian but you can see the version numbers)

perebal@perebal-X202E:~$ sudo apt-get install scilab
[sudo] password for perebal:
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy
egy lehetetlen állapotot kért, vagy ha az unstable disztribúciót
használja, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.
Az alábbi információk segíthetnek megoldani a problémát:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
 scilab : Függ ettől: scilab-cli (>= 5.4.1-1~exp1) de az nincs telepítésre megjelölve
          Függ ettől: scilab-full-bin de az nincs telepítésre megjelölve
E: A problémák nem javíthatók, sérült csomagokat fogott vissza.
perebal@perebal-X202E:~$

Changed in scilab:
status: Fix Released → Confirmed

I don't understand. I installed ubuntu on virtualbox, and there were no problems with scilab. After that I tried to install scilab on my notebook with synaptic. Synaptic said that there are dependensies which cannot be resolved. I closed synaptic, restarted it and tried again. The second trying was sucsessfull, scilab was installed with no problems. Can anybody explain what happend?

That is a bug to be reported on the Ubuntu bug tracker...

Changed in scilab:
status: Confirmed → Unknown
Dufay Basile (basile-dufay14) wrote :

I can confirm this bug as I'm also affected.
Ubuntu 13.10 64bits, when trying to install "scilab", says (in French):

Les paquets suivants contiennent des dépendances non satisfaites :
 scilab : Dépend: scilab-cli (>= 5.4.1-1~exp1) mais ne sera pas installé
          Dépend: scilab-full-bin mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Anders (eddiedog988) on 2014-03-13
Changed in scilab (Ubuntu):
assignee: nobody → Anders (eddiedog988)

(originally entered in version "5.3 GIT version [5.3 branch]")

I'm having the same problem, but it's installing packages on Ubuntu 16.04, having no relation to 12.04, as I did a fresh install.
I'm having the problem with Google Chrome, Ubuntu Tweak, Kompozer, and a few others. Those were just the ones that I remember.

- Blossom

Connor Fredireck Sarles (cx+) wrote :

Same here all the way, but it's WORSE THAN YOU THINK...
https://bugs.launchpad.net/ubuntu/+source/telepathy-accounts-signon/+bug/1652835

For Ubnuntu 16.04, for this situation the package system is probably broken, or Jason, you may have to uninstall some packages. If anything you try does not work, give more info about this issue, or describe what has malfunctioned and stopped working. E-Mail me if you need help, because right now, I'm having the same exact issue with you right now.

E-Mail: <email address hidden>

Changed in ktp-accounts-kcm (Ubuntu):
status: New → Incomplete
Connor Fredireck Sarles (cx+) wrote :

For Ubnuntu 16.04, for this situation the package system is probably broken, or Jason, you may have to uninstall some packages. If anything you try does not work, give more info about this issue, or describe what has malfunctioned and stopped working. E-Mail me if you need help, because right now, I'm having the same exact issue with you right now.

E-Mail: <email address hidden>

I'll reply soon for a solution.

Changed in ktp-accounts-kcm (Ubuntu):
assignee: nobody → Connor Fredireck Sarles (cx+)
Changed in ktp-accounts-kcm (Ubuntu):
status: Incomplete → Invalid
Changed in scilab (Ubuntu):
assignee: Anders (eddiedog988) → Connor Fredireck Sarles (cx+)
Mantisfist JABN (mantisfist) wrote :
Download full text (4.1 KiB)

This installing on Ubuntu 16.04.1 (Spanish)

mantisfist@Lenovo-IdeaPad-U310-Touch ~ $ sudo apt install lxqt
[sudo] password for mantisfist:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 lxqt : Depende: lxqt-core (= 4) pero no va a instalarse
        Depende: lxqt-about pero no va a instalarse
        Depende: lxqt-admin pero no va a instalarse
        Depende: lxqt-config pero no va a instalarse
        Depende: lxqt-globalkeys pero no va a instalarse
        Depende: lxqt-notificationd pero no va a instalarse
        Depende: lxqt-openssh-askpass pero no va a instalarse
        Depende: lxqt-policykit pero no va a instalarse
        Depende: lxqt-powermanagement pero no va a instalarse
        Depende: lxqt-qtplugin pero no va a instalarse
        Depende: lxqt-runner pero no va a instalarse
        Depende: lxqt-sudo pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
mantisfist@Lenovo-IdeaPad-U310-Touch ~ $ sudo apt install lxqt-core
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 lxqt-core : Depende: lxqt-panel pero no va a instalarse
             Depende: lxqt-session pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
mantisfist@Lenovo-IdeaPad-U310-Touch ~ $ sudo apt install lxqt-panel
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 lxqt-panel : Depende: liblxqt0 (>= 0.9.0+20151024) pero no va a instalarse
              Depende: libqt5xdg1 (>= 1.0.0) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
mantisfist@Lenovo-IdeaPad-U310-Touch ~ $ sudo apt install liblxqt0
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesari...

Read more...

Mantisfist JABN (mantisfist) wrote :

At this moment qtbase-abi-5-5-1 is not in repositories (thru libqt5core), but 5-6-1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.