Missing dependency on qt4-assistant

Bug #601617 reported by Alex Valavanis on 2010-07-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SciDAVis
Unknown
Unknown
qt4-x11 (Ubuntu)
Undecided
Unassigned
scidavis (Debian)
Fix Released
Unknown
scidavis (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: scidavis

Scidavis can't be installed in Maverick, due to its dependency on the obsolete QAssistantClient class.

This was previously provided by the qt4-assistant binary package (from qt4-x11) but this package is no longer available. The qassistantclient.h header also appears to have been removed from the dev package.

I guess the proper solution is to patch scidavis to use the QProcess class instead, as described at http://doc.qt.nokia.com/4.6/qassistantclient.html

Alternatively, qt4-x11 should be made to provide qt4-assistant.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: scidavis (not installed)
ProcVersionSignature: Ubuntu 2.6.35-6.9-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Jul 4 15:22:51 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: scidavis

Related branches

Changed in scidavis (Debian):
status: Unknown → Confirmed
Alex Valavanis (valavanisalex) wrote :

qt-assistant-compat is on its way. Marking as fix committed in qt4-x11 (Ubuntu)

Changed in scidavis (Ubuntu):
status: New → Confirmed
Changed in qt4-x11 (Ubuntu):
status: New → Fix Committed
Alex Valavanis (valavanisalex) wrote :

qt-assistant-compat is now in repos

Changed in qt4-x11 (Ubuntu):
status: Fix Committed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scidavis - 0.2.4-1ubuntu1

---------------
scidavis (0.2.4-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #604811, LP: #565206)
    + No changes left.
  * debian/control:
    + add Build-Depends libqt4assistantclient-dev. This fix a FTBFS with Qt 4.7
      (LP: #601617)
    + add Recommends: qt-assistant-compat
 -- Alexander Valavanis <email address hidden> Mon, 12 Jul 2010 23:50:09 +0100

Changed in scidavis (Ubuntu):
status: Confirmed → Fix Released
Changed in scidavis (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.