scidavis crashed with SIGSEGV in QHeaderView::sectionSizeFromContents()

Bug #532732 reported by der_vegi on 2010-03-05
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
SciDAVis
Unknown
Unknown
scidavis (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Angel Abad

Bug Description

Binary package hint: scidavis

When I try to open this project (see attached file), Scidavis crashes with a Segmentation fault. Using Lucid Alpha 3, but this doesn't seem to be distribution specific, as it also happens in Karmic with the package from debian.physik.hu-berlin.de .

ProblemType: Crash
Architecture: amd64
CheckboxSubmission: de79b5a68af91feb416899245a658969
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Fri Mar 5 16:47:19 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/scidavis
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
Package: scidavis 0.2.3-1
ProcCmdline: scidavis /home/username/Desktop/some_file.sciprj
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SegvAnalysis:
 Segfault happened at: 0x6e0825: mov (%rsi),%rax
 PC (0x006e0825) ok
 source "(%rsi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: scidavis
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 QHeaderView::sectionSizeFromContents(int) const ()
 QHeaderView::sizeHint() const ()
Title: scidavis crashed with SIGSEGV in QHeaderView::sectionSizeFromContents()
Uname: Linux 2.6.32-15-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1418): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-terminal:1601): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (gnome-terminal:2038): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (gnome-terminal:2062): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Related branches

der_vegi (m-may) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 QHeaderView::sectionSizeFromContents (
 QHeaderView::sizeHint (this=0x2b4dd60)

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
der_vegi (m-may) on 2010-03-08
visibility: private → public
Alex Valavanis (valavanisalex) wrote :

Confirmed in Ubuntu lucid alpha 3. Same version as reporter

Changed in scidavis (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Forwarded to https://sourceforge.net/tracker/?func=detail&aid=2965581&group_id=199120&atid=968214

I'll set an upstream link as soon as Launchpad lets me!

Alex Valavanis (valavanisalex) wrote :

Fixed upstream (still can't update this in Launchpad?!?) in r1282. Attaching patch from upstream revision

Angel Abad (angelabad) wrote :

I attach debdiff with working patch.

Thanks!

tags: added: patch
Fabrice Coutadeur (fabricesp) wrote :

Hi,

Can you add a DEP3 header to the patch, and also thank Alex in the changelog entry? (he is the one that reported upstream, and found the patch).

Thanks,
Fabrice

Changed in scidavis (Ubuntu):
assignee: nobody → Angel Abad (angelabad)
status: Confirmed → In Progress
Angel Abad (angelabad) wrote :

Thanks Frabrice for your review. Upload new debdiff with your suggestions.

Fabrice Coutadeur (fabricesp) wrote :

Hi,

One last thing: Alex is not the author of the patch; this is knut_f (http://scidavis.svn.sourceforge.net/viewvc/scidavis?view=rev&revision=1282), so please update the DEP3 header.
Also, you deleted part of the original patch (the second part). Can you fix the patch?

Thanks,
Fabrice

Angel Abad (angelabad) wrote :

Sorry Fabrice for the delay, I updated the patch author in header. I remove the las part of patch becouse the ubuntu version is different since patch creation. Now, only with the first patch scidavis works well.

Thanks!

Angel Abad (angelabad) wrote :

Sorry, I was wrong and resuscribed ubuntu universe sponsors, I cant remove it again. Sorry for the inconvenience.

Thanks!

Angel Abad (angelabad) on 2010-03-29
Changed in scidavis (Ubuntu):
status: In Progress → New
Changed in scidavis (Ubuntu):
assignee: Angel Abad (angelabad) → Fabrice Coutadeur (fabricesp)
status: New → In Progress

This debdiff didn't solve the problem for me, still crashing if I try to create a new column in a table. It has changed slightly though, it used to hang for a second or two, and then crash, now it crashed instantly when I create the column.

Fabrice Coutadeur (fabricesp) wrote :

Hi,

This is another issue, not linked to this bug report. I've seen in Debian that there are issues with qt 4.6, fixed in 0.2.4. I'll try to get this updated. Uploading this fix in the meantime.

Thanks,
Fabrice

Sorry, thought it was the same issue. So it's a qt issue, thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scidavis - 0.2.3-1ubuntu1

---------------
scidavis (0.2.3-1ubuntu1) lucid; urgency=low

  * New patch reorder-updatehorizontalheader.patch to fix Segmentation
    Faults, taken from upstream. Thanks Alex Valavanis (LP: #532732)
 -- Angel Abad <email address hidden> Mon, 15 Mar 2010 13:04:45 +0100

Changed in scidavis (Ubuntu):
status: In Progress → Fix Released
Angel Abad (angelabad) wrote :

Bug fixed in upstream project.

Thanks!

Changed in scidavis:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Changed in scidavis (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
Changed in scidavis:
importance: Undecided → Unknown
status: Fix Released → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.