Ubuntu

Problems removing schooltool-2009

Reported by Timo Schneemann on 2011-03-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
schooltool (Ubuntu)
High
Gediminas Paulauskas

Bug Description

I installed schooltool for testing and after removing it again i noticed by accident, that still the init-script tries to start-up when turning on the computer (I "solved" this via boot-up-manager). To be sure i tried "aptidude purge schooltool-2009", which failed and even after reaktivating the ppa and trying to remove it completly via synaptic i got the message in the attachment (sorry, its in german).
I think i will handle this somehow on my own, but maybe there is something too fix in the remove-process?

Timo Schneemann (timobauwan) wrote :
description: updated
Gediminas Paulauskas (menesis) wrote :

apt-get install schooltool-common
apt-get remove --purge schooltool-2009 schooltool-common

should allow the removal.

Changed in schooltool:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Gediminas Paulauskas (menesis)
milestone: none → 1.5.4
Timo Schneemann (timobauwan) wrote :

Thanks for the answer! Thats more or less how did it now. I installed the whole program again and removed it completely via synaptic. Now nearly all is gone. The rest is shown in attachment. The shortcuts i removed by hand, some other rests are normal as far as i know and some i didn't touch because i do not know what they might be necessary for.

Changed in schooltool:
importance: Low → High
Gediminas Paulauskas (menesis) wrote :

An update to schooltool-common was uploaded to the PPA for Maverick:

schooltool-common (6.4) maverick; urgency=low

  * debian/control: do not conflict with schooltool.
  * Incorporate scripts fixes from schooltool package in natty.
    - Start the instance on new installation
    - Silently start on restart command even if instance was not running.
    - A separate paste.log file for each instance.

 -- Gediminas Paulauskas <email address hidden> Fri, 29 Apr 2011 17:29:07 +0300

Before upgrading to Natty, update from Maverick PPA. Then, mark schooltool-common as manually installed:

  $ sudo apt-get install schooltool-common

On dist-upgrade:
- all PPA's will be disabled
- python-schooltool upgraded to 1.6.0
- installed schooltool
- removed schooltool-2009
- schooltool-common left, in obsolete packages

Take a look at differences between new standard installation and previous schooltool-2009 configuration files:

  $ diff -u /etc/schooltool/schooltool-2009/main.conf /etc/schooltool/standard/schooltool.conf
  $ diff -u /etc/schooltool/schooltool-2009/paste.ini /etc/schooltool/standard/paste.ini

Edit the standard files if needed. Restart schooltool:

  $ sudo service schooltool restart

Now you can purge schooltool-2009:

  $ sudo apt-get remove --purge schooltool-2009

Changed in schooltool (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Gediminas Paulauskas (menesis)
milestone: none → oneiric-alpha-1
milestone: oneiric-alpha-1 → none
Gediminas Paulauskas (menesis) wrote :

In Lucid the main package is schooltool-2009. The new schooltool package must cleanly replace it.

no longer affects: schooltool
Changed in schooltool (Ubuntu):
importance: Medium → High
milestone: none → precise-alpha-2
status: In Progress → Triaged
Martin Pitt (pitti) on 2012-02-06
Changed in schooltool (Ubuntu):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
Changed in schooltool (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Changed in schooltool (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Changed in schooltool (Ubuntu):
milestone: ubuntu-12.04 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers