sbuild ADT test can only pass in devel series

Bug #1686064 reported by Dimitri John Ledkov on 2017-04-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sbuild (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Dimitri John Ledkov
Yakkety
Medium
Dimitri John Ledkov
Zesty
Medium
Łukasz Zemczak

Bug Description

[Impact]

 * sbuild adt tests assume that the test is running on the host, which is the current devel series, which is not the case when adt tests are running as part of SRU regression testing.

[Test Case]

 * ADT test should pass

[Regression Potential]

 * sbuild itself is not modified, only the autopkgtest themself are fixed to not make unrealistic assumptions

[Other Info]

 * Original bug report / problem description

src:sbuild has test build-procenv which can only pass in devel series, as it assumes that the release test is running is the devel series.

This was true, until we started to run adt tests for stable releases and SRUs.

Here is the detailed log of running build-procenv on xenial, whilst devel series is called artful:

# ADTTMP=$(mktemp -d) sh -x debian/tests/build-procenv
+ set -e
+ pkg=procenv
+ components=
+ lsb_release -is
+ tr [A-Z] [a-z]
+ distro=ubuntu
+ [ -z ubuntu ]
+ lsb_release -cs
+ host_release=xenial
+ [ -z xenial ]
+ [ ubuntu = ubuntu ]
+ distro-info --devel
+ release=artful
+ components=main,universe
+ dpkg --print-architecture
+ url=http://archive.ubuntu.com/ubuntu
+ dpkg --print-architecture
+ arch=amd64
+ [ -z amd64 ]
+ [ -z /tmp/tmp.QYJvzqYkbV ]
+ dir=/tmp/tmp.QYJvzqYkbV/schroot-artful
+ chroot=artful-amd64-sbuild
+ schroot -l
+ schroots=
+ [ -n ]
+ [ -z ]
+ apt-config shell http_proxy Acquire::http::Proxy
+ RES=
+ eval
+ export http_proxy
+ echo INFO: using proxy: (none)
INFO: using proxy: (none)
+ echo INFO: Downloading source for package 'procenv' from release 'artful'
INFO: Downloading source for package 'procenv' from release 'artful'
+ apt-get source --download-only -o APT::Sandbox::User=root procenv/artful
Reading package lists... Done
E: Unable to find a source package for procenv

There are a couple of options here depending what we want to test. We can either build procenv from $current on $current release -> this will test that e.g. SRUs in xenial, do not break building packages for xenial on xenial.

Or we can try to always build procenv from $devel in $devel chroot -> this will test that all currently supported releases, can build packages for $devel series.

no longer affects: sbuild (Ubuntu Zesty)
no longer affects: sbuild (Ubuntu Artful)
Changed in sbuild (Ubuntu):
status: New → Fix Released
description: updated
Changed in sbuild (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Medium
Changed in sbuild (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in sbuild (Ubuntu Yakkety):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → yakkety-updates
Changed in sbuild (Ubuntu Xenial):
milestone: none → ubuntu-16.04.3

Hello Dimitri, or anyone else affected,

Accepted sbuild into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sbuild/0.71.0-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sbuild (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in sbuild (Ubuntu Xenial):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Dimitri, or anyone else affected,

Accepted sbuild into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sbuild/0.67.0-2ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Łukasz Zemczak (sil2100) wrote :

Let me try validating this bug. Also, the same issue seems to be affecting zesty. From what I saw the proposed change helps - if the package is moved to -updates I'll also forward the same patch to zesty. Thanks!

Changed in sbuild (Ubuntu Zesty):
status: New → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
importance: Undecided → Medium
Changed in sbuild (Ubuntu Yakkety):
status: Fix Committed → Won't Fix
tags: added: verification-done-xenial
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbuild - 0.67.0-2ubuntu7.1

---------------
sbuild (0.67.0-2ubuntu7.1) xenial; urgency=medium

  * Backport autopkgtest fixes from artful, to resolve test failures due
    to assumption that host releases matches current development
    release. With further addition to query sample package version from
    the target release. LP: #1686064

 -- Dimitri John Ledkov <email address hidden> Tue, 25 Apr 2017 14:27:27 +0100

Changed in sbuild (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sbuild has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Łukasz Zemczak (sil2100) wrote :

...I actually should have waited for the zesty package to get uploaded. My bad. Anyway, uploaded zesty version of the package - would be grateful for getting it accepted.

Hello Dimitri, or anyone else affected,

Accepted sbuild into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sbuild/0.71.0-2ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sbuild (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty
Steve Langasek (vorlon) wrote :

the autopkgtests now pass.

tags: added: verification-done-zesty
removed: verification-needed verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbuild - 0.71.0-2ubuntu2

---------------
sbuild (0.71.0-2ubuntu2) zesty; urgency=medium

  [ Dimitri John Ledkov ]
  * Backport autopkgtest fixes from artful, to resolve test failures due
    to assumption that host releases matches current development
    release. With further addition to query sample package version from
    the target release. LP: #1686064

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 29 Aug 2017 15:42:20 +0200

Changed in sbuild (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers