s390x environment is weird

Bug #1566590 reported by Dimitri John Ledkov on 2016-04-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sbuild (Ubuntu)
Undecided
Unassigned

Bug Description

https://launchpadlibrarian.net/251866360/buildlog_ubuntu-xenial-s390x.procenv_0.43-2_BUILDING.txt.gz

LANG=C.UTF-8
LC_ALL=POSIX

thus
locale:
  LANG: C.UTF-8
  LANGUAGE:
  LC_ADDRESS: C
  LC_COLLATE: C
  LC_CTYPE: C
  LC_IDENTIFICATION: C
  LC_MEASUREMENT: C
  LC_MESSAGES: C
  LC_MONETARY: C
  LC_NAME: C
  LC_NUMERIC: C
  LC_PAPER: C
  LC_TELEPHONE: C
  LC_TIME: C
  LC_ALL: POSIX

vs

https://launchpadlibrarian.net/251866399/buildlog_ubuntu-xenial-amd64.procenv_0.43-2_BUILDING.txt.gz

LANG=C.UTF-8

thus
locale:
  LANG: C.UTF-8
  LANGUAGE:
  LC_ADDRESS: C.UTF-8
  LC_COLLATE: C.UTF-8
  LC_CTYPE: C.UTF-8
  LC_IDENTIFICATION: C.UTF-8
  LC_MEASUREMENT: C.UTF-8
  LC_MESSAGES: C.UTF-8
  LC_MONETARY: C.UTF-8
  LC_NAME: C.UTF-8
  LC_NUMERIC: C.UTF-8
  LC_PAPER: C.UTF-8
  LC_TELEPHONE: C.UTF-8
  LC_TIME: C.UTF-8
  LC_ALL:

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sbuild (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2016-04-19
affects: launchpad-buildd → sbuild (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbuild - 0.67.0-2ubuntu7

---------------
sbuild (0.67.0-2ubuntu7) xenial; urgency=medium

  * utf-8-by-default.patch: Switch to C.UTF-8 by default (LP: #1566590)

 -- Adam Conrad <email address hidden> Tue, 19 Apr 2016 07:51:15 -0600

Changed in sbuild (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers