sbackup doesn't honor regex excludes on full backup

Bug #675298 reported by MichaelIhde on 2010-11-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sbackup
Status tracked in Trunk
0.10
Low
Unassigned
Trunk
Undecided
Unassigned
sbackup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sbackup

System: On Ubuntu 10.04 (although the problem appears to exist at least as far back as Ubuntu 8.04).
Package Version: 0.10.5ubuntu2.1

Expected Behavior:
I was attempting to use regular expression "excludes" to prevent .git and .svn folders from being included in backups. I tried multiple formats of the regular expressions, such as:

"/home/[^/]+?/.+/\.git/"
".+/\.git/"

and then executed "Backup Now!". The expectation is that the files.tgz would not include any files within these directories.

What Occured:
The files.tgz in the '-ful' backup directory contained files that should have been excluded.

Possible Patch:
It appears that when a full backup occurs, the exclude regex is not applied. The attached patch resolves the issue to my satisfaction.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: sbackup 0.10.5ubuntu2.1
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic-pae 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic-pae i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Sun Nov 14 15:25:38 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: sbackup

MichaelIhde (mike-ihde) wrote :
tags: added: patch
Jean-Peer Lorenz (peer.loz) wrote :

Thank you for choosing sbackup and reporting this issue. I'll apply your patch to sbackup series 0.10. Thanks for your help.

Changed in sbackup (Ubuntu):
status: New → Confirmed
Jean-Peer Lorenz (peer.loz) wrote :

The bug is reported against sbackup 0.10.5ubuntu2.1 and does not encounter with sbackup series 0.11.

Jean-Peer Lorenz (peer.loz) wrote :

I am closing this report since it is fixed in latest version of sbackup 0.11.x. Please upgrade to the latest version.

Changed in sbackup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers