simple-backup-config has incorrect example exclusion regex

Bug #157250 reported by Jonathan Rogers on 2007-10-25
2
Affects Status Importance Assigned to Milestone
nssbackup
Fix Released
Medium
Oumar Aziz OUATTARA
sbackup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sbackup

In simple-backup-config 0.10.4, if one clicks "Add" on the "Exclude" tab and "Regex" subtab, a dialog called "Exclude by regex" appears with the text "$.*\.mp3^" in the text field. However, this is a useless and nonsensical regex, since it places the end of the string before the end. A more useful default would be "^.*\.mp3$".

This is potential very confusing to any user, especially those unfamiliar with regular expressions. I had used them before I ran simple-backup-config, but had not written a regex for a while, so I assumed that the default was reasonable and didn't look up the significance of the '^' and '$' characters. I replaced the "mp3" with the substring I wished to match and was surprised when the desired path wasn't excluded.

Jonathan Rogers (jonner) wrote :

I meant to type: "However, this is a useless and nonsensical regex, since it places the end of the string before the beginning." By the way, the bogus example regex seems to be in "/usr/share/sbackup/simple-backup-config.glade".

Oumar Aziz OUATTARA (wattazoum) wrote :

Fixing it for NSsbackup on release0.1 branch

Changed in sbackup:
status: New → Confirmed
Changed in nssbackup:
assignee: nobody → wattazoum
importance: Undecided → Medium
status: New → In Progress
Oumar Aziz OUATTARA (wattazoum) wrote :

Fixed

Thank you very much for your bug report

Changed in nssbackup:
status: In Progress → Fix Committed
Oumar Aziz OUATTARA (wattazoum) wrote :

fix released on NSsbackup 0.1-3

Changed in nssbackup:
status: Fix Committed → Fix Released
Martin Schaaf (mascha) on 2008-10-30
Changed in sbackup:
status: Confirmed → Fix Committed
Luca Falavigna (dktrkranz) wrote :

Fixed in Gutsy and newer.

Changed in sbackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers