sawfish does not work

Bug #453115 reported by Eric on 2009-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sawfish (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sawfish

After login from gdm to a sawfish session,
these's no response for any keyboard input nor mouse click

~/.xsession-errors

Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xi
nput.d/default.

Eric (deadeye2k-gmail) wrote :

I got the same problem on a fresh ubuntu installation(karmic)

Michael Haggerty (mhagger) wrote :

Under lucid, when I try to choose sawfish via the login screen, it seems that sawfish is indeed started. But none of the other GNOME stuff (panels, nautilus, etc) gets started. So the screen is pretty much blank, which can be confusing.

I would like to use sawfish as my window manager but have the rest of the gnome session running. This worked under dapper and hardy but I have not yet been able to get it working under lucid.

Strangely, the old trick of "killall -HUP metacity && sleep 5 && sawfish &" worked after my first few logins. But then (after I temporarily installed and enabled compiz) it stopped working because metacity is quickly being respawned (by whom?). So I tried "killall -HUP metacity && sawfish &" (without the sleep) to try to give sawfish a chance to start before metacity respawned. This kindof worked (in the sense that sawfish took over as window manager) but metacity continued rapidly trying to respawn, failing each time because a window manager was already running. The result was that one CPU was 100% busy (top showed most of the CPU being consumed by gconfd-2 and Xorg).

I'd love to get sawfish running for its excellent key- and mouse-binding configurability!

Michael Haggerty (mhagger) wrote :

I think I've solved the problem. I got a crucial hint here:

http://fedora.1344471.n2.nabble.com/Is-Gnome-windown-manager-switching-broken-again-td1394329.html

1. I went into gconf and changed /desktop/gnome/session/required-components/windowmanager from "metacity" to "sawfish".

2. I created a file /usr/share/applications/sawfish.desktop by copying the file metacity.desktop from the same directory and changing "metacity" to "sawfish" wherever it appeared.

I'm not sure whether this is exactly right, but it seems to work for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers