sawfish-ui fails with broken pipe

Bug #433358 reported by Michael Shulman
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
sawfish (Ubuntu)
Fix Released
High
Daniel T Chen
Karmic
Won't Fix
Undecided
Unassigned
Lucid
Fix Released
High
Daniel T Chen
Maverick
Fix Released
High
Daniel T Chen

Bug Description

-- SRU report follows --

Impact: As stated in the original bug report below, attempting to invoke sawfish-ui results in an error message instead of correctly opening the graphical configuration utility for sawfish.

Resolution in current development release: Cherry-picked relevant upstream git changeset; applied in maverick's 1:1.3.5.2-1ubuntu2 (https://bugs.edge.launchpad.net/ubuntu/+source/sawfish/+bug/433358/comments/9)

Minimal patch (in maverick): http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/sawfish/maverick/revision/15

TEST CASE: From a pristine karmic or lucid installation, add the sawfish binary package, and attempt to invoke the sawfish-ui command.

Regression potential: Very low (none identified)

-- Original report follows --

Binary package hint: sawfish

In karmic alpha 6 with sawfish 1:1.3.5.2-1, the command "sawfish-ui," which is supposed to open the sawfish graphical configurator, dies with the result:

$ sawfish-ui
eval_req: Broken pipe
$

The same happens with the command-line interface program "sawfish-client".

ProblemType: Bug
Architecture: i386
Date: Sat Sep 19 22:06:23 2009
DistroRelease: Ubuntu 9.10
Package: sawfish 1:1.3.5.2-1
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SourcePackage: sawfish
Uname: Linux 2.6.31-10-generic i686

Revision history for this message
Michael Shulman (shulman) wrote :
Revision history for this message
Michael Shulman (shulman) wrote :

On current karmic beta, the error message is somewhat different:

$ sawfish-ui
eval_req: Connection reset by peer
*** Remote sawfish error: unknown error
$

I'd be happy to try to help debug this if anyone can give me instructions.

Revision history for this message
Michael Shulman (shulman) wrote :

Is no one else having this problem? I find it pretty serious.

Revision history for this message
Leszek Lesner (leszek-lesner) wrote :

I am experiencing the same problem. I think it has something to do with the upstream version that had the same problem but got fixed.
Upgrading would be wise here.

I downgraded my sawfish version to work with it properly for now.

Revision history for this message
Gabriele Favalessa (favalex) wrote :

The patch mentioned here http://sawfish.wikia.com/wiki/Fix_sawfish_server_connection fixed the problem for me.

I couldn't track down in what version the bug was introduced and in what version in was fixed, since the references are to SVN revisions, but they seem to have switched to git.

bvk (bvk)
Changed in sawfish (Ubuntu):
assignee: nobody → bvk (bvk)
bvk (bvk)
Changed in sawfish (Ubuntu):
assignee: bvk (bvk) → nobody
Revision history for this message
cyber_rigger (cyber-rigger) wrote :

I confirm this with Karmic

I can confirm this bug with Karmic .

$ sawfish-ui
eval_req: Connection reset by peer
*** Remote sawfish error: unknown error

I'm using sawfish 1.3.5.2-1

uname -a
Linux *** 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 i686 GNU/Linux

This is on a 32 bit AMD processor.
------------------------------------------------------------------------------------------------------------------
I have a similar installation on an AMD64 (64 bit kernel) and sawfish-ui works fine.

$ uname -a
Linux *** 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:02:26 UTC 2010 x86_64 GNU/Linux

Revision history for this message
Fergal Daly (fergal) wrote :

I see the same thing in lucid. Is this package maintained in Ubuntu? There seems to be no individual listed.

Revision history for this message
Daniel T Chen (crimsun) wrote :

According to "git log src/server.c", it's:

commit ff1212a2006f195fa35335e1a6432cfb3ab51e7b
Author: Christopher Bratusek <email address hidden>
Date: Sun Dec 28 19:16:32 2008 +0000

    fixed an "unknown remote error", that might appear

    svn path=/trunk/; revision=4338

Changed in sawfish (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: New → Triaged
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sawfish - 1:1.3.5.2-1ubuntu2

---------------
sawfish (1:1.3.5.2-1ubuntu2) maverick; urgency=low

  * debian/patches/remote_sawfish_error.patch:
    Cherry-pick relevant code hunk from upstream git changeset
    ff1212a2006f195fa35335e1a6432cfb3ab51e7b to resolve fatal
    error at runtime. (LP: #433358)
 -- Daniel T Chen <email address hidden> Fri, 02 Jul 2010 02:06:11 -0400

Changed in sawfish (Ubuntu Maverick):
status: Triaged → Fix Released
Daniel T Chen (crimsun)
description: updated
Daniel T Chen (crimsun)
Changed in sawfish (Ubuntu Lucid):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → High
milestone: none → lucid-updates
status: New → In Progress
Revision history for this message
Jonathan Riddell (jr) wrote :

Lucid SRU needs a patch added or linked to from this bug and a test case. (also approval from ubuntu-sru)

Revision history for this message
Daniel T Chen (crimsun) wrote : Re: [Bug 433358] Re: sawfish-ui fails with broken pipe

Please see the bug description; the patch is linked from bazaar (viewable
through loggerhead) and the test case as well.

On Jul 20, 2010 9:57 AM, "Jonathan Riddell" <email address hidden> wrote:

Lucid SRU needs a patch added or linked to from this bug and a test
case. (also approval from ubuntu-sru)

--
sawfish-ui fails with broken pipe
https://bugs.launchpad.net/bugs/433358
You received this bug ...

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted sawfish into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in sawfish (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Fergal Daly (fergal) wrote :

From apt-cache showpkg:

1:1.3.5.2-1ubuntu1.1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-proposed_universe_binary-amd64_Packages) (/var/lib/dpkg/status)

So I think I'm using the right package

Several problems:
1 I created a test account (with a fresh homedir) and chose sawfish on the login screen, I got nothing on log in. None of my mouse buttons do anything (I think it was middle-click to get the sawfish menu to launch things).

2 rep is not installed and so sawfish-ui still gives me "exec: 8: rep: not found". So the dependencies seem busted.

That said, with rep installed #2 goes away and I can kill metacity, start sawfish and successfully start sawfish-ui.

I have not tried logging into my every-day account with sawfish as the WM yet, I have a lot of state on my desktop that I don't want to get rid of right now.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Fergal, please file a separate bug for the missing dependency on rep.

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted sawfish into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Lucid:
I have reproduced the problem with sawfish 1:1.3.5.2-1ubuntu1 in lucid and have verified that the version of sawfish 1:1.3.5.2-1ubuntu1.2 in -proposed fixes the issue.

But because of bug 573197 (sawfish < 1.5.2 incompatible with rep >= 0.90) sawfish-ui can not be started.

I'm marking as verification-done because the issue reported here is fixed but the package still need a fix in order to be used.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Daniel, do you plan to port the fix to Karmic or is it a won't fix ?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sawfish - 1:1.3.5.2-1ubuntu1.2

---------------
sawfish (1:1.3.5.2-1ubuntu1.2) lucid-proposed; urgency=low

  * Add rep as an explicit dependency of sawfish, otherwise sawfish-ui
    fails. (LP: #616115)

sawfish (1:1.3.5.2-1ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/remote_sawfish_error.patch:
    Cherry-pick relevant code hunk from upstream git changeset
    ff1212a2006f195fa35335e1a6432cfb3ab51e7b to resolve fatal
    error at runtime. (LP: #433358)
 -- Daniel T Chen <email address hidden> Sun, 15 Aug 2010 15:22:38 -0400

Changed in sawfish (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Rolf Leggewie (r0lf)
Changed in sawfish (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers