too many SCSI scanners found

Bug #172433 reported by Explosive on 2007-11-27
4
Affects Status Importance Assigned to Milestone
sane-frontends (Ubuntu)
Undecided
Unassigned

Bug Description

I have Agfa Arcus II scanner attached to Adaptec 29160 SCSI card
It works fine in Ubuntu 7.04 but it work bad in Ubuntu 7.10
I also have Minolta scanner attached to USB.

I use program Vuescan. When I run it in Ubuntu 7.04, it show me drop down meny which have entry for Agfa scanner and entry for Minolta scanner. I can choose any of this scanners and it work fine.
When I run Vuescan in Ubuntu 7.10, it show about 30 entrys for Agfa Arcus II and 1 entry for Minolta scanner in same drop down menu .
I can choose any scanner in this menu, but only Agfa scanner works, even if I choose Minolta. And Agfa scanner works bad. From time to time it turn off leds and don't work till system reboot.

When I run XSane, it show me very long list of Agfa Arcus II I even can't choose Minolta scanner because list is out of screen.

When I type sane-find-scanner, it say that I have Agfa Arcus II scanner attached in same time to sg3, to sg4, to sg5.... sg9

I didn't get any answer from forums. :((

Explosive (mal-off) wrote :

hi all !!
Recompiled kernel works good with scanner. Only one Agfa Arcus II. :)))
This page helped me to recompile kernel http://www.howtoforge.com/roll_a_kernel_debian_ubuntu_way

in makemenuconfig in Device drivers-> SCSI device support , uncheck option "Probe all LUNs"

Jonathan Carter (jonathan) wrote :

Hi Explosive. Have you checked whether this problem also occurs in Ubuntu 8.04?

Explosive (mal-off) wrote :

Hi . Ubuntu 8.04 have no problem

Daniel T Chen (crimsun) on 2008-11-16
Changed in sane-frontends:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers