scanimage does not scan image with CanoScan FB630U

Bug #118843 reported by Wolf Rogner on 2007-06-05
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
sane-frontends (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: sane

scanimage > test.prn

does not produce a scan

Scanner Canon 636u

wolf@hb:~$ lsusb
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 04a9:2204 Canon, Inc. CanoScan FB630U
Bus 002 Device 003: ID 03f0:011d Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 05ac:0304 Apple Computer, Inc.
Bus 001 Device 001: ID 0000:0000

Scanner detected. After scan attempt, scanner is unmounted and mounted again at a higher Device ID

What else can I provide to help you isolate.

der_vegi (m-may) wrote :

I have the same problem here with a fresh install of Gutsy i386, all updates till today applied. Xsane does start and find the scanner. Scanning does not work, xsane does not respond for a while and then shows a blank image. After the first scan, I cannont access the scanner anymore, 'scanimage -L' does not find it anymore. I have tu plug it out and in again.
Also, I notice a very high sound (barely audible), during the time, Xsane is 'working', so there seems to be some power supplied to the scanner.

It works in Hardy Alpha amd64 on another pc, though.

Changed in sane-frontends:
status: New → Confirmed
der_vegi (m-may) wrote :

Installing libsane and sane-utils from Hardy (that includes also new libc6) does not resolve the issue. So it might be a dbus or kernel problem?

der_vegi (m-may) wrote :

If that helps, here the output of 'cat /proc/version': Linux version 2.6.22-14-generic (buildd@terranova) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Tue Dec 18 08:02:57 UTC 2007 .

der_vegi (m-may) wrote :

This bug might be related to the problem described in the forums here http://ubuntuforums.org/showthread.php?t=446207 , so it seems to be a kernel problem.
I don't think, it is a duplicate of bug 85488 , as the command 'scanimage' produces a scan there.

der_vegi (m-may) wrote :

output of 'dmesg'

Changed in dell:
status: New → Invalid

The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . Please note that Alpha3 will be released within the next day or two so you may want to wait. You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .

Changed in linux:
status: New → Incomplete

I've opened a new task against the actively developed kernel and am closing the task against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
der_vegi (m-may) wrote :

I have already tested this scanner on my other machine with Hardy Alpha (1 or maybe 2, amd64), it does work indeed. But the machine, where this scanner is used, is a couple of hours away from me and I do not want to install an unstable release of Ubuntu there, especially, as updates are a little bit painful with modem connection. ;)

So is there no chance that this bug will be fixed in Gutsy? Can I provide further information? I'll probably have access to this machine again in a couple of days.

der_vegi (m-may) wrote :

Okay, with the newest updates until today installed, the scanner works again now. It is a little bit slow while initializing, but apart from this, it seems to be fine. Didn't have too much time for testing, though.

Thanks for testing and the update. I'm glad to hear things are working. It's unlikely that a fix will be backported to Gutsy as this does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux:
status: Incomplete → Fix Released
der_vegi (m-may) wrote :

Well. Now, a couple of weeks later, I am testing this machine again and the scanner does not work anymore, same problem as described above... :(

der_vegi (m-may) wrote :

This problem seems to happen to others as well: http://ubuntuforums.org/showthread.php?t=612797 .

Hi der_vegi,

Can you comment what version of the kernel you are running when experience the regression? Also care to test with the latest Hardy Alpha6 release which was recently released and if the issue still exists, attach an updated dmesg output. Thanks.

Changed in linux:
status: Fix Released → Incomplete
der_vegi (m-may) wrote :

Well, the next time I will have access to this machine will be around August... The kernel was the latest available for Gutsy at that moment.

Wolf Rogner (war-rsb) wrote :

On 8.04 this issue is fixed (at least on 3 machines here).

If it works for others, I would like to close this bug.

Wolf Rogner (war-rsb) wrote :

Suggest closing it

Changed in sane-frontends:
status: Confirmed → Fix Committed
Wolf Rogner (war-rsb) wrote :

It works in 8.04 on several machines. Slow but works

Changed in linux:
status: Incomplete → Fix Committed

It doesn't work on 3 different machines that have just been upgraded to 8.04.
kernel: Linux Chronotis 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux
libsane 1.0.19-1ubuntu
$ scanimage -L
device `canon630u:libusb:003:003' is a CANON Canoscan FB630U flatbed scanner
$ scanimage
scanimage: sane_start: Device busy
<remove scanner and plug back in>
$ xsane (and initiate scan - 30 second delay then "Device busy" message
May 22 21:20:32 Chronotis kernel: [ 227.416039] usb 3-1: usbfs: USBDEVFS_CONTROL failed cmd xsane rqt 64 rq 12 len 1 ret -110
May 22 21:20:32 Chronotis kernel: [ 227.417335] usb 3-1: usbfs: USBDEVFS_CONTROL failed cmd xsane rqt 64 rq 12 len 1 ret -71 (repeated many times)

$ SANE_DEBUG_CANON=128 scanimage
[sanei_debug] Setting debug level of canon to 128.
[canon] >> sane_init
[canon] sane_init: sane-backends 1.0.19
[canon] >> attach_one
[canon] >> attach
[canon] attach: opening /dev/scanner
[canon] attach: open failed: Invalid argument
[canon] << attach_one
[canon] << sane_init
[canon] >> sane_get_devices
[canon] << sane_get_devices
scanimage: sane_start: Device busy
[canon] >> sane_exit
[canon] << sane_exit

der_vegi (m-may) wrote :

I am on Intrepid (i386) now. Sometimes, the scanner works, but most of the time, I get an error in dmesg like this

[12411.302123] usb 4-1: usbfs: USBDEVFS_CONTROL failed cmd sane-find-scann rqt 128 rq 6 len 2 ret -71

many times repeated.

My current kernel: Linux 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux.

der_vegi (m-may) on 2008-11-02
Changed in linux:
status: Fix Committed → New
der_vegi (m-may) wrote :

Can someone else confirm, that the scanner still does not work on Intrepid? As the device is quite old by now, I am not 100% sure, if this is maybe related to my device.

Here some further information on the way the scanner crashes: When I plug it in, xsane finds the scanner, I do a scan and after approx. 30s (the scanner does not move) I get a blank image. Next scan does not work, as the device claims to be busy.

Glenn Mills (grmills) wrote :

I have just connected a Canon FB630U to my Laptop running Intrepid and experience the same problem as described above.
Have not had a successful scan yet. Just get the following errors in the logs.

usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd xsane rqt 64 rq 12 len 1 ret -110
usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd xsane rqt 64 rq 12 len 1 ret -71
Repeated many times

Kernel is 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux

Daniel T Chen (crimsun) on 2008-11-23
Changed in linux:
status: New → Confirmed

I've got exactly the same problem under intrepid 32bit. In fact, I've never got this scanner to work 100% reliably under linux. When I get the above error, I have to disconnect/reconnect the scanner and try again. After some times it works (sometimes setting the debug options works too, but that shouldn't be related).

Hanno (hzulla) wrote :

Same Problem, with Intrepid 32 bit. Scanner works fine in Windows, but not in Ubuntu.

briancb (brian-bosomworth) wrote :

Same problem in Karmic Linux 2.6.31-16-generic x86_64

Sane recognises scanner but just does not scan

MIchael B (silverlightningcat) wrote :

Yeap I have the same problem, had it for months now. "Scanner is Busy" work in Jaunty.

I really need my scanner but short of getting stuck in at a development level I cant seem to fix it.
I have tried reintallling the Jaunty packages but this hasn't fixed it in my case.

Still does not work in Ubuntu 10.10 2.6.35-25-generic #44-Ubuntu.
It worked briefly in an earlier variant of 10.10.
It's been a long time!!!

Mark Lanctot (mark-lanctot) wrote :

Very intermittent operation here on Ubuntu 10.10 2.6.35-28-generic #49-Ubuntu SMP x86_64.

It works about once per boot. It usually fails by working a little, the scan mechanism jogs a little bit. After this it never works again, either resulting in nothing, a "device busy" error or a device I/O error. If I unplug and reinsert the USB cable I might get the mechanism to jog again but the same errors after that.

I've got a suspicion that malformed commands are being sent to the scanner, causing the mechanism to stop. Commands sent after that result in errors and I'm getting the impression they're held in a software queue, which is why the errors remain consistent until the USB plug is removed. Once reinserted, the queue is cleared but the malformed command is sent again.

Jaunty was the last version where this scanner worked well. It's been this way ever since.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix

Has this fix landed in Ubuntu? Does this still happen?

Changed in sane-frontends (Ubuntu):
status: Fix Committed → Incomplete
Wolf Rogner (war-rsb) wrote :

The scanner stopped working as of 10.10.

scanimage must be the problem. Using VueScan the scanner works immediately (without any noticable delay) and repetitively.
Using scanimage the scanner stops working after the 5th line and has to be reset (using Windows and Canons ScanGear Toolbox or VueScan).

The error still prevails.

Changed in sane-frontends (Ubuntu):
status: Incomplete → Confirmed
Changed in somerville:
status: New → Invalid
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305593

no longer affects: somerville

Wolf Rogner, thank you for reporting this bug to Ubuntu. Maverick reached EOL on April 10, 2012.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Is this reproducible in a supported release? If so, please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p sane-frontends 118843

no longer affects: linux-source-2.6.22 (Ubuntu)
Changed in sane-frontends (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for sane-frontends (Ubuntu) because there has been no activity for 60 days.]

Changed in sane-frontends (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers