Ubuntu

package libsane 1.0.22-7ubuntu1 [modified: lib/udev/rules.d/40-libsane.rules] failed to install/upgrade: './lib/udev/rules.d/40-libsane.rules' is different from the same file on the system

Reported by Robse on 2012-03-11
194
This bug affects 29 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Undecided
Unassigned

Bug Description

Samsung SCX3200

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libsane 1.0.22-7ubuntu1 [modified: lib/udev/rules.d/40-libsane.rules]
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sun Mar 11 22:15:55 2012
DuplicateSignature:
 Unpacking libsane:i386 (from .../libsane_1.0.22-7ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libsane_1.0.22-7ubuntu1_i386.deb (--unpack):
  './lib/udev/rules.d/40-libsane.rules' is different from the same file on the system
ErrorMessage: './lib/udev/rules.d/40-libsane.rules' is different from the same file on the system
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120308)
SourcePackage: sane-backends
Title: package libsane 1.0.22-7ubuntu1 [modified: lib/udev/rules.d/40-libsane.rules] failed to install/upgrade: './lib/udev/rules.d/40-libsane.rules' is different from the same file on the system
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.sane.d.xerox.mfp.conf: 2012-03-08T20:04:55.663817

Robse (rob-se) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
Clyne Dawes (cedawes) wrote :

I selected "fix released" in error

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Released
Adam Thompson (athompso) wrote :

Same error. udev rules file previous modified to accomodate Brother scanner drivers.

Toby (to-mueller87) wrote :

What worked for me was making a backup (that I never used again) of './lib/udev/rules.d/40-libsane.rules' and then delete it. After that everything works fine for me. It did not affect my installed mfp with proprietary drivers.

Manpreet Sushil (manssster) wrote :

Yes, the above (Toby (to-mueller87) wrote on 2012-08-09:) worked for me too.. thanks..

tags: added: bugpattern-needed

I can confirm that the workaround from "Toby (to-mueller87) wrote on 2012-08-09" worked for me as well (Bug #1041915 that I filed is a duplicate of this one) .
I did this:
cp 40-libsane.rules 40-libsane.rules-2012-08-26-for-scanner-breaks-apt
sudo rm 40-libsane.rules

Then the repair using the "Ubuntu Software Center" worked.

Homer (omer-simha) wrote :

Toby solution worked here too.
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/952544/comments/5

I didn't check if the scanner still working, but I can always revert to
./lib/udev/rules.d/40-libsane.rules.old

August Quint (augustq) wrote :

that link helped me too.

I modified this file to myke my scanner (Brother DCP-7010) working - as recommended somewhere.

But when I try to install wine then I got this error.

AugustQ

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers