[Feisty]Regression from edgy: Unable to scan properly

Bug #93515 reported by Luca Beltrame on 2007-03-18
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
sane-backends (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrading to Feisty I'm unable to scan properly using SANE. My scanner is an Acer (now BenQ) 640BU: it uses the snapscan backend and requires a firmware upload.

Steps to reproduce:

1. Connect the scanner
2. Open kooka or xsane
3. Do a preview scan

Actual result:

After scanning, the lamp doesn't return to its former position (it's also turned off) and the scanner is "hung" - doesn't accept new commands, and doesn't show up on scanimage -L either. Only by physically turning it off and back on it is seen by the kernel again, but however the problem remains.

Expected result:

The preview scans completes normally.

I'll attach lsusb, my snapscan.conf and a dmesg if possible.

max63 (max-maxbase) wrote :

Same behavior here with a LIDE25, doesn't work on feisty, but it doesn't work with my other PC which is based on edgy with a home made 2.6.19.1 kernel.

max@max-desktop:~$ lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 04a9:2220 Canon, Inc.
Bus 001 Device 001: ID 0000:0000

Clay Weber (claydoh) wrote :

see bug #85488, this is looking to effect a number of scanner backends

max63, you can fix this on your kernel by disabling the option 'USB selective suspend/resume and wakeup' (USB_SUSPEND) but that may possibly effect other parts of your system

max63 (max-maxbase) wrote :

Thanks Clay Weber but I think I will wait for a feisty update

SpookyGhost (francesco-g) wrote :

I have the same problem with a agfa snapscan 1212 scanner. Only the first "scan" work then i have to
unplug and plug again the scanner from the USB port.
With edgy the scanner work

# lsusb
Bus 002 Device 002: ID 1058:0900 Western Digital Technologies, Inc.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 06bd:0001 AGFA-Gevaert NV SnapScan 1212U
Bus 001 Device 001: ID 0000:0000

Jaime (jaime-lopez) wrote :

Same problem with Benq (Acer) S2W 3300U

Device correctly detected with snapscan -L, but after selecting the scanner in xsane device dialog, it completely hangs, complaining several minutes later about scanner being busy, and unlisting it from snapscan -L
It worked fine with Dapper

# lsusb
...
Bus 003 Device 003: ID 04a5:20b0 Acer Peripherals Inc. (now BenQ Corp.) S2W 3300U/4300U
...

# scanimage -L
...
device `snapscan:libusb:003:003' is a Acer FlatbedScanner23 flatbed scanner

SpookyGhost (francesco-g) wrote :

Now ia am on feisty 7.04 "stable" the problem is still present.

Same problem here with Canon LiDE 30 (Feisty).

L2D (laurent-vlp) wrote :

I experiment the same problem with a Canon LiDE 30 (Feisty). With previous ubuntu versions, no problem occurs.

Robert Hrovat (robi-hipnos) wrote :

Same problem with Canon N670U and Lide 20. Edgy and Dapper worked perfect.

markba (mark-baaijens) wrote :

Confirmed on AGFA SnapScan e20.
In my case, opening xsane results in a dialog teling ther are no devieces found.
Scanner worked flawlessly under Edgy.

Hannes Pasqualini (hanzolo) wrote :

confirm this problem on my system as well:
I have tried to use my scanner ever since and I always had the problem that it would get recognized but sometimes just would not work saying something like "no device found" (sorry can't reproduce the problem right now). Since I got feisty things have changed, but to the worse. Now, after scanning (also after preview scan) the lamp does not go back to the start position, but locks up somewhere in the middle, also warming-up times have become much longer and the device makes some weird noise while moving. I also installed the firmware file but this would not have any effect on the problem. Here's some technical specs:
Distro: Ubuntu Fesity Fawn i386
Computer: Amd Athlon 64, Asus a8v Deluxe mo.bo., scanner is attached to an usb port on the mo.bo. no hubs in between.

here's the sane-find-scanner output:
found USB scanner (vendor=0x04b8 [EPSON], product=0x0121 [EPSON Scanner]) at libusb:005:004

and this is what it says when I use scanimage -L:
device `snapscan:libusb:005:004' is a EPSON EPSON Scanner1 flatbed scanner

"scanimage -d snapscan > test.pnm" seems to work fine (at least it did until now)

I hope this can be of some help for getting some bugs squashed out!
Hannes Pasqualini

Hannes Pasqualini (hanzolo) wrote :

sorry forgot to specify the model: EPSON 2580 Photo (USB)

JSladek (wb4ubd) wrote :

Same problem with Benq 620U. The problem also shows in the Ubuntu Feisty live-cd. The Edgy live-cd and PCLinuxOS2007 live-cd works as it should (all three use the same version of libusb and sane).

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers