Ubuntu

some usb_devices fault if usb_suspend enabled

Reported by Clay Weber on 2007-02-16
302
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Graphics
Invalid
Undecided
Unassigned
Linux
Fix Released
Medium
sane-backends
Expired
Medium
xsane
Invalid
Undecided
Unassigned
libusb (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Emanuel Goscinski
linux-source-2.6.20 (Baltix)
Undecided
Unassigned
linux-source-2.6.20 (Debian)
Fix Released
Unknown
linux-source-2.6.20 (Ubuntu)
Low
Unassigned
Nominated for Feisty by Emanuel Goscinski
linux-source-2.6.22 (Ubuntu)
Medium
Amit Kucheria
Nominated for Feisty by Emanuel Goscinski
sane-backends (Ubuntu)
Medium
brethes
Nominated for Feisty by Emanuel Goscinski

Bug Description

Binary package hint: libsane

In Feisty, using xsane or Kooka, my Canon Lide25 scanner, which uses the plustek backend, does not produce any scanned image, though both gui applications go through the motions (progress dialogs, etc) and produce a black preview. Using the command line 'scanimage' does produce a scan correctly

The scanner works correctly in Edgy.

Fix= disable "usb selective suspend/resume' in linux-source

ProblemType: Bug
Date: Thu Feb 15 22:27:27 2007
DistroRelease: Ubuntu 7.04
Uname: Linux feisty 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux

CVE References

Hi :-)

I have a Canon LiDE 25 scanner, woking perfectly with sane-backends-1.0.17. After an upgrade to version 1.0.18 (Gentoo
release 1.0.18-r2), the scanner didn't work anymore; other people also experienced problems with other scanners (see
http://forums.gentoo.org/viewtopic-t-506227.html -- German).

sane-find-scanner lists the scanner anyway, but scanimage -L didn't work anymore.

After a downgrade to version 1.0.17, everything works as expected again.

Greetings, Tobias

Reproducible: Always

Steps to Reproduce:

I am not sure what I can do about this, but I will check the source differences and sane CVS as soon as I find some time (which is quite a problem at the moment).

About the forums thread:
Sorry, but sane-backends 1.0.18 has been in ~x86 since july 2006 and in x86 since september. Since no developer has all the hardware I have to rely on user feedback. This is the first time I am told about such problems with .18.

They just didn't report a bug, as the downgrade worked for them ;-) I don't know if dev-libs/libusb-1.1.11 matters (as reported on the forums), as just downgrading sane-backends worked for me. I also reported this bug on the SANE bugtacker: https://alioth.debian.org/tracker/index.php?func=detail&aid=304426&group_id=30186&atid=410366

Hi,

I have another possible solution to the problem:

My LiDE 25 worked again after removing the kernel-option "Device Drivers - USB Support - USB selective suspend/resume and wakeup". The problem appeared with gentoo-sources-2.6.19.

Other versions:
libusb 0.1.12
sane-backends 1.0.18-r2

470 comments hidden view all 481 comments
barbobot (deadlyh) wrote :

I am also experiencing this problem.

Bus 001 Device 011: ID 04a9:2220 Canon, Inc.
(While it's device ID is well known, I think it's worth note here)

sane-backend uses the plustek driver for this particular scanner.

yostral (y-o) wrote :

Same here, with a canon lide 30 :

Bus 001 Device 009: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30

It's recognized, but doesn't work at all. Nothing is previewed and nothing is scanned.

This scanner works perfectly with dapper and edgy.

echazare (elie-chazarenc) wrote :

Same here, with a canon lide 20 :
Bus 003 Device 002: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20
It's recognized, but doesn't work at all. Nothing is previewed and nothing is scanned.
This scanner works perfectly with dapper and edgy.

etx90 (bruno-germain5) wrote :

Same problem with a Canon Canoscan N656U.

This scanner : works fine with MS Windows
                       makes a lot of noise and does not scan anything with Edgy
                       seems to be recognized with Feisty (herd5), but nothing is previewed nor scanned.

I'm using Xsane under Edubuntu and Omnipage under XP.

Fabio Marzocca (thesaltydog) wrote :

I confirm this bug in Feisty (xsane was working perfectly with all previous ubuntu versions).

Bus 001 Device 002: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30

lebouvier (seb-video) wrote :

i confirm this bug too in feisty. i've got a Canon lide 30 who works perfectly under dapper and edgy but since Feisty it doesn't work at all.

Changed in sane-backends:
status: Unconfirmed → Confirmed
importance: Undecided → Medium
Emanuel Goscinski (emu-) wrote :

Same here with a canon Lide25 and plustek backend.
There appears no errors so that all seems ok but the scanner doesnt scan and a black picture appears in the end.

max63 (max-maxbase) wrote :

Same for me with a LIDE25 too, the scanner doesn't work just scan a black page.

Lemmit Kaplinski (lemmit) wrote :

Same here with Lide 25.

Additionally the scanner was not recognized by udev and I had to add the following to /etc/udev/rules.d/45-libsane.rules:
# Canon CanoScan N670U/N676U/LiDE20
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="2220", MODE="664", GROUP="scanner"

Thom Pischke (thom-pischke) wrote :

Same here. Canoscan n1240u. Worked fine in Edgy. In feisty, it pretends to work, but does not actually scan, just produces a black page.

scanimage via command does work however.

Clay Weber (claydoh) wrote :

I wonder if it is a kernel/udev/hal issue as it seems that the libsane version is the same in Edgy and Feisty

http://bugs.gentoo.org/show_bug.cgi?id=165315#c3

Thom Pischke (thom-pischke) wrote :

Also tried with gnomescan. Exact same behavior. It pretends to scan, with a progress bar and everything, but the scanner itself doesn't even make a peep.

Booted windows and made the scan with no problem, so no issue with the scanner.

Clay Weber (claydoh) wrote :

From the gentoo bug listed above
http://bugs.gentoo.org/show_bug.cgi?id=165315#c3
I compiled a kernel with the 'USB selective suspend/resume and wakeup' disabled, and it does fix this issue in kooka, xsane and xscanimage. The option is marked as experimental

Should I file a bug on linux-source package?

Clay Weber (claydoh) on 2007-03-21
description: updated
description: updated
Ben Collins (ben-collins) wrote :

Unfortunately this option needs to remain enabled so that a good chunk of other users can have suspend/resume, which ultimately is more important than a working scanner.

Hopefully someone sooner or later will fix this properly.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: Unconfirmed → Confirmed
Changed in sane-backends:
status: Unknown → In Progress

Bug is confirmed in Ubuntu Feisty with a Canon N1240U Scanner. The scanner is recognized when plugged in ("dmesg" and "lsusb" list it correctly), but scanning with any GUI (xsane, gnomescan or from within GIMP) is not possible. Using "scanimage" from the command line works, but even that sometimes needs a kick off by first invoking "sane-find-scanner" and then "scanimage -L". After that, the scanning starts smoothely.

Until the kernel/sane problems are solved I propose a small workaround. Edit the file .bashrc in your home directory and add the following alias (everything on one line, modifications of are up to you):

alias scan='scanimage --format tiff --resolution 300 -x 215 -y 297 > ~/Desktop/scanned_image'

From now on you can scan an image by simply typing "scan" in the command line. The file will be saved as TIFF with a resolution of 300 dpi as scanned_image to your Desktop. And dont' forget: If it doesn't scan, you have to try "sane-find-scanner" and/or "scanimage -L" first. Good luck!

I have the same problem with my Canon Lide 20!

Here the Scanner works with the original Feisty Herd5 Iso release(kernel 2.6.20-9 without any updates) but stopped working after applying all updates incl. kernel 2.6.20-12. A reboot with the kernel 2.6.20-9 after applying the updates, don't solved the problem.

So i think that the problem is not only caused by that (USB selective suspend/resume) kernel option!

Ian (superian) wrote :

And another confirmation. Canon LiDE 20, recognised (although not quickly) but that's about it.

Ben said "which ultimately is more important than a working scanner". Well, it depends who has the scanner :) and I'd be surprised if this is the only USB peripheral that's been broken.

My current workaround is to reboot to an earlier live CD and save to a memory stick, but I'll give the other suggestions a go.

Renzo Bagnati (renbag) wrote :

I noticed the same problem with a HP ScanJet 4070 (hp3900 backend) and with an Epson Perfection 1260 (plustek backend). The scanners were perfectly workig in edgy with xsane.

Ulisse (ulipo) wrote :

Canon LiDE25 on Feisty, same as above.
Scanning thru command line works.

Jorge Castelao (jcastelao) wrote :

The same problem with a Canon LiDE30 (Bus 002 Device 008: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30). It works properly under Dapper and Windows, but not under Feisty fully actualized.

confirmed for Feisty with all updates (29.3.07) or from Live-CD:
Canon N650U doesn't work.
Same machine with edgy works out of the box.
Is anyone working on this?
I need a working scanner more than suspend/resume...

As I was informed, the USB_SUSPEND seems to be needed for many people to be able to suspen/resume their laptops, and there are a *lot* of laptops out there these days. I think it has to be fixed in the sane code, not in the kernel, but there are not enough entries in Sane's bug reports/mailing lists

Maybe adding to the existing bug report there might get some attention?
https://alioth.debian.org/tracker/?group_id=30186&atid=410366&func=detail&aid=304132

Dean Loros (autocrosser) wrote :

Same problem as above--Command-line "fix" works (but not a answer). scanimage -L & lsusb below.

dean@linux:~$ lsusb
Bus 006 Device 001: ID 0000:0000
Bus 007 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 005 Device 002: ID 06a3:8021 Saitek PLC
Bus 003 Device 002: ID 0803:9700 Zoom Telephonics, Inc. 2986L FaxModem
Bus 003 Device 001: ID 0000:0000
Bus 008 Device 001: ID 0000:0000
Bus 008 Device 002: ID 04f9:0029 Brother Industries, Ltd
Bus 004 Device 002: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 005: ID 07d0:1106 Dazzle
Bus 001 Device 002: ID 0c0b:2bcf Dura Micro, Inc. (Acomdata)
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 059f:0202 LaCie, Ltd
Bus 002 Device 001: ID 0000:0000
dean@linux:~$ scanimage -L
device `plustek:libusb:004:002' is a Canon N670U/N676U/LiDE20 USB flatbed scanner

llimaa (llimaa) wrote :

@Clay Weber: In Debian Etch it works fine and iirc it's even the same xsane version as in ubuntu feisty. So the problem cant be the xsane code! But maybe depends of compilation options or something else.

Dean Loros (autocrosser) wrote :

I am wondering how this is to be resolved then. Scanimage works, but Xsane won't. What information do you need to help find the error?

Clay Weber (claydoh) wrote :

@ llimaa, as I noted, if you compile a kernel without USB_SUSPEND, it works fine. and as Ubuntu kernel dev Ben Collins also noted, this option is needed for laptop suspend/resume, so either libusb or sane-backends/xsane/kooka/quiteinsane/etc needs to be patched somehow to resolve this. And as i don't see *all* scanners broken, I am guessing this may need to be done for each sane backend (driver) that is exhibiting these issues. Easier than kernel/libusb hacking I am sure.

I have lost the link, but I did find that someone had determined that the scanners were being set to 'sleep' much too quickly so the scanner never even starts, or for those that do, it stops before finishing its path

now to see if i can find where I discovered that information.......

Clay Weber (claydoh) wrote :

@ Dean Loros;
I really have no idea, no one with the technical knowledge has afaik responded to any of the bugs in sane's bug tracker, and only one response in their mailing list.

Dean Loros (autocrosser) wrote :

So this seems to be a problem with interaction of some of the sane backends & hal/udev/USB_SUSPEND. Looks like some of the backends need to access USB "differently".

Dean Loros (autocrosser) wrote :

I just got some information from sane-development-list

Subject: Re: [sane-devel] LIde 20 scanner & kernels newer than
 2.6.20-9 (snip)

I'm using backend with no problems in kernel 2.6.20 disabling such
option. Most backends use libusb to establish communitation between device
and PC. Libusb doesn't provide functions to check that condition. May be
I'm wrong but If it's not a kernel problem (USB_SUSPEND is yet experimental)
I think that problem must be fixed in libusb libraries.

Jonathan Bravo

I an going to file this with libusb & point to this bug.

Renzo Bagnati (renbag) wrote :

I have recompiled the ubuntu feisty kernel disabling the 'USB selective suspend/resume and wakeup' option, but in my case the problem remained. With my HP ScanJet 4070 (hp3900 backend) xsane freezes while triyng to find the device. xscanimage, instead, works if the correct device name is supplied.
I then used strace to see what happens with xsane and found that it was continuosly writing to /dev/parport0:

...
open("./geniusvp2.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/etc/sane.d/geniusvp2.conf", O_RDONLY) = 6
fstat64(6, {st_mode=S_IFREG|0644, st_size=877, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7329000
read(6, "# geniusvp2 backend configuratio"..., 4096) = 877
read(6, "", 4096) = 0
close(6) = 0
munmap(0xb7329000, 4096) = 0
open("/dev/parport0", O_RDWR) = 6
ioctl(6, PPCLAIM, 0x825a1c8) = 0
ioctl(6, PPGETMODES, 0xbf98baac) = 0
ioctl(6, PPWCONTROL, 0xbf98ba80) = 0
ioctl(6, PPWDATA, 0xbf98ba80) = 0
...
ioctl(6, PPWDATA, 0xbf98ba80) = 0
ioctl(6, PPSETMODE, 0xbf98ba80) = 0
write(6, "\0", 1) = 0
write(6, "\0", 1) = 0
...
write(6, "\0", 1) = 0
write(6, "\0", 1) = 0
write(6, "\0", 1 <unfinished ...>

Finally I found that removing the 'ppdev' kernel module (rmmod ppdev) solved the problem.
This module was not automatically loaded in edgy, but I have read that it has been introduced in feisty to allow automatic detection of parallel printers.
I tried this also for an Epson Perfection 1260 (plustek backend) and it works too.
So maybe that the problem is not the 'USB selective suspend/resume and wakeup' option but the 'ppdev' kernel module.

Clay Weber (claydoh) wrote :

disabling ppdev didn't help in my case. On my canon LiDE25 9plustek, it does let e get a preview scan (as it would on occasion let me) but the scan head does not return all the way (also as would do when it would actually scan) and on a second scan attempt, it would do the ususal.

What specific command can I run, and where do I look do get strace results for comparison?

Dean Loros (autocrosser) wrote :

I also tried disabling ppdev with no positive result. It seems like there are several problems with the backends, depending on which one you need/use.

Renzo--I would think that you should open a seperate bug for your problem, and link it to this bug. I am hoping that with enough problems, we will get some "love".

Renzo Bagnati (renbag) wrote :

I used this command to get a strace dump: 'strace xsane 2&> dump.txt'
If it hangs you have to kill the process, otherways it will continue to write to the dump file.

I have also replied to another bug which was already reported for an Epson Perfection scanner:
https://bugs.launchpad.net/ubuntu/+source/sane-backends-extras/+bug/88672/

439 comments hidden view all 481 comments

Same issue with my LiDE 30, however downgrading sane-backends didn't fix it. Fixed after removing `USB selective suspend/resume and wakeup' as suggested by Achim Strobelt above. My kernel is 2.6.20.4, libusb 0.1.12.

438 comments hidden view all 481 comments
ianrose (ian-themagictree) wrote :

Bug still here on a LiDE20 - hopefully this will be fixed (or a workaround found) by release. Feisty supported ALL my hardware nicely up until the last few weeks, unlike Dapper and Edgy, so it's a bit heartbreaking to see another bit of my hardware support dropping away :(

howtoforums.net (jbaloul) wrote :

Same problem here...this is a very painful showstopper...we have multiple Cannon LiDE scanners in our organization and we cannot upgrade due to this issue.

Please help fix this before release,

Thanks,
Jacob

Thomas (thomas-pabst) wrote :

Hi,

I have the same thing here, with my canoscan lide 25.
Bus 002 Device 011: ID 04a9:2220 Canon, Inc.
is it this bug fix before release

kervel (frank-dekervel) wrote :

same problem here, with LIDE 30, and indeed scanimage cmdline works fine. i understand it is a kernel/libusb issue, but i wonder why the commandline version manages to scan.

Arthus42 (arthus42) wrote :

I have the same problem and switch backed to Edgy Eft. I´ll hope they fixe the problem, otherwise i don´t want to change to feisty wich seems to be good.

ianrose (ian-themagictree) wrote :

The kernel has gone from 2.6.20-14 to 2.6.20-15, but this regression is still unfixed - like a large number of people I bought this hardware specifically due to its mature support under linux. I don't really understand why experimental suspend/resume functionality for laptops should be allowed to break support for scanners attached to desktop machines - is it not possible for the installer to detect laptop/desktop initially, and install laptop-specific stuff like this (and NetworkManager!) only for laptops?

ianrose (ian-themagictree) wrote :

Workaround to enable GUI tools:
I can use the command line workaround mentioned earlier, but it isn't acceptable for the rest of my family. I have written a short shell script that "prods" the scanner every second and stops after around 15-20 minutes. This enables the standard GUI scanner utitlities (Kooka and so on) to work. Apologies for the quality of the solution, as I am far from a skilled technical type, however I don't think anyone is likely to sort this problem out so close to release.

1. Find the device using "lsusb":
for me:
Bus 001 Device 004: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20

so my scanner is on bus 001, device 004 - these numbers are used in the "wake-up" script as follows:

#!/bin/sh
echo "prodding scanner begins ..."
         for i in `seq 1 1000`;
        do
cat /dev/bus/usb/001/004 > /dev/null
sleep 1
        done
echo "scanner is now having a nice rest..."

save the above as "scantouch.sh". Activate the script by typing "sh scantouch.sh" - while the script is running (around 17 minutes max), the GUI scanner utilities can be used. Thanks to this horrible hack, my wife is able to get on with her work, and my ears no longer ring!

Warning: This worked for me, it might not for you, it might not be safe, there are surely better ways of doing this.

txana (wepman) on 2007-04-24
Changed in xsane:
status: Unconfirmed → Confirmed
Changed in linux:
status: Unknown → Rejected
Lionel Duval (fennec) on 2007-05-18
Changed in sane-backends:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.20:
status: Unknown → Unconfirmed
433 comments hidden view all 481 comments

I also have some problems with Mustek BearPaw 1200 when using sane-backends-1.0.18. The obtained image looks overexposed - I suspect that there are problems with calibration. Downgrading to sane-backends-1.0.17 solves this problem.

Amit Kucheria (amitk) on 2007-07-19
Changed in linux-source-2.6.22:
assignee: nobody → amitk
importance: Undecided → Medium
status: New → In Progress
Changed in linux:
status: Invalid → Fix Released
Amit Kucheria (amitk) on 2007-07-23
Changed in linux-source-2.6.22:
status: In Progress → Fix Committed
Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.20:
status: New → Fix Committed

Same problem here with this hardware:

jupiter linux # lsusb
Bus 002 Device 017: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20

If you keep the device awake with

while true; do sleep 1; cat /dev/bus/usb/002/017; done > /dev/null
(replace 002 and 017 with your bus and device id from lsusb)

you can do a preview and a full scan in e.g. kooka, but usually only one time. When it stops working, the scanning application has to be restarted. Looks like the backend or libusb cannot keep the device awake long enough.

Ideas for this found here: https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/85488

33 comments hidden view all 481 comments
Sitsofe Wheeler (sitsofe) wrote :

It looks like regularly blacklisting USB devices in the kernel will soon be at an end. According to this git commit http://git.kernel.org/?p=linux/kernel/git/gregkh/usb-2.6.git;a=commit;h=7d2c592609a7da950b458403f1936d382f38ff9c USB autosuspend will be disabled for everything bar USB hubs. I suspect those devices (or perhaps categories of devices) that do suspend can probably be dealt with by HAL and perhaps put into some sort of whitelist. Some of the discussion leading up to the change can be read on http://kerneltrap.org/Linux/Whitelists_and_Blacklists (which mentions that nearly 2/3rds of all printers can't cope with USB autosuspend).

Will this change be backported to Ubuntu Gutsy?

Brian Murray (brian-murray) wrote :

Sistofe - Thanks for tracking down the upstream kernel commit. This patch has been committed to the Gutsy kernel tree. You can view it at http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-gutsy.git;a=commit;h=e818eec4b546562fb1215a8756805eadb0c390c2 .

Ben Collins (ben-collins) wrote :

linux-source-2.6.22 (2.6.22-11.34) gutsy; urgency=low

  [Alan Stern]

  * USB: disable autosuspend by default for non-hubs
    - LP: #85488

  [Ben Collins]

  * ubuntu: Enable LEDS_TRIGGERS and related options
    - Needed for iwlwifi
  * ubuntu: Add real ABI files for virtual flavour
  * ubuntu: Re-enable missing CONFIG_SERPENT for hppa64
    - Noticed by Lamont
  * ubuntu: Add linux-headers postinst to handle hooks
    - LP: #125816
  * ubuntu: Add support for /etc/kernel/headers_postinst.d/ to
    headers-postinst
    - LP: #120049
  * cell: Add binary-custom flavour "cell" to support ps3

  [Mattia Dongili]

  * sony-laptop: restore the last user requested brightness level on
    resume.
    - LP: #117331

  [Tejun Heo]

  * ata_piix: fix suspend/resume for some TOSHIBA laptops
    - LP: #139045
  * PCI: export __pci_reenable_device()
    - needed for ata_piix change

  [Tim Gardner]

  * Enable Sierra Wireless MC8775 0x6813
    - LP: #131167

  [Zhang Rui]

  * ACPI: work around duplicate name "VID" problem on T61
    - Noted by mjg59

 -- Ben Collins <email address hidden> Sun, 16 Sep 2007 22:31:47 -0400

Markus Kienast (elias1884) wrote :

This bug would also benefit from resolving bug #3382.

1 comments hidden view all 481 comments
huffylinux (huffylinux) wrote :

After upgrading to 7.10 Gutsy, I no longer need to run the kernel that had no suspend compiled in it. My scanner is working fine.

After the initial post-upgrade restart, it did take awhile for the 1st preview to run after xsane was started. If xsane was left running, subsequent previews were as fast as usual.

Now that I shutdown and restarted, the scanner works as expected.

Eric

On Sun, 2007-10-28 at 02:13 +0000, huffy318 wrote:
> After upgrading to 7.10 Gutsy, I no longer need to run the kernel that
> had no suspend compiled in it. My scanner is working fine.
>
> After the initial post-upgrade restart, it did take awhile for the 1st
> preview to run after xsane was started. If xsane was left running,
> subsequent previews were as fast as usual.
>
> Now that I shutdown and restarted, the scanner works as expected.
>
> Eric
>

>From some bug report I got the impression, that this bug was actually
the reason for bug #88746. Is this the case?

Can somebody with the proper knowledge please advice.

Elias

dentament (elledone) wrote :

there's another workaround wich worked for me before using scanbuttond:
http://ubuntuforums.org/showpost.php?p=3126808&postcount=33

Oleksij Rempel (olerem) on 2007-11-23
Changed in libusb:
status: New → Invalid
Changed in linux-source-2.6.20:
status: New → Invalid
Markus Kienast (elias1884) wrote :

This one might actually be for the same reason:

Seagate snubs Linux
Latest drives show no visible means of support
http://www.theinquirer.net/gb/inquirer/news/2007/12/06/seagate-snubs-linux

What is reported in this article is most likely also caused by this bug. Maybe somebody starts to care now! While as seagate already pointed out, it will not be them.

Oleksij Rempel (olerem) wrote :

1. this is not a bug.
2. this report is used to collect information about usb devices which claim to support usb-suspend but do not do it correctly.

do you have this device?
if yes, please report lsusb and demsg about it.

Markus Kienast (elias1884) wrote :

I don't have this device. You should get in contact with Seagate
support. They have investigated the problem.

On Sun, 2007-12-09 at 09:42 +0000, fishor wrote:
> 1. this is not a bug.
> 2. this report is used to collect information about usb devices which claim to support usb-suspend but do not do it correctly.
>
> do you have this device?
> if yes, please report lsusb and demsg about it.
>

Robert North (russetrob) wrote :

Ok, I've reported success using the autosuspend workaround in bug #88746.
(See following comment: https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/88746/comments/188)
Now, should some of my hardware be blacklisted?
Is this now being done in kernel, or in udev rules?

I have also attached the lsusb -v output

Matt Zimmerman (mdz) on 2007-12-19
Changed in kdegraphics:
status: New → Invalid
Changed in linux-source-2.6.20:
status: Fix Committed → New
jack (ubuntu-jackh) wrote :

well, they seem to exist to manage communications with partners, but i
expect you'd worked that out!

they have an internal web site, but after a lot of verbiage it doesn't
really say any more than that.

jack

On Jan 31, 2008 10:33 AM, Bug Watch Updater -
<email address hidden><+ubuntu+jackh+509fb2199f.bugwatch#bugs.launchpad.net@
spamgourmet.com> wrote:

> ** Changed in: linux-source-2.6.20 (Debian)
> Status: Fix Committed => New
>
> --
> some usb_devices fault if usb_suspend enabled
> https://bugs.launchpad.net/bugs/85488
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

jengel (jengel-iname) wrote :

Since upgrading to Ubuntu 7.10 (kernel 2.6.22-14-generic) my Canon N1240U works perfectly. No suspend issues, no scanning black pages.

Changed in linux-source-2.6.20:
status: New → Fix Committed

This bug was marked "Fix Released" against the 2.6.22 Gutsy kernel. Just adding a note that the 2.6.20 Feisty kernel task is being closed as this does not qualify for a stable release update - https://wiki.ubuntu.com/StableReleaseUpdates . If anyone is still experiencing issues, please test against the latest Hardy Heron 8.04 Beta release and open a new bug report if the issue still exists: http://www.ubuntu.com/testing. Unfortunately, sifting through 450+ comments and 17 duplicate bug reports it not exactly easy on the development teams trying to resolve any remaining outstanding issues. Thanks.

Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
20 comments hidden view all 481 comments

Unfortunately Hewlett-Packard ScanJet 7400c also is affected by this bug.
I tried sane-backends-1.0.19 and my scanner was not working at all. I recompiled kernel without USB suspend support and still no go.
Downgraded to 1.0.17 and everything started to work.
With 1.0.18-r6 it's starts to scan but hangs in middle of A4 sheet.

~x86 2.6.24-gentoo-r4

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released

sane-backends 1.0.19 had some problems that while probing backends the epson2 backend did not properly release the device. This is fixed in 1.0.19-r2 - could you perhaps try this version?

I don't when the variable was first introduced but for canon lide25,
SANE_BACKENDS should be setted to plustek and not canon in make.conf
sane-find-scanner look for the sane db so no problem but scanimage -L needs the correct backend to be available to test the device.
This solved the problem for me.

21 comments hidden view all 481 comments

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Joshia (joshia-setiawan) wrote :

I have the same problem on my Hardy (2.6.27-7-generic). My scanner (UMAX, forgot the type) at home works perfectly without any hassles of scanning any document.

But I'm now outside my hometown and I have to scan some pictures for my homework. Here, there is an EPSON Perfection 660. Because no drivers released for Windows Vista for this model, I have been trying to use my hardy.

I just plugged it into one of my USB socket in my laptop. At first, it was unable to access the scanner at all so I installed the firmware file to "/usr/share/sane/snapscan" and input the firmware file location to the config file in "/etc/sane.d/snapscan.conf".

Then I opened Xsane. It worked fine in a few seconds when I tried to scan a book cover in Xsane, and in several seconds, Xsane was no longer able to access my scanner. I restarted Xsane but now It didn't even able to contact my scanner. Then I restarted my computer for several times and it didn't work at all.

So, I googled around and tried to install scanbuttond: No luck. Using other programs didn't give me any outcome to be able to access my scanner. I have also tried to use the command-line method "scanimage" and it produces the same error as in Xsane.

Please help me as I have to finish my work during next two weeks.

This should work for permanent settings:

sudo echo "options usbcore autosuspend=-1" > /etc/modprobe.d/usb_suspend
after this us should reboot.

this is for temporary:

sudo su
echo "-1" > /sys/module/usbcore/parameters/autosuspend

after this you need replug you scanner.

-1 mean - disable autosuspend
2 mean - enable autosuspend with delay 2 seconds

Clay Weber (claydoh) wrote :

Can we consider this bug closed?

1 comments hidden view all 481 comments

On Tue, 2010-08-03 at 21:00 +0000, Clay Weber wrote:
> Can we consider this bug closed?
>
Yes.

--
Peter Miller <email address hidden>

Martin Paulo (martin-paulo) wrote :

yes.

On 4 August 2010 07:00, Clay Weber <email address hidden> wrote:

> Can we consider this bug closed?
>
> --
> some usb_devices fault if usb_suspend enabled
> https://bugs.launchpad.net/bugs/85488
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
==================================================================

Martin Paulo, BSc.
Software Developer

Tel : +61-3-9434 2508 (Home)
Tel : 04 205 20339 (Mobile)
Site: http://www.thepaulofamily.net

"Nobody goes there any more. It's too crowded" - Yogi Berra.

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Released
Clay Weber (claydoh) on 2010-08-03
Changed in xsane:
status: Confirmed → Invalid
t2000kw (donhellen) wrote :

On Tue, 03 Aug 2010 21:00:27 -0000, you wrote:

>Can we consider this bug closed?

Yes

marvin duran (marvinduran) wrote :

yup!

<firma>
La provocación por invocación de un adjetivo insulso. Sino he caído con
besos, ¿caeré con provocaciones?
http://www.marvinduran.com
</firma>

2010/8/3 t2000kw <email address hidden>

> On Tue, 03 Aug 2010 21:00:27 -0000, you wrote:
>
> >Can we consider this bug closed?
>
> Yes
>
> --
> some usb_devices fault if usb_suspend enabled
> https://bugs.launchpad.net/bugs/85488
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Yes

On Tue, Aug 3, 2010 at 8:51 PM, marvin duran <email address hidden> wrote:

> yup!
>
> <firma>
> La provocación por invocación de un adjetivo insulso. Sino he caído con
> besos, ¿caeré con provocaciones?
> http://www.marvinduran.com
> </firma>
>
>
> 2010/8/3 t2000kw <email address hidden>
>
> > On Tue, 03 Aug 2010 21:00:27 -0000, you wrote:
> >
> > >Can we consider this bug closed?
> >
> > Yes
> >
> > --
> > some usb_devices fault if usb_suspend enabled
> > https://bugs.launchpad.net/bugs/85488
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
> --
> some usb_devices fault if usb_suspend enabled
> https://bugs.launchpad.net/bugs/85488
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Dean Loros (autocrosser) wrote :

Please close--has not been a problem for quite a while...

Jeremy Vies (jeremy.vies) wrote :

I guess so.

Le mardi 03 août 2010 à 21:00 +0000, Clay Weber a écrit :
> Can we consider this bug closed?
>

--

Changed in sane-backends (Ubuntu):
assignee: nobody → brethes (jacques-brethes)
Changed in linux:
importance: Unknown → Medium
Changed in sane-backends:
importance: Unknown → Medium
11 comments hidden view all 481 comments

I guess this is history...

Changed in sane-backends:
status: In Progress → Expired
Displaying first 40 and last 40 comments. View all 481 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.