Simple Scan with Canon LIDE50 - scan results in black page

Bug #680892 reported by jhoyne on 2010-11-24
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
sane-backends (Debian)
Fix Released
Unknown
sane-backends (Ubuntu)
Undecided
Rolf Leggewie
Nominated for Precise by Rolf Leggewie
xsane (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Rolf Leggewie

Bug Description

Binary package hint: simple-scan

It makes no difference whether scanning as Photo or Text or whether the scan resolution is 150 or 300 - the output is always a black page. The scanner makes the noises you'd expect of the scanner head moving along.

Version 2.32.0-0ubuntu4 (simple-scan)
Ubuntu 10.10

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: simple-scan 2.32.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic-pae 2.6.35.7
Uname: Linux 2.6.35-23-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Wed Nov 24 11:51:54 2010
DriverPackageVersions:
 libsane 1.0.21-2ubuntu2
 libsane-extras N/A
 hplip 3.10.6-1ubuntu10.1
 hpoj N/A
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
Lsusb:
 Bus 002 Device 005: ID 03f0:d404 Hewlett-Packard
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 010: ID 04a9:2213 Canon, Inc. CanoScan LiDE 50/LiDE 35/LiDE 40
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: FOXCONN M61PMV
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic-pae root=UUID=17835c06-fc07-4aff-81ac-02ed321c96cc ro vga=769 quiet splash nomodeset video=uvesafb:mode_option=1920x1200-24,mtrr=3,scroll=ywrap
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: simple-scan
dmi.bios.date: 07/01/2010
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: P09
dmi.board.name: M61PMV
dmi.board.vendor: FOXCONN
dmi.board.version: FAB 1.1
dmi.chassis.asset.tag: Unknow
dmi.chassis.type: 3
dmi.chassis.vendor: FOXCONN
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrP09:bd07/01/2010:svnFOXCONN:pnM61PMV:pvrFAB1.1:rvnFOXCONN:rnM61PMV:rvrFAB1.1:cvnFOXCONN:ct3:cvr:
dmi.product.name: M61PMV
dmi.product.version: FAB 1.1
dmi.sys.vendor: FOXCONN

jhoyne (john-hoyne) wrote :
Mali (mali2010) wrote :

Same here: Ubuntu 10.10, x86_64, Canon LiDE 50.

Seems to affect all programs accessing the scanner: Simple Scan, xsane, scanimage ...

Mali (mali2010) wrote :

Same on Debian Lenny, armel. Tested with scanimage (sane-backends) 1.0.21; backend version 1.0.21 ...

Mali (mali2010) wrote :

Some more details:

The armel system mentioned above is actually a Debian Squeeze system (not Lenny!) running on a Seagate Dockstar.

The original description mentions the characteristic noise. This noise is produces while the scanner head is supposed to move, but it is not really moving but standing still with the light turned on (green or alternating color, depending on the scanning mode).

The scanner was working fine until some update some weeks ago.

Robert Ancell (robert-ancell) wrote :

Reassigned to from simple-scan/xsane to sane-backends - as it affects all programs, it's a driver problem.

affects: simple-scan (Ubuntu) → sane-backends (Ubuntu)
Changed in xsane (Ubuntu):
status: New → Invalid
Mali (mali2010) wrote :

Seems to be the same as in this Debian bug report:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=594047

Mali (mali2010) wrote :

Yet another mentioning of the same behaviour on a Debian Sid system:

http://lists.alioth.debian.org/pipermail/sane-devel/2010-August/027343.html

Mali (mali2010) wrote :

I just tested some older versions of libsane:

1.0.20-13ubuntu2 works fine, 1.0.21-2ubuntu2 shows the behaviour described above ...

jhoyne (john-hoyne) wrote :

I confirm Mali's experience here also: forcing Maverick to use libsane 1.0.20-13ubuntu2 works round this bug

Chriss (neuhaus-info) wrote :

I confirm Mali's experience here also: forcing Maverick to use libsane
1.0.20-13ubuntu2 works round this bug
Simple-Scan works without a problem
1) removed libsane via apt-get (simple-scan will be removed also)
2) downloaded deb from https://launchpad.net/ubuntu/lucid/+package/libsane
3) Installed deb
4) installed simple-scan via apt-get

Mali (mali2010) wrote :

Ah, the problem seems to have gone in the most recent package from

https://launchpad.net/~stef-dev/+archive/sane-backend-genesys

Just installing libsane_1.0.22git-5ubuntu2ppa14~lucid1_amd64.deb from there seems to restore the old, working condition. I have no idea what has been changed ...

Alkis Georgopoulos (alkisg) wrote :

I confirm that the problem exists in Precise and that it is solved by installing the libsane package from Lucid
(with dpkg -i and "echo hold libsane | dpkg --set-selections).

Rolf Leggewie (r0lf) on 2013-04-12
Changed in sane-backends (Debian):
importance: Undecided → Unknown
status: New → Unknown
Rolf Leggewie (r0lf) wrote :

So, lucid was good, but maverick and later were not. How about Quantal and in particular raring? Are those affected? They've seen a new upstream release compared to precise and that release seems to have gotten many bug fixes.

Changed in sane-backends (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: New → Incomplete
Changed in sane-backends (Debian):
status: Unknown → Fix Released
Rolf Leggewie (r0lf) wrote :

The upstream Debian ticket was marked as fixed for 1.0.22-1 and confirmed fixed for 1.0.22-2 by the reporter. Alkis, I am surprised to hear you might still be affected with version 1.0.22-7ubuntu1 in precise.

Rolf Leggewie (r0lf) wrote :

jhoyne did not report back so I will close this ticket now. Please feel free to reopen if you are still affected.

Alkis, I suggest you open a new ticket since your problem might be a different issue after all.

Changed in sane-backends (Ubuntu):
status: Incomplete → Fix Released
Nino (nino-ketonen) wrote :

Argh =) HP scanjet scan results are all black.

I changed resolution and it worked once, but second scan was all black again.

Ubuntu 13.10

Nino (nino-ketonen) wrote :

And it is getting more weird.

I tried several different software's with same result and somehow when nerves was almost done, i started xsane from terminal as a root and it worked. Same thing with simple scan.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.