XSane and SANE do not maintain a proper connection with many Epson scanners

Bug #377977 reported by xteejx on 2009-05-18
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sane-backends

SANE and XSane are able to initially detect scanners listed as being supported here: http://www.sane-project.org/man/sane-epson2.5.html . However, when attempting to scan this connection is lost.

Steps to Reproduce:
1. Login
2. Connect scanner and turn it on
3. Run 'sane-find-scanner' and it is found
4. Attempt to use the scanner with XSane or 'scanimage'

Expected Results:
The software should be able to communicate with the scanner and retrieve the scanned image.

Experienced Results:
The connection to the scanner is lost by SANE.

==============
WORKAROUND (for USB scanners):
1. Run 'sudo gedit /etc/sane.d/espon2.conf'
2. Add 'usb 0x4b8 0x<device id>'
3. Save

Confirmed on Lucid 10.04 alpha 2 (see bug 521827)

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: sane-backends
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

affects: sane-frontends (Ubuntu) → sane-backends (Ubuntu)

Same bug here, printing driver detects it fine so IMHO it's sane's problem.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
alkemyst (s-mersi) wrote :

There is a simple solution to this problem.
Just add the following line to the /etc/sane.d/epson.conf file at the bottom:
usb 0x4b8 0x838

I don't have the scanner to hand at the minute will test this over the week, but either way it still needs editing into sane config files if its something as silly as 1 line, it should be easy enough to code it in.

stef33560 (stef33560) wrote :

@alkemyst : did not work :(

Cumberland (cumberlanddan) wrote :

You need to add:

usb 0x4b8 0x838

as alkemyst says but to:

/etc/sane.d/epson2.conf

Sorted.

The above did work, but I'm not sure this bug will be relevant for Lucid, I read somewhere that xsane is going to be removed in favour of something else?

Set Medium importance, Triaged, as there should be enough information here for a developer to know what to look at to enable this.

Changed in sane-backends (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
description: updated
description: updated
summary: - xsane / sane does not detect Epson DX7400
+ XSane / SANE do not maintain a proper connection with many Epson
+ scanners
description: updated
description: updated

I apologize for the bug mail spam that you may have received due to my actions. I was recently working on bug 521827 when I found this report that seemed to describe the same behavior. I also found many other similar bugs about different Epson scanner models, but they are all related to the same package. I have marked them as duplicates in order to make this easier for any SANE developers who choose to look at this report.

summary: - XSane / SANE do not maintain a proper connection with many Epson
+ XSane and SANE do not maintain a proper connection with many Epson
scanners
billowy (billowy) wrote :

Ok thank you very mush for your implication.
Just let me know if you have any news about that, ok?
Have a nice week-end.

tags: added: karmic lucid
Changed in sane-backends:
status: New → Invalid
sanfin (sanfin08) wrote :

Epson Stylus Scanner DX7400
Worked for me!
Thank you guys!

I'm having exactly the same problem with an Epson Perfection 3170 Photo. All worked on Karmic and earlier.

Meant to add that none of the above 'fixes' works for me.

Hi,
I just want to add, that also the communication via network regardless of autodetection is turned on or a fixed IP is used for the epson printer the initial communication works fine but gets interrupted with a I/O error.
The same has worked perfect with Ubuntu 8.04, which means this is a regression!

Thank you

Christian

tags: added: regression-release
Changed in sane-backends (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2011-02-21
Changed in sane-backends (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Herczeg Zsolt (zsolt94) wrote :

It's still a bug for us, in Ubuntu 10.04 (10.04.2)

Martin Pitt (pitti) wrote :

Unassigned from Canonical desktop t eam. We don't have this scanner, and unfortunately nobody of us is particularly experienced with such bugs, so I don't want to let this stay assigned forever, as this would give the wrong impression that it's being handled. I think this needs to be reported at and debugged with upstream (see http://www.sane-project.org/bugs.html). Thanks!

Hi,
I am not sure, but it looks like the sane-backend version 1.0.20 has some issue with the network implementation according to: http://comments.gmane.org/gmane.comp.graphics.scanning.sane.devel/16983
Since there is a new version available 1.0.22 would it be possible to provide this in an update?

Thank you

Christian

no longer affects: sane-backends (Ubuntu)
affects: sane-backends → sane-backends (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers