hp5590 not detected by sane on Jaunty

Bug #368172 reported by Bart on 2009-04-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Undecided
Unassigned

Bug Description

lsusb
Bus 001 Device 002: ID 03f0:1705 Hewlett-Packard ScanJet 5590

sane-find-scanner
found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x1705 [hp scanjet scanner], chip=HP5550/5590/7650) at libusb:001:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

scanimage -L
device `v4l:/dev/video0' is a Noname USB 2.0 Camera virtual device

scanimage -v -T -d hp5590
scanimage: open of device hp5590 failed: Invalid argument

xsane, gscan2pdf and other frontends are not able to find this scanner. It was working well on this laptop on hardy and Intrepid.
I tried all the commands and frontends with sudo and gksu too. Same result.

libsane 1.0.19-23ubuntu7

Is there anything else needed? Or am I doing anything wrong?

I do have the same problem on Intrepid.

sane:
  Installed: 1.0.14-6
  Candidate: 1.0.14-6
  Version table:
 *** 1.0.14-6 0
        500 http://gm.archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

libsane:
  Installed: 1.0.19-6ubuntu1
  Candidate: 1.0.19-6ubuntu1
  Version table:
 *** 1.0.19-6ubuntu1 0
        500 http://gm.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

hplip:
  Installed: 2.8.7-0ubuntu6
  Candidate: 2.8.7-0ubuntu6
  Version table:
 *** 2.8.7-0ubuntu6 0
        500 http://gm.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

libsane-hp5590 files:
-rw-r--r-- 1 root root 862 2008-05-07 08:35 /usr/lib/sane/libsane-hp5590.la
lrwxrwxrwx 1 root root 24 2008-11-24 15:03 /usr/lib/sane/libsane-hp5590.so.1 -> libsane-hp5590.so.1.0.19
-rw-r--r-- 1 root root 68096 2008-05-07 08:36 /usr/lib/sane/libsane-hp5590.so.1.0.19

Matti Viljanen (direc85) wrote :

I'm having the same problem with Ubuntu 11.10 Oneiric, server edition. Got enough of banging my head against the wall, now upgrading to 12.04 Precise... Will let you know how this ends.

Matti Viljanen (direc85) wrote :
Matti Viljanen (direc85) wrote :

Yes, it's usbfs locking the device. This is from my syslog:

usb 1-1: usbfs: interface 0 claimed by usbfs while 'scanimage' sets config #1
 usb 1-1: usbfs: interface 0 claimed by usbfs while 'sane-find-scann' sets config #1

Now, the question is: How do I unclaim the interface...?

Matti Viljanen (direc85) wrote :

Sorry, didn't mean to start spamming this bug, but after re-plugging the device the scanner gets recognized by scanimage -L...

I'll keep an eye on things, and post updates later.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed

Bart, thank you for reporting this and helping make Ubuntu better.

As per https://wiki.ubuntu.com/Releases Jaunty is EOL.

If you have an issue in a supported release (ex. 16.04) please file a new report, and feel free to subscribe me to it.

Changed in sane-backends (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.