Scanner in Epson CX-6000 multi-function detected but not available

Bug #314485 reported by Fabián Rodríguez on 2009-01-06
2
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Low
Martin Pitt
Jaunty
Low
Martin Pitt

Bug Description

The scanner function of this multi-function device is detected and listed in lsusb:

Bus 008 Device 016: ID 04b8:082e Seiko Epson Corp. 0x082e DX-60x0 MFP scanner

However xsane reports the device is not available. After adding it to epson.conf in /etc/sane.d, and restarting udev, it worked as expected.

To get it working:

1) gksudo gedit /etc/sane.d/epson.conf
Add this to the last line:
usb 0x04b8 0x082e
2) Restart the udev service or reboot:
sudo /etc/init.d/udev restart
3) Unplug and replug the scanner.

This looks similar to Bug # 184230, minus the udev rules files (not needed in this case, probably a fix recently introduced).

The sane project lists this scanner as supported with the sane-epson2 backend:
http://www.sane-project.org/sane-mfgs.html#Z-EPSON

Product page @ epson.com:
http://www.epson.com/cgi-bin/Store/consumer/consDetail.jsp?BV_UseBVCookie=yes&oid=63059192

Martin Pitt (pitti) wrote :

Seems we just have a slightly older version in intrepid which doesn't yet know it can handle this device. Easy enough to add to the backend.

Changed in sane-backends:
assignee: nobody → pitti
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.19-23ubuntu3

---------------
sane-backends (1.0.19-23ubuntu3) jaunty; urgency=low

  * Add 42_add_epson_cx_6000.dpatch: Add Epson CX6000. (LP: #314485)

 -- Martin Pitt <email address hidden> Fri, 13 Feb 2009 12:12:55 +0100

Changed in sane-backends:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers