Comment 6 for bug 236956

Jeff Kowalczyk (jfkw) wrote :

Could someone please describe and document the command-line version of the explicit grant needed so that 'scanimage|scanadf' works always for that user, even for an ssh into the machine or cron script?

Are the Ubuntu 8.04.1 /etc/udev/rules.d/45-libsane.rules a simple file-copy to install under 8.10?

If policykit is to be part of Ubuntu, then I presume the commands:

polkit-action
polkit-auth
polkit-config-file-validate
polkit-policy-file-validate

will be available on the server version as well.

Attached is a screenshot of what the users sees for granting on a default Ubuntu 8.04.1 to 8.10 upgraded desktop.

It appears that a grant must be made for each user, as groups are not available in the list for granting.

Perhaps polkit is an advantageous infrastructure decision, but it is a bit troubling that no documentation about the change in behavior is readily found in Google or Ubuntu Wiki searches. This is something that should be explicitly described to avoid surprising the user.