sane-backends ftbfs in eoan (armhf)

Bug #1843764 reported by Matthias Klose
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Fix Released
High
Robert Ancell
Eoan
Fix Released
High
Robert Ancell

Bug Description

https://launchpadlibrarian.net/441263700/buildlog_ubuntu-eoan-armhf.sane-backends_1.0.27-3.2ubuntu2_BUILDING.txt.gz

dpkg-gensymbols: warning: debian/libsane/DEBIAN/symbols doesn't match completely debian/libsane.symbols.armhf
--- debian/libsane.symbols.armhf (libsane_1.0.27_armhf)
+++ dpkg-gensymbolsHF3hxU 2019-09-09 11:12:09.992951725 +0000
@@ -4304,7 +4304,7 @@
  sanei_constrain_value@Base 1.0.25
  sanei_debug_msg@Base 1.0.25
  sanei_debug_mustek@Base 1.0.25
- sanei_debug_sanei_ab306@Base 1.0.25
+#MISSING: 1.0.27# sanei_debug_sanei_ab306@Base 1.0.25
  sanei_debug_sanei_config@Base 1.0.25
  sanei_debug_sanei_debug@Base 1.0.25
  sanei_debug_sanei_pa4s2@Base 1.0.25
@@ -5390,7 +5390,7 @@
  sanei_pp_outb_addr@Base 1.0.25
  sanei_pp_outb_ctrl@Base 1.0.25
  sanei_pp_outb_data@Base 1.0.25
- sanei_pp_outb_epp@Base 1.0.25
+#MISSING: 1.0.27# sanei_pp_outb_epp@Base 1.0.25
  sanei_pp_release@Base 1.0.25
  sanei_pp_set_datadir@Base 1.0.25
  sanei_pp_setmode@Base 1.0.25
@@ -5452,59 +5452,6 @@
  sanei_debug_sanei_config@Base 1.0.25
  sanei_debug_sanei_debug@Base 1.0.25
  sanei_init_debug@Base 1.0.25
-libsane-qcam.so.1 libsane #MINVER#
- md5_buffer@Base 1.0.27
- md5_finish_ctx@Base 1.0.27
- md5_init_ctx@Base 1.0.27
- md5_process_block@Base 1.0.27
- md5_process_bytes@Base 1.0.27
- md5_read_ctx@Base 1.0.27
- md5_stream@Base 1.0.27
- sane_cancel@Base 1.0.25
- sane_close@Base 1.0.25
- sane_control_option@Base 1.0.25
- sane_exit@Base 1.0.25
- sane_get_devices@Base 1.0.25
- sane_get_option_descriptor@Base 1.0.25
- sane_get_parameters@Base 1.0.25
- sane_get_select_fd@Base 1.0.25
- sane_init@Base 1.0.25
- sane_open@Base 1.0.25
- sane_qcam_cancel@Base 1.0.25
- sane_qcam_close@Base 1.0.25
- sane_qcam_control_option@Base 1.0.25
- sane_qcam_exit@Base 1.0.25
- sane_qcam_get_devices@Base 1.0.25
- sane_qcam_get_option_descriptor@Base 1.0.25
- sane_qcam_get_parameters@Base 1.0.25
- sane_qcam_get_select_fd@Base 1.0.25
- sane_qcam_init@Base 1.0.25
- sane_qcam_open@Base 1.0.25
- sane_qcam_read@Base 1.0.25
- sane_qcam_set_io_mode@Base 1.0.25
- sane_qcam_start@Base 1.0.25
- sane_read@Base 1.0.25
- sane_set_io_mode@Base 1.0.25
- sane_start@Base 1.0.25
- sane_strstatus@Base 1.0.25
- sanei_check_value@Base 1.0.25
- sanei_config_get_paths@Base 1.0.25
- sanei_config_get_string@Base 1.0.25
- sanei_config_open@Base 1.0.25
- sanei_config_read@Base 1.0.25
- sanei_config_skip_whitespace@Base 1.0.25
- sanei_configure_attach@Base 1.0.25
- sanei_constrain_value@Base 1.0.25
- sanei_debug_msg@Base 1.0.25
- sanei_debug_qcam@Base 1.0.25
- sanei_debug_sanei_config@Base 1.0.25
- sanei_debug_sanei_debug@Base 1.0.25
- sanei_debug_sanei_pio@Base 1.0.25
- sanei_init_debug@Base 1.0.25
- sanei_pio_close@Base 1.0.25
- sanei_pio_open@Base 1.0.25
- sanei_pio_read@Base 1.0.25
- sanei_pio_write@Base 1.0.25
 libsane-ricoh.so.1 libsane #MINVER#
  md5_buffer@Base 1.0.27
  md5_finish_ctx@Base 1.0.27
@@ -7142,7 +7089,7 @@
  sanei_constrain_value@Base 1.0.24
  sanei_debug_dll@Base 1.0.25
  sanei_debug_msg@Base 1.0.24
- sanei_debug_sanei_ab306@Base 1.0.25
+#MISSING: 1.0.27# sanei_debug_sanei_ab306@Base 1.0.25
  sanei_debug_sanei_access@Base 1.0.25
  sanei_debug_sanei_config@Base 1.0.24
  sanei_debug_sanei_debug@Base 1.0.24
@@ -7204,7 +7151,7 @@
  sanei_pp_outb_addr@Base 1.0.25
  sanei_pp_outb_ctrl@Base 1.0.25
  sanei_pp_outb_data@Base 1.0.25
- sanei_pp_outb_epp@Base 1.0.25
+#MISSING: 1.0.27# sanei_pp_outb_epp@Base 1.0.25
  sanei_pp_release@Base 1.0.25
  sanei_pp_set_datadir@Base 1.0.25
  sanei_pp_setmode@Base 1.0.25
dh_makeshlibs: failing due to earlier errors

Tags: ftbfs
Matthias Klose (doko)
Changed in sane-backends (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: ftbfs rls-ee-incoming
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Notes:

- armhf built successfully on eoan from the same source as late as 2019-08-20

- No Ubuntu/Debian delta wrt debian/libsane.symbols.armhf

Revision history for this message
Matthias Klose (doko) wrote :
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Indeed. That was merely input to the desktop team and not an objection to the bug. :)

Will Cooke (willcooke)
Changed in sane-backends (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
tags: removed: rls-ee-incoming
Revision history for this message
James Henstridge (jamesh) wrote :

Does it actually make sense to have symbols files for plugins? As long as they work with the libsane.so.1 that they're shipped with, does it matter what symbols they export?

Revision history for this message
Robert Ancell (robert-ancell) wrote :

It's indicating the some of the backends are no longer building on ARM, e.g. for qcam:

*** qcam backend requires (ioperm, inb and outb) or portaccess functions - disabling

So something changed that stops them building...

Revision history for this message
Robert Ancell (robert-ancell) wrote :

glibc removed some emulated syscalls that didn't work properly, so this is intended behaviour. Debian will have to pick up the same change when they update glibc.

Changed in sane-backends (Ubuntu Eoan):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.27-3.2ubuntu3

---------------
sane-backends (1.0.27-3.2ubuntu3) eoan; urgency=medium

  * debian/libsane.symbols.armhf:
    - Update for drivers that no longer build due to emulated syscalls being
      removed in glibc (LP: #1843764)

 -- Robert Ancell <email address hidden> Thu, 19 Sep 2019 14:08:14 +0200

Changed in sane-backends (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers