saned not working in Trusty, Utopic, or Vivid

Bug #1442956 reported by Christopher M. Peñalver
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

Following verbatim https://help.ubuntu.com/community/SaneDaemonTutorial previously worked in Trusty with my HP OfficeJet 5610v All-in-one plugged into a USB 2.0 port, where the Trusty server had a wireless interface setup as a WAP for clients to connect directly to. However, it now no longer works in Trusty when instead ethernet through a switch or via WiFi router, and doesn't work in Utopic or Vivid. For example, in Windows 8.1 with SaneTwain 1.3.6, it used to work. Now it pops up a window:
Error
No devices found on backend.

However, in the Device drop down it notes:
hpaio:/usb/Officejet_5600_series?serial=XXXXXXXXXXXXXX

Ubuntu 15.04 client with either xsane or simple-scan doesn't find anything. Running the following from a terminal results in either a crash or no SANE devices found as per https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442960 :
scanimage 192.168.1.15
scanimage: no SANE devices found

scanimage 192.168.1.15
*** Error in `scanimage': double free or corruption (!prev): 0x00007f5a939fff10 ***

The scanner works fine locally on the server via simple-scan and xsane.

Intermediary device networking being the root cause has been ruled out as I connected the server and client via ethernet through a switch, disabled wireless and still reproducible. Confirmed clients and host may ping each other.

Tried disabling ipv6 on just and both server and clients, no change.

= Trusty Server (upstart) =

+ 12.04 Client attempting to connect:
SANE_DEBUG_NET=128 SANE_DEBUG_DLL=128 scanimage -L net:192.168.1.6
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442956/+attachment/4388269/+files/SANE_DEBUG_NET%3D128%20SANE_DEBUG_DLL%3D128%20scanimage%20-L%20hpaio%3Anet%3A192.168.1.6

= Vivid Server (systemd) =

scanimage --device net:localhost
scanimage: open of device net:localhost failed: Error during device I/O

sudo systemctl restart saned.service && sudo systemctl status saned.service -l
● saned.service - Scanner Service
   Loaded: loaded (/lib/systemd/system/saned.service; static; vendor preset: enabled)
   Active: inactive (dead)

Apr 22 19:40:24 pc systemd[1]: Unit saned.service entered failed state.
Apr 22 19:40:24 pc systemd[1]: saned.service failed.
Apr 22 19:40:24 pc systemd[1]: Starting Scanner Service...
Apr 22 19:41:31 pc systemd[1]: Started Scanner Service.
Apr 22 19:41:31 pc systemd[1]: Starting Scanner Service...
Apr 22 19:41:31 pc saned[2545]: saned (AF-indep+IPv6) from sane-backends 1.0.24 starting up
Apr 22 19:41:47 pc systemd[1]: Started Scanner Service.
Apr 22 19:41:47 pc systemd[1]: Starting Scanner Service...
Apr 22 19:41:47 pc saned[2574]: saned (AF-indep+IPv6) from sane-backends 1.0.24 starting up
Apr 22 19:41:47 pc saned[2574]: check_host: access by remote host: localhost

    journalctl -xe
    Apr 22 20:04:41 pc sudo[2669]: pam_unix(sudo:session): session opened for user root by USERNAME(uid=0)
    Apr 22 20:04:41 pc polkitd(authority=local)[979]: Registered Authentication Agent for unix-process:2670:337819 (
    Apr 22 20:04:41 pc systemd[1]: Got more than one socket.
    Apr 22 20:04:41 pc systemd[1]: saned.service failed to run 'start' task: Invalid argument
    Apr 22 20:04:41 pc systemd[1]: Failed to start Scanner Service.
    -- Subject: Unit saned.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit saned.service has failed.
    --
    -- The result is failed.
    Apr 22 20:04:41 pc systemd[1]: saned.service failed.
    Apr 22 20:04:41 pc systemd[1]: Starting Scanner Service...
    -- Subject: Unit saned.service has begun start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit saned.service has begun starting up.
    Apr 22 20:04:41 pc sudo[2669]: pam_unix(sudo:session): session closed for user root

/lib/systemd/system/saned.service :
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442956/+attachment/4383859/+files/saned.service

/lib/systemd/system/saned.socket :
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442956/+attachment/4383860/+files/saned.socket

/etc/default/saned :
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442956/+attachment/4385534/+files/saned

/etc/sane.d/saned.conf :
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1442956/+attachment/4388266/+files/saned.conf

Following verbatim did not work:
https://lists.fedoraproject.org/pipermail/users/2014-December/456319.html

Related report focusing on my scanner's driver:
https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1448467

Posting as a reference, may or may not be relevant:
https://bugzilla.redhat.com/show_bug.cgi?id=1091566

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: sane-utils 1.0.24-1.1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-34.45-generic 3.16.7-ckt8
Uname: Linux 3.16.0-34-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Apr 11 14:56:27 2015
InstallationDate: Installed on 2015-04-09 (2 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: sane-backends
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.default.saned: 2015-04-11T13:29:50.323836
mtime.conffile..etc.sane.d.saned.conf: 2015-04-11T14:30:15.645215

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :
description: updated
description: updated
Changed in sane-backends (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - saned not working in Utopic
+ saned not working in Utopic or Vivid
tags: added: vivid
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
summary: - saned not working in Utopic or Vivid
+ saned not working in Trusty, Utopic, or Vivid
description: updated
description: updated
tags: added: trusty
tags: removed: regression-release
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :
description: updated
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :
description: updated
description: updated
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Works for me in Xenial via systemd. Will update documentation at https://help.ubuntu.com/community/SaneDaemonTutorial with instructions.

Changed in sane-backends (Ubuntu):
status: Triaged → Invalid
no longer affects: sane-backends
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.