Cannot scan using Canon Lide 25 with simple-scan on 14.04. on USB 3.0, USB 2.0 works

Bug #1384303 reported by Ferdinand on 2014-10-22
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
sane-backends (Ubuntu)
Undecided
Unassigned
simple-scan (Ubuntu)
Low
Unassigned

Bug Description

I do a clean install UBuntu 14.04, but unable to scan via simple-scan with error "Failed to scan, unable to start scan".
The scanner (Canon Lide 25) was detected properly on lsusb, and working fine via VirtualBox.

Previously using Lubuntu 13.10, simple-scan able to scan perfectly.

$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0612 Genesys Logic, Inc.
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 003 Device 005: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 003 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 002: ID 046d:c52e Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

apt-cache policy simple-scan
simple-scan:
  Installed: 3.12.1-0ubuntu1
  Candidate: 3.12.1-0ubuntu1
  Version table:
 *** 3.12.1-0ubuntu1 0
        500 http://id.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.12.0-0ubuntu1 0
        500 http://id.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: simple-scan 3.12.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Oct 22 22:18:36 2014
DriverPackageVersions:
 libsane 1.0.23-3ubuntu3.1
 libsane-extras N/A
 hplip 3.14.3-0ubuntu3.2
 hpoj N/A
InstallationDate: Installed on 2014-08-29 (54 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic root=UUID=6ae128c4-d0aa-401f-8057-102dea6e8953 ro quiet splash vt.handoff=7
SourcePackage: simple-scan
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/04/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P2.00
dmi.board.name: H87M-ITX
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP2.00:bd07/04/2014:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH87M-ITX:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Ferdinand (k-ferdinand) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in simple-scan (Ubuntu):
status: New → Confirmed
eezacque (eezacque) wrote :

Same problem here with CanoScan Lide 25, running Ubuntu 14.10

eezacque (eezacque) wrote :

Fixed by disabling xHCI in BIOS

Ferdinand (k-ferdinand) wrote :

Confirmed, temporary fixed by disabling usb 3.0 and connect the scanner to existing usb 2.0 port.

John Rose (johnaaronrose) wrote :

Not sure if my issue is this bug. Trusty used to be able to find & scan using Canoscan LIDE 25 on usb 2.0 port. I used to be able to scan using this scanner: last used approx 2 months ago. This also happens with XSane. HP 2540 found & useable using XSane. scanimage -L does not display the Canoscan Lide 25 scanner when HP 2540 powered off. My BIOS does not seem to have an xHCI parameter.

Paul Crawford (psc-sat) wrote :

Same problem as Ferdinand, scanner not recognised by xsane when on USB 3 port (but seen by lsusb) but worked when put on USB 2.

One USB3:
$ lsusb
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 010: ID 22b8:2e82 Motorola PCS
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

On USB2:
$ lsusb
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 010: ID 22b8:2e82 Motorola PCS
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ lsb_release -rd
Description: Ubuntu 14.04.4 LTS
Release: 14.04

$ apt-cache policy simple-scan
simple-scan:
  Installed: 3.12.3-0ubuntu1
  Candidate: 3.12.3-0ubuntu1
  Version table:
 *** 3.12.3-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.12.0-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

I expect that USB 2/3 should be transparent to any application, more so when the peripheral is going to operate in USB2 in both cases.

John Rose (johnaaronrose) wrote :

This is a regression bug as noth Simple Scan & Xsane used to work with my Canon Lide 25 scanner.

Scanner not recognised by xsane even though using USB2.

root@Desktop:/home/john# lsusb
Bus 002 Device 004: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25

root@Desktop:/home/john# lsb_release -rd
Description: Ubuntu 14.04.4 LTS
Release: 14.04

root@Desktop:/home/john# apt-cache policy xsane
xsane:
  Installed: 0.998-5ubuntu1
  Candidate: 0.998-5ubuntu1
  Version table:
 *** 0.998-5ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

root@Desktop:/home/john# apt-cache policy simple-scan
simple-scan:
  Installed: 3.12.3-0ubuntu1
  Candidate: 3.12.3-0ubuntu1
  Version table:
 *** 3.12.3-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.12.0-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Simple scan doesn't even recognise my HP2540 printer/scanner even though xsane does.

PS my user is in the Scanner group

Ferdinand, thank you for reporting this and helping make Ubuntu better.

To see if this is already resolved, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

tags: added: bios-outdated-2.40
Changed in simple-scan (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
John Rose (johnaaronrose) wrote :

I'm not going to install another version of Ubuntu to test if the bug is fixed. Bug still not fixed on 16.04: on 2 computers, one upgraded and one fresh install.

lsusb sees scanner:
Bus 001 Device 002: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25

"sudo sane-find-scanner" sees scanner:
found USB scanner (vendor=0x04a9, product=0x2220) at libusb:001:002

"sudo scanimage -L" sometimes sees scanner:
device `plustek:libusb:001:006' is a Canon CanoScan LiDE25 flatbed scanner

I have tried amending plustek.conf in /etc/sane.d by adding the 2 lines:
[usb] 0x04a9 0x2220
device and /dev/usbscanner

John Rose (johnaaronrose) wrote :

Correction: 2 lines added to /etc/sane.d/plustek.conf were:
[usb] 0x04a9 0x2220
device /dev/usbscanner

BTW the sane project shows the scanner as supported:
CanoScan LiDE25 USB 0x04a9/0x2220 Good plustek
(0.52) sane-plustek

Rolf Leggewie (r0lf) on 2016-10-22
summary: - Cannot scan using Canon Lide 25 with simple-scan on 14.04.
+ Cannot scan using Canon Lide 25 with simple-scan on 14.04. on USB 3.0,
+ USB 2.0 works
Rolf Leggewie (r0lf) wrote :

This is most likely not a bug in simple-scan but in sane-utils. Debian knows about ticket 774333 and claims the issue was fixed in sane-backends/1.0.25+git20150102-1.

Changed in debian:
status: Unknown → Fix Released
John Rose (johnaaronrose) wrote :

Not fixed in sane-utils version 1.0.25+git20150528-1ubuntu2, assuming that that is the package for sane-backends.

John Rose (johnaaronrose) wrote :

I should have said that it's the same version for libsane.

Rolf Leggewie (r0lf) wrote :

I'm not sure that everyone in this ticket is seeing the same problem. I for one do not have USB 3.0 ports. sane-find-scanner sees the scanner, but scanimage -L does not in trusty. I tested a Xenial live CD now and the scanner worked (even if producing terribly-looking images with simple-scan).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.