network scanner (pixma mg4250) not found

Bug #1346415 reported by Leonard Michlmayr on 2014-07-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Low
Unassigned

Bug Description

sane does not report the availability of the scanner although bjnp detection works.

The attached file shows the output of SANE_DEBUG_BJNP=3 SANE_DEBUG_PIXMA=11 scanimage -L

simple scan and xsane do not recognize the scanner either.

I have also tried putting the IP-address in /etc/sane.d/pixma.conf but it did not help.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libsane 1.0.23-3ubuntu3.1
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Jul 21 19:23:52 2014
InstallationDate: Installed on 2014-06-29 (22 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: sane-backends
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.sane.d.pixma.conf: 2014-07-21T19:17:43.944149

Volker (vdxbox) wrote :

Here is my workaround: Updated libsane-common and libsane to version 1.0.24 from the Ubuntu 14.10 "Utopic" repositories. Pixma MG4250 scanner on Wifi is supported out of the box. Have not tested USB connection.

Volker (vdxbox) on 2014-08-13
Changed in sane-backends (Ubuntu):
status: New → Fix Released

Following https://help.ubuntu.com/community/PinningHowto
I have updated libsane and sane-utils etc. to utopic. Now discovery works without any trouble.

Thank you for the help!

Changed in sane-backends (Ubuntu):
status: Fix Released → Fix Committed

Leonard Michlmayr, thank you for reporting this and helping make Ubuntu better.

To see if this is already resolved, could you please test for this via http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Changed in sane-backends (Ubuntu):
importance: Undecided → Low
status: Fix Committed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for sane-backends (Ubuntu) because there has been no activity for 60 days.]

Changed in sane-backends (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers