Canon LIDE 110 can only scan once, then I need to replug the usb cable

Bug #1184699 reported by jeekajoo on 2013-05-27
108
This bug affects 20 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Low
Rolf Leggewie

Bug Description

I have a Canon LIDE 110 scanner which works by default on ubuntu 13.04.
The problem is after first scan, I can not scan for second time. I need to reconnect the USB cable to use the scanner again.

# TEST 1 : without reconnecting the usb cable
francois@pc:~$ scanimage -v > test1.jpg # success
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/255
scanimage: read 562860 bytes in total
# I don't unplug plug the usb cable.
francois@pc:~$ scanimage -v > test2.jpg # FAIL
scanimage: no SANE devices found

# TEST 2 : reconnect usb cable between scan attempts
francois@pc:~$ scanimage -v > test1.jpg # success
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/255
scanimage: read 562860 bytes in total
# I unplug and replug the usb cable.
francois@pc:~$ scanimage -v > test2.jpg # SUCCESS
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/255
scanimage: read 562860 bytes in total

francois@pc:~$ dmesg # extract
[ 829.365158] usb 3-1: USB disconnect, device number 2
[ 834.935000] usb 3-1: new high-speed USB device number 4 using xhci_hcd
[ 834.952515] usb 3-1: New USB device found, idVendor=04a9, idProduct=1909
[ 834.952519] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 834.952522] usb 3-1: Product: CanoScan
[ 834.952524] usb 3-1: Manufacturer: Canon
[ 1623.738811] usb 3-1: USB disconnect, device number 4
[ 1623.739072] xhci_hcd 0000:00:14.0: Slot 3 endpoint 6 not removed from BW list!
[ 1625.528827] usb 3-1: new high-speed USB device number 5 using xhci_hcd
[ 1625.546327] usb 3-1: New USB device found, idVendor=04a9, idProduct=1909
[ 1625.546331] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1625.546334] usb 3-1: Product: CanoScan
[ 1625.546336] usb 3-1: Manufacturer: Canon

francois@pc:~$ uname -a && cat /etc/issue
Linux pc 3.8.0-22-generic #33-Ubuntu SMP Thu May 16 15:17:14 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 13.04 \n \l

The problem was reported here by someone else : http://askubuntu.com/questions/278473/canon-lide-110-should-reconnect-usb-for-each-scan

Thanks
François

Mehdi Sadeghi (mehdix) wrote :

I have exactly the same problem on ubuntu 13.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
jmxhyz (jmxhyz) wrote :

I have exactly the same problem on ubuntu 12.04 (x64).
Moreover, when ubuntu upgrade to 13.10 (libsane upgrade to 1.0.23),
the scanner does not work (the lamp can not be moved).

jeekajoo (jeekajoo) wrote :

I don't have the bug anymore in xubuntu 13.10 with kernel 3.11.0-12-generic

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Released
Tero Sillander (tsilland) wrote :

I also did not have the problem on Ubuntu 13.10, but now I do in Ubuntu 14.04. The symptoms are exactly as described above, and the scanner device is also the same, Canon LiDe 110. Libsane version 1.0.24.

Mehdi Sadeghi (mehdix) wrote :

I have recently installed 14.04 and the scanner works fine for me, even though I get "scanimage: no SANE devices found" message the "simple scan" which is provided by ubuntu can scan with no problem.

jeekajoo (jeekajoo) wrote :

no problem for me on 14.04 (3.13.0-24-generic). tested with two consecutive scans:
$ scanimage -v > test1.jpg
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/251
scanimage: read 562860 bytes in total
$ scanimage -v > test2.jpg
scanimage: scanning image of size 636x885 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/254
scanimage: read 562860 bytes in total

moimael (moimael) wrote :

I just upgraded from 13.04 to 14.04 and hit the same issue. The scanner is a canon LIDE 210, and it was working fine under 13.04.

moimael (moimael) wrote :

+3,63s] DEBUG: scanner.vala:1209: sane_start (page=0, pass=0) -> SANE_STATUS_GOOD
[+3,63s] DEBUG: scanner.vala:1226: sane_get_parameters () -> SANE_STATUS_GOOD
[+3,63s] DEBUG: scanner.vala:1238: Parameters: format=SANE_FRAME_RGB last_frame=SANE_TRUE bytes_per_line=7668 pixels_per_line=2556 lines=3543 depth=8
[+3,63s] DEBUG: simple-scan.vala:254: Page is 2556 pixels wide, 3543 pixels high, 8 bits per pixel
[+3,65s] DEBUG: simple-scan.vala:188: Getting color profile for device genesys:libusb:003:003
[+3,66s] DEBUG: simple-scan.vala:208: Unable to find colord device genesys:libusb:003:003: property match 'Serial'='sane:genesys:libusb:003:003' does not exist
[+3,75s] DEBUG: ui.vala:1739: Saving state to /home/simon/.cache/simple-scan/state
[+24,07s] DEBUG: scanner.vala:1510: Requesting redetection of scan devices
[+33,64s] DEBUG: scanner.vala:1310: sane_read (7669) -> (SANE_STATUS_IO_ERROR, 7669)
[+33,64s] WARNING: scanner.vala:1326: Unable to read frame from device: Error during device I/O
[+33,92s] DEBUG: scanner.vala:764: sane_cancel ()
[+35,74s] DEBUG: scanner.vala:767: sane_close ()
[+35,74s] DEBUG: scanner.vala:802: Processing request
[+35,84s] DEBUG: ui.vala:1739: Saving state to /home/simon/.cache/simple-scan/state
[+38,05s] DEBUG: scanner.vala:338: sane_get_devices () -> SANE_STATUS_GOOD
[+38,05s] DEBUG: scanner.vala:350: Device: name="genesys:libusb:003:003" vendor="Canon" model="LiDE 210" type="flatbed scanner"

max (macsym69) wrote :

It might be fixed for earlier versions of Ubuntu but I confirm this also affects me with:
- Scanner = Canon Lide 110
- OS = Ubuntu 14.04 up to date
- simple-scan = 3.12.1

The process to repeat the bug is:
1- scan an image and save it
2- close simple scan
3- re-open simple scan
4- simple scan just hangs and nothing happens. It looks like it doesn't see the scanner anymore.

It is important to close simple scan between scans (the bug doesn't occur if you scan multiple pages with closing simple scan). My versi

max (macsym69) wrote :

Sorry, I just noticed a mistake in my last sentence: It is important to close simple scan between scans (the bug doesn't occur if you scan multiple pages withOUT closing simple scan).

Is there a way to change this bug as "not fixed"?

max (macsym69) wrote :

I tested almost all the frontends listed on http://www.sane-project.org/sane-frontends.html on Ubuntu 14.04 (64Bit). The only one which worked correctly was Skanlite (not Scanlite). It might be because it is based on libksane (instead of libsane)?

I'd like to scan from the terminal though but it has no specific command...

max (macsym69) wrote :

Here are a few notes after some researches:

--- jeekajoo's way to debug:
$ scanimage -v > test1.jpg
$ scanimage -v > test2.jpg

is a good way because it produces the bug (so no need to have simplescan hanging and force quitting it).

--- contrary to what I wrote earlier, Skanlite is also producing errors

--- I found a solution that I described at http://askubuntu.com/questions/278473/canon-lide-110-should-reconnect-usb-for-each-scan

moimael (moimael) wrote :

For me the bug happens even if I don't close simple scan between scans. I must restart the scanner every single scan which is really annoying. Can we reopen this ? Is this a sane bug or libusb related ?

jeekajoo (jeekajoo) wrote :

I reopen this report as the bug is happening again in 14.04. See comments above.

Changed in sane-backends (Ubuntu):
status: Fix Released → Confirmed

still having the problem w Simple Scan and ubuntu 14.04 w all fixes. The problem does not happens with XSane, but after using Simple Scan also XSane does not find the scanner.
Ubuntu 14.04 (trusty) Kernel 3.13.0-24-generic (#47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014)

zasran (erik-zasran) wrote :

Is this duplicate of https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/1247371?

I have the same problem with Fujitsu S1300 scanner on Ubuntu 14.04.

moimael (moimael) wrote :

Does someone works on it ?

Peter Ebert (ptr-ebert) wrote :

I had the same problem, Canon LiDe 110 worked out of the box in Kubuntu 12.04, upgraded to 14.04 and any attempt to scan failed with an "Invalid argument" error message; but a workaround reported here ( https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/1247371 ) worked for me:

Kubuntu 14.04 3.13.0-34-generic #60-Ubuntu SMP Wed Aug 13 15:45:27 UTC 2014 x86_64
sane: 1.0.14-9

Workaround: disable "Intel xHCI Mode" in UEFI
Mainboard: Asus H97M-Plus
Canon LiDe 110 now works fine

JoeNazz (joenazz) wrote :

For me, there is no option to disable "Intel xHCI Mode" on DELL XPS notebook. So I have got the exact symptoms and no working Canon LiDE 110 scanner.

Ubuntu 12.04.5 LTS
Kernel 3.13.0-36-generic x86_64

Mauro (mauromol) wrote :

In Linux Mint 17 (Ubuntu 14.04) the situation is much worse: I can't ever scan. With Mint 16 (Ubuntu 13.10) the "invalid argument" error message just happened sometimes, now it happens almost always.
With Skanlite, it's either shown almost immediately, after a weak movement, when pressing the preview button, or after the backlight has moved from top to bottom, without returning the actual preview result.
With XSane the situation is the same, with the only difference that when the error is not given immediately, the scanner backlight runs fast from top to bottom and then hits against the bottom of the plate, while the motor keeps on trying to move it even further (the scanner makes very bad noise, I have to unplug the USB cable otherwise I fear it will get damaged).

In other words, support for this scanner is severely broken in the latest release and I think it may even damage the hardware :-(
Is there a hope that it will get fixed?

Mauro (mauromol) wrote :

I opened the following bug against SANE:
https://alioth.debian.org/tracker/index.php?func=detail&aid=314832
It ends that the bug was fixed after the 1.0.24 SANE release (Trusty comes with 1.0.23 and Utopic with 1.0.24).
It seems like this bug was fixed in RELEASE_1_0_24-213-g92e4d96, but not on RELEASE_1_0_24 tag (on which the latest 1.0.24 tar.gz and the Ubuntu packages are based).
On my own, I tested this by building from source the latest snapshot (sane-backends-git20141102) and I confirm that it seems to work reliably now!

It would be great if Ubuntu could backport the fixes for Trusty and Utopic.

halfgaar (wiebe-halfgaar) wrote :

I also have a Lide 110 that won't work the second time (bought it because my old Lide 25 broke on USB3 and the 110 was rated as 'complete support'). Sane-utils 1.0.23-3ubuntu3.1. I have Mint 17.

Michael (michaeljt) wrote :

See also bug #40682 (and note comment 21).

Jbankes1 (jbankes1) wrote :

Same issue here, It appears that after I scan one time it switches the source of the scan to another scanner on my network. The LiDe goes missing from the list. I am also using Simple Scan.

moimael (moimael) wrote :

Also hit the same issue with a Canon MP270...

brulaz (bruce-lazerte) wrote :

Version 1.025-git fixed it for me.
See: https://bugs.launchpad.net/~rolfbensch/+archive/ubuntu/sane-git/+index?field.series_filter=utopic

and do this:

sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get update
sudo apt-get upgrade

JoeNazz (joenazz) wrote :

Does not fix it for me. Same behavior.

max (macsym69) wrote :

Version 1.025-git is now working fine for me. Thanks!

Boris Boutkov (boris-boutkov) wrote :

Version 1.025-git does not fix the issue for me. ubuntu 14.04

Michael (michaeljt) wrote :

This may be fixed by commit 09daef4<1> to sane-backends. I tested a similar fix locally (actually just adding a pause using the debugger) and it worked for me.

<1> http://anonscm.debian.org/cgit/sane/sane-backends.git/commit/?id=09daef4a681e43a411b14389ceee9292ffbc29fc

Freudi74 (marco-freudenberger) wrote :

Tested with GIT sane 1.025 git, commit 425edc705e6323353bf99f58c277dc4f0fe47deb

Fixes it for me on my 110.

also see: https://alioth.debian.org/tracker/?func=detail&atid=410366&aid=314832&group_id=30186

Michael (michaeljt) wrote :

Here is a patch against Wily containing upstream commits 09daef4 and 425edc7, which fix the issue for me and Freudi74. I don't have a chance to test this properly just now. If anyone else does, please do (see the Ubuntu process<1>, as pointed out to me on #ubuntu-bugs).

<1> https://wiki.ubuntu.com/SponsorshipProcess

The attachment "This patch should fix the problems described in this ticket for at least two users." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Michael (michaeljt) wrote :

Upgraded to Wily, rebuilt with above patch and tested that simple-scan works with patch.

Marc Deslauriers (mdeslaur) wrote :

Michael,

Could you please prepare a whole debdiff for sponsoring that includes your patch, along with the required changes to debian/changelog and debian/patches/series?

Thanks!

Martin Pitt (pitti) wrote :

It is, thanks Michael! Yay for "fixing" timing issues with sleep :/ (but not your fault, of course).

Uploaded.

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Committed
Changed in simple-scan:
status: New → Invalid

Martin, it might be good to wait for more feedback before closing this. I suspect that different people may be seeing different issues, and that some might still have problems. And in defence of upstream, a short sleep does seem reasonable to me when dealing with timing issues in black box external hardware. You never know what is going in inside of it, and it could well just be that the designers never anticipated that it would have to cope with communication at the speed USB 3 allows for.

Hua Zhang (zhhuabj) wrote :

Version 1.025-git is now working fine for me as well. Thanks!

suntek (amtecson) wrote :

pls assist in fixing oour scanner not ablt to use after upgrading from 13.04 to 14.04..TY!

Changed in sane-backends (Ubuntu):
assignee: nobody → suntek (amtecson)
Dmitry (dmitrymq) wrote :

Canon Lide 210 stopped working in Ubuntu 16.04. It worked fine in 14.04. https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1588878

Tero Gusto (tero-gusto) wrote :

Thanks @brulaz, after updating the drivers I can scan more than one time with my Canon LiDE 210 scanner, and the scanner no longer "disappears". See comment #27.

halfgaar (wiebe-halfgaar) wrote :

With the PPA from #27, it's still not working correctly for me.

System: Host: melk Kernel: 3.19.0-32-generic x86_64 (64 bit) Desktop: KDE Plasma 4.14.2
           Distro: Linux Mint 17.3 Rosa
Machine: Mobo: MSI model: H170A PC MATE (MS-7971) v: 2.0 Bios: American Megatrends v: B.50 date: 01/25/2016
CPU: Quad core Intel Core i5-6500 (-MCP-) cache: 6144 KB
           clock speeds: max: 3201 MHz 1: 1100 MHz 2: 1300 MHz 3: 800 MHz 4: 2300 MHz
Graphics: Card: Intel Sky Lake Integrated Graphics
           Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.0hz, 1920x1200@60.0hz
           GLX Renderer: Mesa DRI Intel Skylake DT GT2 GLX Version: 3.0 Mesa 10.5.9
Audio: Card C-Media CMI8788 [Oxygen HD Audio] driver: snd_virtuoso Sound: ALSA v: k3.19.0-32-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 3000.6GB (7.9% used) ID-1: /dev/sda model: WDC_WD15EARS size: 1500.3GB
           ID-2: /dev/sdb model: WDC_WD15EARS size: 1500.3GB
Partition: ID-1: / size: 23G used: 6.2G (29%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: /home size: 212G used: 85G (42%) fs: ext4 dev: /dev/nvme0n1p2
RAID: Device-1: /dev/md3 - active raid: 1 components: online: 2/2 - sdb sda
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 245 Uptime: 3:40 Memory: 2168.9/15936.9MB Client: Shell (bash) inxi: 2.2.28

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0bda:0301 Realtek Semiconductor Corp. multicard reader
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 04a9:1909 Canon, Inc. CanoScan LiDE 110
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

jeekajoo, to see if this is already resolved in Ubuntu, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

no longer affects: sane-backends (Ubuntu)
affects: simple-scan → sane-backends (Ubuntu)
Changed in sane-backends (Ubuntu):
status: Invalid → New
importance: Undecided → Low
status: New → Incomplete
halfgaar (wiebe-halfgaar) wrote :

To pitch in; I use that rolfsbensch PPA, version 1.0.26-git20160803-trusty1; that is newer than their newest release of 1.0.25 (which is 11 months old...). What version does Ubuntu daily have now?

In any case, I'm still having issues with my LiDE 110, so this problem is likely not resolved. It mostly works somewhat (it sometimes stops responding), but just two days ago, it was refusing to do anything. It took me an hour of retrying and then suddenly it worked.

Rolf Leggewie (r0lf) wrote :

Just ignore whatever Christopher is doing. People were already making progress and preparing patches. No need for him to step in and get things diffused in all kinds of unproductive directions. I rather suggest to

1) verify if this is fixed in zesty (I will take what jeekajo is seeing for this ticket)
2) SRU the proposed patch as necessary
3) verify about any remaining problems and deal with them separately

Changed in sane-backends (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Rolf Leggewie (r0lf) on 2017-02-08
Changed in sane-backends (Ubuntu):
status: Incomplete → Confirmed
Rolf Leggewie (r0lf) wrote :

bug 1532582 and bug 1184699 both talk about scanning to work for only a single page

Rolf Leggewie (r0lf) wrote :

halfgaar / Rolf Leggewie, unfortunately, I wasn't aware that apport (i.e. ubuntu-bug) doesn't presently work for sane-backends, and I've filed https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1656599 about it. My bad.

Rolf Leggewie (r0lf) wrote :

@jeekajo Can you please let us know if you can verify this problem in zesty or later?

Rolf Leggewie (r0lf) wrote :

ping jeekajo

Marcus Mikulcak (mikulcak) wrote :

I can confirm that the problem persists for my Canon DR-2580 which works perfectly fine with ehci in Ubuntu 16.04 but can only scan a single page using xhci on Ubuntu 16.04 (tested on different machines: the first has a USB 2 port, the second one doesn't and connecting using a USB 2 cable doesn't help). Both run sane 1.0.27

Rolf Leggewie (r0lf) wrote :

Markus, can you test it on bionic?

Rigo (rgr) wrote :

I've just been testing this and it seems that sane / driver doesn't check for the end of track correctly when returning the scanner element to the start of the track after a scan.

This means that the scanner element gets rammed into the start of the track and you can hear the motor screaming in pain as it tries to push against an immovable object.

If you listen you will hear a high pitched humming noise at this point as the scanner desperately tries to move the optical sensor (scanner element)

I presume this triggers some sort of fail safe / over current protection which kills the scanner motor and resets the scanner. Effectively causing the behaviour everyone is observing.

This has the potential to break the motor and scanner.

On windows with MP_Navigator EX4.0 (Canon's Software) this does not happen.

Rolf Leggewie (r0lf) wrote :

I am truly sorry to have been silent for so long.

At this point, I can't do more than ask you to verify if this is still a problem with bionic and/or cosmic. I'm hoping it's fixed in a later release and then we can hopefully backport a fix.

Rolf Leggewie (r0lf) wrote :

I agree that this is a pretty serious issue (certainly for those affected), with it being capable to destroy hardware, etc.

Mauro (mauromol) wrote :

I can just report my own experience. As described in my previous comments, in Mint 17 (based on Ubuntu Trusty) I had to replace the built-in driver with one compiled from source to be able to use this scanner. I used sane-backends-git20141102 and I lived with it for some years with almost no problem (just some sporadic crashes).

I upgraded to Mint 18 (based on Xenial) just last week and yesterday I scanned a couple of pages with no issue at all, but it's a bit soon to draw conclusions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.