Ubuntu

canon pixma MP970 TPU scanning stopped working

Reported by marsteegh on 2013-01-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Medium
Unassigned

Bug Description

The scanning with the transparency unit fails consistently with 'operation was cancelled'.

I downloaded the source from http://git.debian.org/?p=sane/sane-backends.git and used git bisect to find the first failing commit.

The commit causing the bug is

9fc0ac9d1bf771510e11815a9ffad309d29e49d1

Author: Rolf Bensch <email address hidden> 2012-04-04 15:15:18
Committer: Rolf Bensch <email address hidden> 2012-04-04 15:15:18
Parent: 9c6afe1b95f47de2a9b2dd85b8f4171cc2ea0c93 (cropping y and h to scanable area in TPU mode)
Child: d723944fae0875e11e9c0b6147075d1a21b47080 (new scanners Canon Pixma MX510 and Canon Pixma MX890)
Branches: master, remotes/origin/master
Follows: RELEASE_1_0_22
Precedes: RELEASE_1_0_23

    color and grayscale negatives scan in TPU mode
    for CS8800F and CS9000F

I can see there are indeed some changes in the pixma code at this commit, but I don't know enough about the subject to see what's wrong.

It would probably be better to report it directly ion the debian bug tracker of the sane project, but I don't feel like creating *yet another* online account just to report a bug.

Rolf Bensch (rolfbensch) wrote :

Please use the attached patch to fix pixma_mp810.c.

The attachment "pixma_mp810.c.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

subscribing the sponsors team to get this uploaded. I am currently severely bandwidth-limited so I hope you will forgive me for not preparing a debdiff, but that should not be such a terrible burden for the sponsor team, I hope.

Changed in sane-backends (Ubuntu):
importance: Undecided → Medium
Rolf Bensch (rolfbensch) wrote :

I prepared a ppa for SANE daily git snapshots here: https://launchpad.net/~rolfbensch/+archive/sane-git.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.23-0ubuntu2

---------------
sane-backends (1.0.23-0ubuntu2) saucy; urgency=low

  * Apply upstream patch supplied by Rolf Bensh to fix Canon Pixma MP970 TPU
    scanning (LP: #1096612)
 -- Iain Lane <email address hidden> Tue, 21 May 2013 16:01:15 +0100

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers