Ubuntu

samba4 failed to install - ProvisioningError: guess_names: 'server role=standalone' in domain controller must match chosen server role '/etc/samba/smb.conf'! Please remove the smb.conf file and let provision generate it

Reported by James Page on 2012-02-20
84
This bug affects 12 people
Affects Status Importance Assigned to Milestone
samba4 (Debian)
Fix Released
Unknown
samba4 (Ubuntu)
High
Unassigned

Bug Description

Fresh precise chroot environment:

sudo apt-get install samba4

samba4 fails to configure:

Setting up samba4 (4.0.0~alpha17.dfsg2-1) ...
Administrator password will be set randomly!
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
ProvisioningError: guess_names: 'server role=standalone' in domain controller must match chosen server role '/etc/samba/smb.conf'! Please remove the smb.conf file and let provision generate it
dpkg: error processing samba4 (--configure):
 subprocess installed post-installation script returned error exit status 1

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: samba4 4.0.0~alpha17.dfsg2-1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: btrfs zlib_deflate libcrc32c ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs reiserfs ext2 overlayfs ip6table_filter ip6_tables ebtable_nat ebtables xt_state ipt_REJECT parport_pc xt_CHECKSUM ppdev iptable_mangle vesafb xt_tcpudp iptable_filter ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 ip_tables x_tables kvm_intel kvm bridge stp rfcomm bnep bluetooth binfmt_misc snd_hda_codec_hdmi snd_hda_codec_idt snd_usb_audio snd_hda_intel snd_hda_codec uvcvideo videodev snd_pcm v4l2_compat_ioctl32 joydev snd_seq_midi snd_hwdep snd_usbmidi_lib snd_rawmidi snd_seq_midi_event arc4 snd_seq snd_timer snd_seq_device dell_wmi snd iwlwifi psmouse i7core_edac soundcore serio_raw snd_page_alloc dell_laptop sparse_keymap mac80211 dcdbas cfg80211 coretemp edac_core fglrx mac_hid mei wmi video lp parport usb_storage hid_microsoft usbhid hid r8169 sdhci_pci sdhci
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Mon Feb 20 11:07:48 2012
SourcePackage: samba4
UpgradeStatus: No upgrade log present (probably fresh install)

James Page (james-page) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba4 (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-02-26
Changed in samba4 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
RedScourge (redscourge) wrote :

In the meantime until this is fixed, you can just mv /etc/samba/smb.conf /etc/samba/smb.conf.backup and finish the install and it should succeed.

Source:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=659775#24

Changed in samba4 (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba4 - 4.0.0~alpha18.dfsg1-4

---------------
samba4 (4.0.0~alpha18.dfsg1-4) unstable; urgency=low

  * Add patch 08_smb2_deps: Remove (unnecessary) dependencies on various
    private Samba 3 libraries, for which proper package Depends: lines were
    missing. Closes: #665295
  * Add dependency on tdb-tools. This will be removed once upstream
    removes the use of tdbbackup in provision. Closes: #664658

 -- Jelmer Vernooij <email address hidden> Wed, 28 Mar 2012 16:20:21 +0200

Changed in samba4 (Ubuntu):
status: Triaged → Fix Released
Changed in samba4 (Debian):
status: New → Fix Released

Ran aptitude install samba4 and got the same error messages on a clean install of ubuntu 12.04. This was for samba4-alpha 18 I believe. No debs were installed/added to apt-get prior to running install.

Adding output of apt-get install samba4 samba4-clients

Reading package lists...
Building dependency tree...
Reading state information...
Suggested packages:
  phpldapadmin samba-gtk swat2
The following NEW packages will be installed:
  samba4 samba4-clients
Preconfiguring packages ...
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,710 kB of archives.
After this operation, 11.4 MB of additional disk space will be used.
Selecting previously unselected package samba4.
(Reading database ... 32430 files and directories currently installed.)
Unpacking samba4 (from .../samba4_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package samba4-clients.
Unpacking samba4-clients (from .../samba4-clients_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up samba4 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
ERROR: Invalid smb.conf
ERROR: Invalid smb.conf
/var/lib/dpkg/info/samba4.postinst: 14: /var/lib/dpkg/info/samba4.postinst: /usr/share/samba/setoption.pl: Permission denied
dpkg: error processing samba4 (--configure):
 subprocess installed post-installation script returned error exit status 126

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.