missing libraries for samba.samba3 python module

Bug #889869 reported by Claudio Luck on 2011-11-13
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
samba4 (Ubuntu)
High
Jelmer Vernooij

Bug Description

This is on Ubuntu Precise 12.04

samba4:
  Installed: 4.0.0~alpha17.dfsg1-2
  Candidate: 4.0.0~alpha17.dfsg1-2
  Version table:
 *** 4.0.0~alpha17.dfsg1-2 0
        500 http://ch.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status
python-samba:
  Installed: 4.0.0~alpha17.dfsg1-2
  Candidate: 4.0.0~alpha17.dfsg1-2
  Version table:
 *** 4.0.0~alpha17.dfsg1-2 0
        500 http://ch.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status
samba4-common-bin:
  Installed: 4.0.0~alpha17.dfsg1-2
  Candidate: 4.0.0~alpha17.dfsg1-2
  Version table:
 *** 4.0.0~alpha17.dfsg1-2 0
        500 http://ch.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Traceback (most recent call last):
  File "/usr/sbin/samba-tool", line 30, in <module>
    from samba.netcmd.domain import cmd_domain
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/domain.py", line 44, in <module>
    from samba.samba3 import Samba3
  File "/usr/lib/python2.7/dist-packages/samba/samba3/__init__.py", line 29, in <module>
    import passdb
ImportError: libutil_str.so: cannot open shared object file: No such file or directory

(This comes after working around Bug #889864)

Jelmer Vernooij (jelmer) on 2011-11-13
Changed in samba4 (Ubuntu):
status: New → Triaged
importance: Undecided → High
Claudio Luck (cluck) wrote :

Compiled with this patch, now gives: ImportError: libdbwrap.so: cannot open shared object file: No such file or directory

.build file has a matching dpkg-shlibdeps warning for libpdb.so and libsmbconf.so.0:

dpkg-shlibdeps: warning: couldn't find library libdbwrap.so needed by debian/python-samba/usr/lib/x86_64-linux-gnu/samba/libpdb.so (ELF format: 'elf64-x86-64'; RPATH: '/usr/lib/x86_64-linux-gnu/samba').
dpkg-shlibdeps: warning: couldn't find library libdbwrap.so needed by debian/python-samba/usr/lib/x86_64-linux-gnu/libsmbconf.so.0 (ELF format: 'elf64-x86-64'; RPATH: '/usr/lib/x86_64-linux-gnu/samba').

And there are more missing libraries:

For debian/python-samba/usr/lib/x86_64-linux-gnu/libsmbconf.so.0:

libCHARSET3.so
libdbwrap.so
libsmbd_conn.so
libsmbd_shim.so
libsmbregistry.so
libstring_init.so
libtdb_compat.so
libutil_malloc.so
libutil_sec.so

For debian/python-samba/usr/lib/x86_64-linux-gnu/samba/libpdb.so:

libsmbd_shim.so
libsmbregistry.so
libdbwrap.so

summary: - python-samba uses libutil_str.so which no package provides
+ missing libraries for samba.samba3 python module
Claudio Luck (cluck) wrote :

With the latest patch I now get samba-tool working after compiling with dpkg-buildpackage -us -uc and following
the dance in Bug #832465 to install samba4, then manually locating the following libraries in the just built sources
and copying them to /usr/lib/x86_64-linux-gnu/samba/:

libkdc-policy.so
libCHARSET3.so
libadt_tree.so
libnamearray.so

After this the samba-tool manages to display it's help text when called without options.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba4 - 4.0.0~alpha17.dfsg2-1

---------------
samba4 (4.0.0~alpha17.dfsg2-1) unstable; urgency=low

  * Remove more non-free IETF files. Closes: #547280
  * Rebuild for newer version of ldb.

 -- Jelmer Vernooij <email address hidden> Sat, 03 Dec 2011 01:41:49 +0100

Changed in samba4 (Ubuntu):
status: Triaged → Fix Released
Claudio Luck (cluck) wrote :

This is not fixed yet, these three libraries are still not installed:

libCHARSET3.so
libadt_tree.so
libnamearray.so

Thus loading samba.samba3 fails after install. E.g.:

# python -c 'import samba.samba3'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/samba/samba3/__init__.py", line 29, in <module>
    import passdb
ImportError: libnamearray.so: cannot open shared object file: No such file or directory

Claudio Luck (cluck) on 2011-12-04
Changed in samba4 (Ubuntu):
status: Fix Released → New
Jelmer Vernooij (jelmer) wrote :

Hmm, I'm not sure why the janitor tried to mark it as fixreleased.

This is an upstream bug btw, and one that should be fixed with the next upstream release. libCHARSET3.so isn't installed by upstream at all in alpha17.

Changed in samba4 (Ubuntu):
status: New → Triaged
Jelmer Vernooij (jelmer) on 2012-03-12
Changed in samba4 (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba4 - 4.0.0~alpha18.dfsg1-4

---------------
samba4 (4.0.0~alpha18.dfsg1-4) unstable; urgency=low

  * Add patch 08_smb2_deps: Remove (unnecessary) dependencies on various
    private Samba 3 libraries, for which proper package Depends: lines were
    missing. Closes: #665295
  * Add dependency on tdb-tools. This will be removed once upstream
    removes the use of tdbbackup in provision. Closes: #664658

 -- Jelmer Vernooij <email address hidden> Wed, 28 Mar 2012 16:20:21 +0200

Changed in samba4 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers