testparm.samba4 crashed with ImportError in <module>()

Bug #641082 reported by Verdomde on 2010-09-17
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
samba4 (Ubuntu)
Undecided
Jelmer Vernooij

Bug Description

Binary package hint: samba4

upon startup

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: samba4-common-bin 4.0.0~alpha13+git+bzr12984.dfsg1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Sep 17 07:55:55 2010
ExecutablePath: /usr/bin/testparm.samba4
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/bin/testparm -s --parameter-name=disable\ netbios
ProcEnviron: PATH=(custom, no user)
PythonArgs: ['/usr/bin/testparm', '-s', '--parameter-name=disable netbios']
SourcePackage: samba4
Title: testparm.samba4 crashed with ImportError in <module>()
UserGroups:

Related branches

Verdomde (frog-yawn) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Liam Dunn (ldunn) wrote :

Successfully reproduced here.

Changed in samba4 (Ubuntu):
status: New → Confirmed
Verdomde (frog-yawn) on 2011-01-21
description: updated
Jelmer Vernooij (jelmer) wrote :

Missing dependency on python-samba.

Changed in samba4 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) wrote :

Fix committed to the Debian branch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba4 - 4.0.0~alpha15~git20110124.dfsg1-2ubuntu1

---------------
samba4 (4.0.0~alpha15~git20110124.dfsg1-2ubuntu1) natty; urgency=low

  * Add missing dependency on python-samba, required for testparm. LP: #641082
  * Add 03_wbclient.diff: Use system-packaged libwbclient.
   + Back out the new 'dc-info' command in wbinfo as libwbclient0 lacks some
     required symbols.
   + Solves unable to load libwbclient.so.0 errors. LP: #714344
  * Make sure /var/run/samba exists. LP: #646037
  * Add 04_setlocale.diff: Cherry-pick upstream fix to avoid setlocale() calls
    when used as a library. LP: #519025, #519025
  * Use system ldb headers so modules get built with the system ldb version.
 -- Jelmer Vernooij <email address hidden> Sun, 27 Feb 2011 18:06:26 +0100

Changed in samba4 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers